mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH iproute2-next v1 0/6] iplink_can: preparation before introduction of CAN XL
@ 2024-11-12 17:27 Vincent Mailhol
  2024-11-12 17:27 ` [PATCH iproute2-next v1 1/6] iplink_can: remove unused FILE *f parameter in three functions Vincent Mailhol
                   ` (6 more replies)
  0 siblings, 7 replies; 8+ messages in thread
From: Vincent Mailhol @ 2024-11-12 17:27 UTC (permalink / raw)
  To: netdev, Stephen Hemminger, David Ahern, linux-can,
	Marc Kleine-Budde, Oliver Hartkopp
  Cc: Robert Nawrath, linux-kernel, Vincent Mailhol

An RFC was sent last weekend to kick-off the discussion of the
introduction of CAN XL: [1] for the kernel side and [2] for the
iproute2 interface. While the series received some positive feedback,
it is far from completion. Some work is still needed to:

  - adjust the nesting of the IFLA_CAN_XL_DATA_BITTIMING_CONST in the
    netlink interface

  - add the CAN XL PWM configuration

and this TODO list may grow if more feedback is received.

Regardless of this, the RFC started with a set of trivial patches to
do some clean-up and some renaming in preparation of the introduction
of CAN XL.

This series just contains those preparation patches which were cherry
picked from the RFC.

The goal is to have those merged first to remove some overhead from
the netlink CAN XL main series before tacking care of the other
comments.

[1] [RFC] can: netlink: add CAN XL
Link: https://lore.kernel.org/linux-can/20241110155902.72807-16-mailhol.vincent@wanadoo.fr/

[2] [RFC] iplink_can: add CAN XL
Link: https://lore.kernel.org/linux-can/20241110160406.73584-10-mailhol.vincent@wanadoo.fr/

Vincent Mailhol (6):
  iplink_can: remove unused FILE *f parameter in three functions
  iplink_can: reduce the visibility of tdc in can_parse_opt()
  iplink_can: remove newline at the end of invarg()'s messages
  iplink_can: use invarg() instead of fprintf()
  iplink_can: add struct can_tdc
  iplink_can: rename dbt into fd_dbt in can_parse_opt()

 ip/iplink_can.c | 107 +++++++++++++++++++++++++-----------------------
 1 file changed, 56 insertions(+), 51 deletions(-)

-- 
2.45.2


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2024-11-18 17:00 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-11-12 17:27 [PATCH iproute2-next v1 0/6] iplink_can: preparation before introduction of CAN XL Vincent Mailhol
2024-11-12 17:27 ` [PATCH iproute2-next v1 1/6] iplink_can: remove unused FILE *f parameter in three functions Vincent Mailhol
2024-11-12 17:27 ` [PATCH iproute2-next v1 2/6] iplink_can: reduce the visibility of tdc in can_parse_opt() Vincent Mailhol
2024-11-12 17:27 ` [PATCH iproute2-next v1 3/6] iplink_can: remove newline at the end of invarg()'s messages Vincent Mailhol
2024-11-12 17:27 ` [PATCH iproute2-next v1 4/6] iplink_can: use invarg() instead of fprintf() Vincent Mailhol
2024-11-12 17:27 ` [PATCH iproute2-next v1 5/6] iplink_can: add struct can_tdc Vincent Mailhol
2024-11-12 17:27 ` [PATCH iproute2-next v1 6/6] iplink_can: rename dbt into fd_dbt in can_parse_opt() Vincent Mailhol
2024-11-18 17:00 ` [PATCH iproute2-next v1 0/6] iplink_can: preparation before introduction of CAN XL patchwork-bot+netdevbpf

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®