mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [GIT PULL] ACPI updates for v6.14-rc1
@ 2025-01-20 21:05 Rafael J. Wysocki
  2025-01-22 19:41 ` pr-tracker-bot
  0 siblings, 1 reply; 2+ messages in thread
From: Rafael J. Wysocki @ 2025-01-20 21:05 UTC (permalink / raw)
  To: Linus Torvalds
  Cc: ACPI Devel Maling List, Linux PM, Linux Kernel Mailing List

Hi Linus,

Please pull from the tag

 git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git \
 acpi-6.14-rc1

with top-most commit d1ddf94665c6805a63659ab0b09ef626ecc2b0b2

 Merge branches 'acpi-battery', 'acpi-fan' and 'acpi-misc'

on top of commit 14578923e8c251091d2bb8a2756cde3b662ac316

 ACPI: video: Fix random crashes due to bad kfree()

to receive ACPI updates for 6.14-rc1.

The most significant change here is replacing msleep() in acpi_os_sleep()
with usleep_range() to reduce spurious sleep time due to timer inaccuracy
which may spectacularly reduce the duration of system suspend and resume
transitions on some systems.

All of the other changes fall into the fixes and cleanups category this
time.

Specifics:

 - Use usleep_range() instead of msleep() in acpi_os_sleep() to reduce
   excessive delays due to timer inaccuracy, mostly affecting system
   suspend and resume (Rafael Wysocki).

 - Use str_enabled_disabled() string helpers in the ACPI tables parsing
   code to make it easier to follow (Sunil V L).

 - Update device properties parsing on systems using ACPI so that
   data firmware nodes resulting from _DSD evaluation are treated
   as available in firmware nodes walks (Sakari Ailus).

 - Fix missing guid_t declaration in linux/prmt.h (Robert Richter).

 - Update the GHES handling code to follow the global panic= policy
   instead of overriding it by force-rebooting the system after a
   fatal HW error has been reported (Borislav Petkov).

 - Update messages printed by the ACPI battery driver to always
   refer to driver extensions as "hooks" to avoid confusion with
   similar functionality in the power supply subsystem in the
   future (Thomas Weißschuh).

 - Fix .probe() error path cleanup in the ACPI fan driver to avoid
   memory leaks (Joe Hattori).

 - Constify 'struct bin_attribute' in some places in the ACPI subsystem
   and mark it as __ro_after_init in one place to prevent binary blob
   attributes from being updated (Thomas Weißschuh)

 - Add empty stubs for several ACPI-related symbols so that they can be
   used when CONFIG_ACPI is unset and use them for removing unnecessary
   conditional compilation from the ipu-bridge driver (Ricardo Ribalda).

Thanks!


---------------

Borislav Petkov (1):
      APEI: GHES: Have GHES honor the panic= setting

Joe Hattori (1):
      ACPI: fan: cleanup resources in the error path of .probe()

Rafael J. Wysocki (1):
      ACPI: OSL: Use usleep_range() in acpi_os_sleep()

Ricardo Ribalda (7):
      ACPI: bus: change the prototype for acpi_get_physical_device_location
      ACPI: bus: implement for_each_acpi_dev_match when !ACPI
      ACPI: bus: implement acpi_get_physical_device_location when !ACPI
      ACPI: header: implement acpi_device_handle when !ACPI
      ACPI: bus: implement for_each_acpi_consumer_dev when !ACPI
      ACPI: bus: implement acpi_device_hid when !ACPI
      media: ipu-bridge: Remove unneeded conditional compilations

Robert Richter (1):
      ACPI: PRM: Fix missing guid_t declaration in linux/prmt.h

Sakari Ailus (1):
      ACPI: property: Consider data nodes as being available

Sunil V L (1):
      ACPI: tables: Use string choice helpers

Thomas Weißschuh (4):
      ACPI: BGRT: Mark bin_attribute as __ro_after_init
      ACPI: BGRT: Constify 'struct bin_attribute'
      ACPI: sysfs: Constify 'struct bin_attribute'
      ACPI: battery: Rename extensions to hook in messages

---------------

 drivers/acpi/apei/ghes.c             | 10 +++++-----
 drivers/acpi/battery.c               | 14 +++++++-------
 drivers/acpi/bgrt.c                  |  6 +++---
 drivers/acpi/fan_core.c              | 10 ++++++++--
 drivers/acpi/mipi-disco-img.c        |  3 +--
 drivers/acpi/osl.c                   | 22 +++++++++++++++++++++-
 drivers/acpi/property.c              |  2 +-
 drivers/acpi/scan.c                  |  4 +---
 drivers/acpi/sysfs.c                 |  8 ++++----
 drivers/acpi/tables.c                | 12 ++++++------
 drivers/acpi/utils.c                 |  7 +++----
 drivers/base/physical_location.c     |  4 +---
 drivers/media/pci/intel/ipu-bridge.c | 29 ++++-------------------------
 drivers/usb/core/usb-acpi.c          |  3 +--
 include/acpi/acpi_bus.h              | 23 ++++++++++++++++++++---
 include/linux/acpi.h                 |  5 +++++
 include/linux/prmt.h                 |  2 ++
 17 files changed, 93 insertions(+), 71 deletions(-)

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [GIT PULL] ACPI updates for v6.14-rc1
  2025-01-20 21:05 [GIT PULL] ACPI updates for v6.14-rc1 Rafael J. Wysocki
@ 2025-01-22 19:41 ` pr-tracker-bot
  0 siblings, 0 replies; 2+ messages in thread
From: pr-tracker-bot @ 2025-01-22 19:41 UTC (permalink / raw)
  To: Rafael J. Wysocki
  Cc: Linus Torvalds, ACPI Devel Maling List, Linux PM,
	Linux Kernel Mailing List

The pull request you sent on Mon, 20 Jan 2025 22:05:56 +0100:

> git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git acpi-6.14-rc1

has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/603f162a02d5ccf0b3c5b2c6f488e456be81007f

Thank you!

-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/prtracker.html

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2025-01-22 19:40 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-01-20 21:05 [GIT PULL] ACPI updates for v6.14-rc1 Rafael J. Wysocki
2025-01-22 19:41 ` pr-tracker-bot

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®