mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Sean Christopherson <seanjc@google.com>
To: Sean Christopherson <seanjc@google.com>,
	Paolo Bonzini <pbonzini@redhat.com>,
	 Vishal Verma <vishal.l.verma@intel.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
	 Binbin Wu <binbin.wu@linxu.intel.com>,
	Rick Edgecombe <rick.p.edgecombe@intel.com>
Subject: Re: [PATCH v2 0/4] KVM: TDX: Cleanup the kvm_x86_ops structure for vmx/tdx
Date: Fri,  2 May 2025 14:51:07 -0700	[thread overview]
Message-ID: <174622213091.880948.13355437272012240115.b4-ty@google.com> (raw)
In-Reply-To: <20250318-vverma7-cleanup_x86_ops-v2-0-701e82d6b779@intel.com>

On Tue, 18 Mar 2025 00:35:05 -0600, Vishal Verma wrote:
> This is a cleanup that should follow the initial TDX base support (i.e.
> not an immediate fix needed for kvm-coco-queue).
> 
> Patch 1 is a precursory fix for a build warning/error found when
> manually testing the CONFIG_INTEL_TDX_HOST=n case.
> 
> For Patches 2-4:
> 
> [...]

Applied 2-4 to kvm-x86 vmx, with Chao's feedback incorporated, along with a few
other minor cleanups.

[1/4] KVM: TDX: Fix definition of tdx_guest_nr_guest_keyids()
      (no commit info)
[2/4] KVM: VMX: Move apicv_pre_state_restore to posted_intr.c
      https://github.com/kvm-x86/linux/commit/84ad4d834ce9
[3/4] KVM: VMX: Make naming consistent for kvm_complete_insn_gp via define
      https://github.com/kvm-x86/linux/commit/1a81d9d5a1da
[4/4] KVM: VMX: Clean up and macrofy x86_ops
      https://github.com/kvm-x86/linux/commit/907092bf7cbd

--
https://github.com/kvm-x86/linux/tree/next

      parent reply	other threads:[~2025-05-02 21:53 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-18  6:35 Vishal Verma
2025-03-18  6:35 ` [PATCH v2 1/4] KVM: TDX: Fix definition of tdx_guest_nr_guest_keyids() Vishal Verma
2025-03-18 15:33   ` Edgecombe, Rick P
2025-03-18 16:31     ` Verma, Vishal L
2025-03-18  6:35 ` [PATCH v2 2/4] KVM: VMX: Move apicv_pre_state_restore to posted_intr.c Vishal Verma
2025-04-29  8:17   ` Chao Gao
2025-04-29 17:25     ` Verma, Vishal L
2025-03-18  6:35 ` [PATCH v2 3/4] KVM: VMX: Make naming consistent for kvm_complete_insn_gp via define Vishal Verma
2025-03-18  6:35 ` [PATCH v2 4/4] KVM: VMX: Clean up and macrofy x86_ops Vishal Verma
2025-05-02 21:51 ` Sean Christopherson [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=174622213091.880948.13355437272012240115.b4-ty@google.com \
    --to=seanjc@google.com \
    --cc=binbin.wu@linxu.intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pbonzini@redhat.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®