mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Verma, Vishal L" <vishal.l.verma@intel.com>
To: "pbonzini@redhat.com" <pbonzini@redhat.com>,
	"seanjc@google.com" <seanjc@google.com>,
	"Edgecombe, Rick P" <rick.p.edgecombe@intel.com>
Cc: "kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"binbin.wu@linxu.intel.com" <binbin.wu@linxu.intel.com>
Subject: Re: [PATCH v2 1/4] KVM: TDX: Fix definition of tdx_guest_nr_guest_keyids()
Date: Tue, 18 Mar 2025 16:31:29 +0000	[thread overview]
Message-ID: <190c81a8159447ee527b7367051f932e5dfd08bb.camel@intel.com> (raw)
In-Reply-To: <5a9335bdf4fbfef9d34c448d1bd8f075e56f82bc.camel@intel.com>

On Tue, 2025-03-18 at 15:33 +0000, Edgecombe, Rick P wrote:
> On Tue, 2025-03-18 at 00:35 -0600, Vishal Verma wrote:
> > When CONFIG_INTEL_TDX_HOST=n, the above definition produced an
> > unused-function warning with gcc.
> > 
> >   error: ‘tdx_get_nr_guest_keyids’ defined but not used [-
> > Werror=unused-function]
> >     198 | static u32 tdx_get_nr_guest_keyids(void) { return 0; }
> >         |            ^~~~~~~~~~~~~~~~~~~~~~~
> > 
> > Make the definition 'inline' so that in the config disabled case,
> > the
> > whole thing can be optimized away.
> 
> This looks to be fixed in the current kvm-coco-queue. Can you double
> check?
> 
> 
Indeed it is, I will drop it for the next revision.

  reply	other threads:[~2025-03-18 16:32 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-18  6:35 [PATCH v2 0/4] KVM: TDX: Cleanup the kvm_x86_ops structure for vmx/tdx Vishal Verma
2025-03-18  6:35 ` [PATCH v2 1/4] KVM: TDX: Fix definition of tdx_guest_nr_guest_keyids() Vishal Verma
2025-03-18 15:33   ` Edgecombe, Rick P
2025-03-18 16:31     ` Verma, Vishal L [this message]
2025-03-18  6:35 ` [PATCH v2 2/4] KVM: VMX: Move apicv_pre_state_restore to posted_intr.c Vishal Verma
2025-04-29  8:17   ` Chao Gao
2025-04-29 17:25     ` Verma, Vishal L
2025-03-18  6:35 ` [PATCH v2 3/4] KVM: VMX: Make naming consistent for kvm_complete_insn_gp via define Vishal Verma
2025-03-18  6:35 ` [PATCH v2 4/4] KVM: VMX: Clean up and macrofy x86_ops Vishal Verma
2025-05-02 21:51 ` [PATCH v2 0/4] KVM: TDX: Cleanup the kvm_x86_ops structure for vmx/tdx Sean Christopherson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=190c81a8159447ee527b7367051f932e5dfd08bb.camel@intel.com \
    --to=vishal.l.verma@intel.com \
    --cc=binbin.wu@linxu.intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pbonzini@redhat.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=seanjc@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®