mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "tip-bot2 for Dave Martin" <tip-bot2@linutronix.de>
To: linux-tip-commits@vger.kernel.org
Cc: Dave Martin <Dave.Martin@arm.com>,
	James Morse <james.morse@arm.com>,
	"Borislav Petkov (AMD)" <bp@alien8.de>,
	Reinette Chatre <reinette.chatre@intel.com>,
	Fenghua Yu <fenghuay@nvidia.com>,
	Peter Newman <peternewman@google.com>,
	Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>,
	Amit Singh Tomar <amitsinght@marvell.com>,
	Shanker Donthineni <sdonthineni@nvidia.com>,
	Babu Moger <babu.moger@amd.com>, Tony Luck <tony.luck@intel.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org
Subject: [tip: x86/cache] x86/resctrl: Relax some asm #includes
Date: Sat, 17 May 2025 10:02:49 -0000	[thread overview]
Message-ID: <174747616981.406.4962690696174848120.tip-bot2@tip-bot2> (raw)
In-Reply-To: <20250515165855.31452-23-james.morse@arm.com>

The following commit has been merged into the x86/cache branch of tip:

Commit-ID:     b7b57edbf5681c7d0ed504a3a4e912bb68661ab9
Gitweb:        https://git.kernel.org/tip/b7b57edbf5681c7d0ed504a3a4e912bb68661ab9
Author:        Dave Martin <Dave.Martin@arm.com>
AuthorDate:    Thu, 15 May 2025 16:58:52 
Committer:     Borislav Petkov (AMD) <bp@alien8.de>
CommitterDate: Fri, 16 May 2025 14:34:31 +02:00

x86/resctrl: Relax some asm #includes

checkpatch.pl identifies some direct #includes of asm headers that
can be satisfied by including the corresponding <linux/...> header
instead.

Fix them.

No intentional functional change.

Signed-off-by: Dave Martin <Dave.Martin@arm.com>
Signed-off-by: James Morse <james.morse@arm.com>
Signed-off-by: Borislav Petkov (AMD) <bp@alien8.de>
Reviewed-by: Reinette Chatre <reinette.chatre@intel.com>
Reviewed-by: Fenghua Yu <fenghuay@nvidia.com>
Tested-by: Fenghua Yu <fenghuay@nvidia.com>
Tested-by: Peter Newman <peternewman@google.com>
Tested-by: Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>
Tested-by: Amit Singh Tomar <amitsinght@marvell.com> # arm64
Tested-by: Shanker Donthineni <sdonthineni@nvidia.com> # arm64
Tested-by: Babu Moger <babu.moger@amd.com>
Tested-by: Tony Luck <tony.luck@intel.com>
Link: https://lore.kernel.org/20250515165855.31452-23-james.morse@arm.com
---
 arch/x86/kernel/cpu/resctrl/pseudo_lock.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
index db0b75b..bb39ffd 100644
--- a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
+++ b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
@@ -11,6 +11,8 @@
 
 #define pr_fmt(fmt)	KBUILD_MODNAME ": " fmt
 
+#include <linux/cacheflush.h>
+#include <linux/cacheinfo.h>
 #include <linux/cpu.h>
 #include <linux/cpumask.h>
 #include <linux/debugfs.h>
@@ -22,7 +24,6 @@
 #include <linux/slab.h>
 #include <linux/uaccess.h>
 
-#include <asm/cacheflush.h>
 #include <asm/cpu_device_id.h>
 #include <asm/perf_event.h>
 

  reply	other threads:[~2025-05-17 10:02 UTC|newest]

Thread overview: 56+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-05-15 16:58 [PATCH v12 00/25] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-05-15 16:58 ` [PATCH v12 01/25] cpumask: relax cpumask_any_but() James Morse
2025-05-17 10:03   ` [tip: x86/cache] cpumask: Relax cpumask_any_but() tip-bot2 for Yury Norov [NVIDIA]
2025-05-15 16:58 ` [PATCH v12 02/25] find: add find_first_andnot_bit() James Morse
2025-05-17 10:03   ` [tip: x86/cache] find: Add find_first_andnot_bit() tip-bot2 for Yury Norov [NVIDIA]
2025-05-15 16:58 ` [PATCH v12 03/25] cpumask: add cpumask_{first,next}_andnot() API James Morse
2025-05-17 10:03   ` [tip: x86/cache] cpumask: Add " tip-bot2 for Yury Norov [NVIDIA]
2025-05-15 16:58 ` [PATCH v12 04/25] x86/resctrl: Optimize cpumask_any_housekeeping() James Morse
2025-05-17 10:03   ` [tip: x86/cache] " tip-bot2 for Yury Norov [NVIDIA]
2025-05-15 16:58 ` [PATCH v12 05/25] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-05-17 10:03   ` [tip: x86/cache] " tip-bot2 for Amit Singh Tomar
2025-05-15 16:58 ` [PATCH v12 06/25] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-05-17 10:03   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 07/25] x86/resctrl: Check all domains are offline in resctrl_exit() James Morse
2025-05-17 10:03   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 08/25] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-05-17 10:03   ` [tip: x86/cache] x86/resctrl: Resctrl_exit() " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 09/25] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-05-17 10:03   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 10/25] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-05-17 10:03   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 11/25] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 12/25] x86/resctrl: Expand the width of domid by replacing mon_data_bits James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 13/25] x86/resctrl: Split trace.h James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 14/25] x86/resctrl: Add 'resctrl' to the title of the resctrl documentation James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 15/25] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 16/25] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 17/25] x86/resctrl: Move enum resctrl_event_id to resctrl.h James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 18/25] x86/resctrl: Fix types in resctrl_arch_mon_ctx_{alloc,free}() stubs James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 19/25] x86/resctrl: Move pseudo lock prototypes to include/linux/resctrl.h James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 20/25] x86/resctrl: Squelch whitespace anomalies in resctrl core code James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for Dave Martin
2025-05-15 16:58 ` [PATCH v12 21/25] x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context() James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for Dave Martin
2025-05-15 16:58 ` [PATCH v12 22/25] x86/resctrl: Relax some asm #includes James Morse
2025-05-17 10:02   ` tip-bot2 for Dave Martin [this message]
2025-05-15 16:58 ` [PATCH v12 23/25] x86/resctrl: Always initialise rid field in rdt_resources_all[] James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 24/25] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 25/25] MAINTAINERS: Add reviewers for fs/resctrl James Morse
2025-05-17 10:02   ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 17:50 ` [PATCH v12 00/25] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl Borislav Petkov
2025-05-15 18:00   ` Fenghua Yu
2025-05-15 18:06     ` Borislav Petkov
2025-05-15 18:11       ` Fenghua Yu
2025-05-15 18:04 ` Reinette Chatre

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=174747616981.406.4962690696174848120.tip-bot2@tip-bot2 \
    --to=tip-bot2@linutronix.de \
    --cc=Dave.Martin@arm.com \
    --cc=amitsinght@marvell.com \
    --cc=babu.moger@amd.com \
    --cc=bp@alien8.de \
    --cc=fenghuay@nvidia.com \
    --cc=james.morse@arm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-tip-commits@vger.kernel.org \
    --cc=peternewman@google.com \
    --cc=reinette.chatre@intel.com \
    --cc=sdonthineni@nvidia.com \
    --cc=tan.shaopeng@jp.fujitsu.com \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®