From: Reinette Chatre <reinette.chatre@intel.com>
To: James Morse <james.morse@arm.com>, <x86@kernel.org>,
<linux-kernel@vger.kernel.org>, Borislav Petkov <bp@alien8.de>
Cc: Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, "H Peter Anvin" <hpa@zytor.com>,
Babu Moger <Babu.Moger@amd.com>,
<shameerali.kolothum.thodi@huawei.com>,
D Scott Phillips OS <scott@os.amperecomputing.com>,
<carl@os.amperecomputing.com>, <lcherian@marvell.com>,
<bobo.shaobowang@huawei.com>, <tan.shaopeng@fujitsu.com>,
<baolin.wang@linux.alibaba.com>,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>, <peternewman@google.com>,
<dfustini@baylibre.com>, <amitsinght@marvell.com>,
David Hildenbrand <david@redhat.com>,
Rex Nie <rex.nie@jaguarmicro.com>,
"Dave Martin" <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
Shanker Donthineni <sdonthineni@nvidia.com>,
<fenghuay@nvidia.com>
Subject: Re: [PATCH v12 00/25] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl
Date: Thu, 15 May 2025 11:04:52 -0700 [thread overview]
Message-ID: <cd9a0659-8d58-4b12-bb8c-b566c587c630@intel.com> (raw)
In-Reply-To: <20250515165855.31452-1-james.morse@arm.com>
Hi Boris and x86 Maintainers,
On 5/15/25 9:58 AM, James Morse wrote:
> Hello!
>
> No code changes since v11 - this is the 'final' form of the series
> with patches v11:24-29 squashed together. See [v11] for the breakdown.
>
> The first four patches are a series from Yury which I've rebased onto.
>
> This series is based on rc5, and can be retrieved from:
> git://git.kernel.org/pub/scm/linux/kernel/git/morse/linux.git mpam/move_to_fs/v12
(mpam/move_to_fs/v12 -> mpam/move_to_fs/v12_final)
>
> With the exception of invalid configurations for the configurable-events, there
> should be no changes in behaviour caused by this series. It is now possible for
> throttle_mode to report 'undefined', but no known platform will do this.
> resctrl_exit() is now something that can be called, but x86 doesn't do this.
>
> The driving pattern is to make things like struct rdtgroup private to resctrl.
> Features like pseudo-lock aren't going to work on arm64, the ability to disable
> it at compile time is added.
>
> After this, I can start posting the MPAM driver to make use of resctrl on arm64.
> (What's MPAM? See the cover letter of the first series. [1])
>
> Bugs are still welcome!
> Thanks,
>
> James
>
Could you please consider this work for inclusion?
Thank you very much.
Reinette
prev parent reply other threads:[~2025-05-15 18:04 UTC|newest]
Thread overview: 56+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-15 16:58 James Morse
2025-05-15 16:58 ` [PATCH v12 01/25] cpumask: relax cpumask_any_but() James Morse
2025-05-17 10:03 ` [tip: x86/cache] cpumask: Relax cpumask_any_but() tip-bot2 for Yury Norov [NVIDIA]
2025-05-15 16:58 ` [PATCH v12 02/25] find: add find_first_andnot_bit() James Morse
2025-05-17 10:03 ` [tip: x86/cache] find: Add find_first_andnot_bit() tip-bot2 for Yury Norov [NVIDIA]
2025-05-15 16:58 ` [PATCH v12 03/25] cpumask: add cpumask_{first,next}_andnot() API James Morse
2025-05-17 10:03 ` [tip: x86/cache] cpumask: Add " tip-bot2 for Yury Norov [NVIDIA]
2025-05-15 16:58 ` [PATCH v12 04/25] x86/resctrl: Optimize cpumask_any_housekeeping() James Morse
2025-05-17 10:03 ` [tip: x86/cache] " tip-bot2 for Yury Norov [NVIDIA]
2025-05-15 16:58 ` [PATCH v12 05/25] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-05-17 10:03 ` [tip: x86/cache] " tip-bot2 for Amit Singh Tomar
2025-05-15 16:58 ` [PATCH v12 06/25] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-05-17 10:03 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 07/25] x86/resctrl: Check all domains are offline in resctrl_exit() James Morse
2025-05-17 10:03 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 08/25] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-05-17 10:03 ` [tip: x86/cache] x86/resctrl: Resctrl_exit() " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 09/25] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-05-17 10:03 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 10/25] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-05-17 10:03 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 11/25] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 12/25] x86/resctrl: Expand the width of domid by replacing mon_data_bits James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 13/25] x86/resctrl: Split trace.h James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 14/25] x86/resctrl: Add 'resctrl' to the title of the resctrl documentation James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 15/25] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 16/25] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 17/25] x86/resctrl: Move enum resctrl_event_id to resctrl.h James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 18/25] x86/resctrl: Fix types in resctrl_arch_mon_ctx_{alloc,free}() stubs James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 19/25] x86/resctrl: Move pseudo lock prototypes to include/linux/resctrl.h James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 20/25] x86/resctrl: Squelch whitespace anomalies in resctrl core code James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for Dave Martin
2025-05-15 16:58 ` [PATCH v12 21/25] x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context() James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for Dave Martin
2025-05-15 16:58 ` [PATCH v12 22/25] x86/resctrl: Relax some asm #includes James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for Dave Martin
2025-05-15 16:58 ` [PATCH v12 23/25] x86/resctrl: Always initialise rid field in rdt_resources_all[] James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 24/25] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 16:58 ` [PATCH v12 25/25] MAINTAINERS: Add reviewers for fs/resctrl James Morse
2025-05-17 10:02 ` [tip: x86/cache] " tip-bot2 for James Morse
2025-05-15 17:50 ` [PATCH v12 00/25] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl Borislav Petkov
2025-05-15 18:00 ` Fenghua Yu
2025-05-15 18:06 ` Borislav Petkov
2025-05-15 18:11 ` Fenghua Yu
2025-05-15 18:04 ` Reinette Chatre [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cd9a0659-8d58-4b12-bb8c-b566c587c630@intel.com \
--to=reinette.chatre@intel.com \
--cc=Babu.Moger@amd.com \
--cc=amitsinght@marvell.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=dave.martin@arm.com \
--cc=david@redhat.com \
--cc=dfustini@baylibre.com \
--cc=fenghuay@nvidia.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=kobak@nvidia.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=rex.nie@jaguarmicro.com \
--cc=scott@os.amperecomputing.com \
--cc=sdonthineni@nvidia.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®