From: patchwork-bot+netdevbpf@kernel.org
To: Breno Leitao <leitao@debian.org>
Cc: davem@davemloft.net, edumazet@google.com, kuba@kernel.org,
pabeni@redhat.com, horms@kernel.org, andrew+netdev@lunn.ch,
shuah@kernel.org, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-kselftest@vger.kernel.org,
gustavold@gmail.com
Subject: Re: [PATCH net-next v3 0/8] netpoll: Untangle netconsole and netpoll
Date: Mon, 16 Jun 2025 22:30:51 +0000 [thread overview]
Message-ID: <175011305125.2535792.17187511380555589893.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20250613-rework-v3-0-0752bf2e6912@debian.org>
Hello:
This series was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:
On Fri, 13 Jun 2025 04:31:29 -0700 you wrote:
> Initially netpoll and netconsole were created together, and some
> functions are in the wrong file. Seperate netconsole-only functions
> in netconsole, avoiding exports.
>
> 1. Expose netpoll logging macros in the public header to enable consistent
> log formatting across netpoll consumers.
>
> [...]
Here is the summary with links:
- [net-next,v3,1/8] netpoll: remove __netpoll_cleanup from exported API
https://git.kernel.org/netdev/net-next/c/260948993a9f
- [net-next,v3,2/8] netpoll: expose netpoll logging macros in public header
https://git.kernel.org/netdev/net-next/c/afb023329c07
- [net-next,v3,3/8] netpoll: relocate netconsole-specific functions to netconsole module
https://git.kernel.org/netdev/net-next/c/5a34c9a85365
- [net-next,v3,4/8] netpoll: move netpoll_print_options to netconsole
https://git.kernel.org/netdev/net-next/c/ccc7edf0ada8
- [net-next,v3,5/8] netconsole: rename functions to better reflect their purpose
https://git.kernel.org/netdev/net-next/c/abebef96aab1
- [net-next,v3,6/8] netconsole: improve code style in parser function
https://git.kernel.org/netdev/net-next/c/d79206451f4f
- [net-next,v3,7/8] selftests: net: Refactor cleanup logic in lib_netcons.sh
https://git.kernel.org/netdev/net-next/c/bed365ca56ca
- [net-next,v3,8/8] selftests: net: add netconsole test for cmdline configuration
https://git.kernel.org/netdev/net-next/c/69d094ef69b9
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
prev parent reply other threads:[~2025-06-16 22:30 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-13 11:31 Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 1/8] netpoll: remove __netpoll_cleanup from exported API Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 2/8] netpoll: expose netpoll logging macros in public header Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 3/8] netpoll: relocate netconsole-specific functions to netconsole module Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 4/8] netpoll: move netpoll_print_options to netconsole Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 5/8] netconsole: rename functions to better reflect their purpose Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 6/8] netconsole: improve code style in parser function Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 7/8] selftests: net: Refactor cleanup logic in lib_netcons.sh Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 8/8] selftests: net: add netconsole test for cmdline configuration Breno Leitao
2025-06-16 22:30 ` patchwork-bot+netdevbpf [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=175011305125.2535792.17187511380555589893.git-patchwork-notify@kernel.org \
--to=patchwork-bot+netdevbpf@kernel.org \
--cc=andrew+netdev@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=gustavold@gmail.com \
--cc=horms@kernel.org \
--cc=kuba@kernel.org \
--cc=leitao@debian.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=shuah@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®