mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH net-next v3 0/8] netpoll: Untangle netconsole and netpoll
@ 2025-06-13 11:31 Breno Leitao
  2025-06-13 11:31 ` [PATCH net-next v3 1/8] netpoll: remove __netpoll_cleanup from exported API Breno Leitao
                   ` (8 more replies)
  0 siblings, 9 replies; 10+ messages in thread
From: Breno Leitao @ 2025-06-13 11:31 UTC (permalink / raw)
  To: David S. Miller, Eric Dumazet, Jakub Kicinski, Paolo Abeni,
	Simon Horman, Andrew Lunn, Shuah Khan
  Cc: netdev, linux-kernel, linux-kselftest, Breno Leitao, gustavold

Initially netpoll and netconsole were created together, and some
functions are in the wrong file. Seperate netconsole-only functions
in netconsole, avoiding exports.

1. Expose netpoll logging macros in the public header to enable consistent
   log formatting across netpoll consumers.

2. Relocate netconsole-specific functions from netpoll to the netconsole
   module where they are actually used, reducing unnecessary coupling.

3. Remove unnecessary function exports

4. Rename netpoll parsing functions in netconsole to better reflect their
   specific usage.

5. Create a test to check that cmdline works fine. This was in my todo
   list since [1], this was a good time to add it here to make sure this
   patchset doesn't regress.

PS: The code was split in a way that it is easy to review. When copying
the functions from netpoll to netconsole, I do not change than other
than adding `static`. This will make checkpatch unhappy, but, further
patches will address the issues. It is done this way to make it easy for
reviewers.

Link: https://lore.kernel.org/netdev/Z36TlACdNMwFD7wv@dev-ushankar.dev.purestorage.com/ [1]
Signed-off-by: Breno Leitao <leitao@debian.org>
---
Changes in v3:
- The cleanup on the netcons_cmdline.sh test was not cleaning the
  netdevsim. Clean it at the end of the test. (Jakub)
- Link to v2: https://lore.kernel.org/r/20250611-rework-v2-0-ab1d92b458ca@debian.org

Changes in v2:
- No change in the code. Just rebased the patches onto netnext/main
- Link to v1: https://lore.kernel.org/r/20250610-rework-v1-0-7cfde283f246@debian.org

---
Breno Leitao (8):
      netpoll: remove __netpoll_cleanup from exported API
      netpoll: expose netpoll logging macros in public header
      netpoll: relocate netconsole-specific functions to netconsole module
      netpoll: move netpoll_print_options to netconsole
      netconsole: rename functions to better reflect their purpose
      netconsole: improve code style in parser function
      selftests: net: Refactor cleanup logic in lib_netcons.sh
      selftests: net: add netconsole test for cmdline configuration

 drivers/net/netconsole.c                           | 137 ++++++++++++++++++++-
 include/linux/netpoll.h                            |  10 +-
 net/core/netpoll.c                                 | 136 +-------------------
 tools/testing/selftests/drivers/net/Makefile       |   1 +
 .../selftests/drivers/net/lib/sh/lib_netcons.sh    |  59 ++++++---
 .../selftests/drivers/net/netcons_cmdline.sh       |  52 ++++++++
 6 files changed, 240 insertions(+), 155 deletions(-)
---
base-commit: 6d4e01d29d87356924f1521ca6df7a364e948f13
change-id: 20250603-rework-c175cad8d22e

Best regards,
-- 
Breno Leitao <leitao@debian.org>


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2025-06-16 22:30 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-06-13 11:31 [PATCH net-next v3 0/8] netpoll: Untangle netconsole and netpoll Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 1/8] netpoll: remove __netpoll_cleanup from exported API Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 2/8] netpoll: expose netpoll logging macros in public header Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 3/8] netpoll: relocate netconsole-specific functions to netconsole module Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 4/8] netpoll: move netpoll_print_options to netconsole Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 5/8] netconsole: rename functions to better reflect their purpose Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 6/8] netconsole: improve code style in parser function Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 7/8] selftests: net: Refactor cleanup logic in lib_netcons.sh Breno Leitao
2025-06-13 11:31 ` [PATCH net-next v3 8/8] selftests: net: add netconsole test for cmdline configuration Breno Leitao
2025-06-16 22:30 ` [PATCH net-next v3 0/8] netpoll: Untangle netconsole and netpoll patchwork-bot+netdevbpf

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®