* [PATCH] bnxt_en: Improve comment wording and error return code
@ 2025-06-15 15:40 Alok Tiwari
2025-06-16 20:09 ` Michael Chan
2025-06-17 23:20 ` patchwork-bot+netdevbpf
0 siblings, 2 replies; 3+ messages in thread
From: Alok Tiwari @ 2025-06-15 15:40 UTC (permalink / raw)
To: netdev, michael.chan, pavan.chebbi, andrew+netdev, davem,
edumazet, kuba, pabeni
Cc: alok.a.tiwari, darren.kenny, linux-kernel
Improved wording and grammar in several comments for clarity.
"the must belongs" -> "it must belong"
"mininum" -> "minimum"
"fileds" -> "fields"
Replaced return -1 with -EINVAL in hwrm_ring_alloc_send_msg()
to return a proper error code.
These changes enhance code readability and consistent error handling.
Signed-off-by: Alok Tiwari <alok.a.tiwari@oracle.com>
---
drivers/net/ethernet/broadcom/bnxt/bnxt.c | 4 ++--
drivers/net/ethernet/broadcom/bnxt/bnxt_sriov.c | 2 +-
drivers/net/ethernet/broadcom/bnxt/bnxt_tc.c | 4 ++--
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/net/ethernet/broadcom/bnxt/bnxt.c b/drivers/net/ethernet/broadcom/bnxt/bnxt.c
index 869580b6f70d..00a60b2b90c4 100644
--- a/drivers/net/ethernet/broadcom/bnxt/bnxt.c
+++ b/drivers/net/ethernet/broadcom/bnxt/bnxt.c
@@ -1810,7 +1810,7 @@ static struct net_device *bnxt_get_pkt_dev(struct bnxt *bp, u16 cfa_code)
{
struct net_device *dev = bnxt_get_vf_rep(bp, cfa_code);
- /* if vf-rep dev is NULL, the must belongs to the PF */
+ /* if vf-rep dev is NULL, it must belong to the PF */
return dev ? dev : bp->dev;
}
@@ -7116,7 +7116,7 @@ static int hwrm_ring_alloc_send_msg(struct bnxt *bp,
default:
netdev_err(bp->dev, "hwrm alloc invalid ring type %d\n",
ring_type);
- return -1;
+ return -EINVAL;
}
resp = hwrm_req_hold(bp, req);
diff --git a/drivers/net/ethernet/broadcom/bnxt/bnxt_sriov.c b/drivers/net/ethernet/broadcom/bnxt/bnxt_sriov.c
index 5ddddd89052f..bc0d80356568 100644
--- a/drivers/net/ethernet/broadcom/bnxt/bnxt_sriov.c
+++ b/drivers/net/ethernet/broadcom/bnxt/bnxt_sriov.c
@@ -823,7 +823,7 @@ static int bnxt_sriov_enable(struct bnxt *bp, int *num_vfs)
int tx_ok = 0, rx_ok = 0, rss_ok = 0;
int avail_cp, avail_stat;
- /* Check if we can enable requested num of vf's. At a mininum
+ /* Check if we can enable requested num of vf's. At a minimum
* we require 1 RX 1 TX rings for each VF. In this minimum conf
* features like TPA will not be available.
*/
diff --git a/drivers/net/ethernet/broadcom/bnxt/bnxt_tc.c b/drivers/net/ethernet/broadcom/bnxt/bnxt_tc.c
index d2ca90407cce..0599d3016224 100644
--- a/drivers/net/ethernet/broadcom/bnxt/bnxt_tc.c
+++ b/drivers/net/ethernet/broadcom/bnxt/bnxt_tc.c
@@ -1316,7 +1316,7 @@ static int bnxt_tc_get_decap_handle(struct bnxt *bp, struct bnxt_tc_flow *flow,
/* Check if there's another flow using the same tunnel decap.
* If not, add this tunnel to the table and resolve the other
- * tunnel header fileds. Ignore src_port in the tunnel_key,
+ * tunnel header fields. Ignore src_port in the tunnel_key,
* since it is not required for decap filters.
*/
decap_key->tp_src = 0;
@@ -1410,7 +1410,7 @@ static int bnxt_tc_get_encap_handle(struct bnxt *bp, struct bnxt_tc_flow *flow,
/* Check if there's another flow using the same tunnel encap.
* If not, add this tunnel to the table and resolve the other
- * tunnel header fileds
+ * tunnel header fields
*/
encap_node = bnxt_tc_get_tunnel_node(bp, &tc_info->encap_table,
&tc_info->encap_ht_params,
--
2.47.1
^ permalink raw reply [flat|nested] 3+ messages in thread* Re: [PATCH] bnxt_en: Improve comment wording and error return code
2025-06-15 15:40 [PATCH] bnxt_en: Improve comment wording and error return code Alok Tiwari
@ 2025-06-16 20:09 ` Michael Chan
2025-06-17 23:20 ` patchwork-bot+netdevbpf
1 sibling, 0 replies; 3+ messages in thread
From: Michael Chan @ 2025-06-16 20:09 UTC (permalink / raw)
To: Alok Tiwari
Cc: netdev, pavan.chebbi, andrew+netdev, davem, edumazet, kuba,
pabeni, darren.kenny, linux-kernel
[-- Attachment #1: Type: text/plain, Size: 575 bytes --]
On Sun, Jun 15, 2025 at 8:40 AM Alok Tiwari <alok.a.tiwari@oracle.com> wrote:
>
> Improved wording and grammar in several comments for clarity.
> "the must belongs" -> "it must belong"
> "mininum" -> "minimum"
> "fileds" -> "fields"
>
> Replaced return -1 with -EINVAL in hwrm_ring_alloc_send_msg()
> to return a proper error code.
>
> These changes enhance code readability and consistent error handling.
>
> Signed-off-by: Alok Tiwari <alok.a.tiwari@oracle.com>
Reviewed for net-next. Thanks.
Reviewed-by: Michael Chan <michael.chan@broadcom.com>
[-- Attachment #2: S/MIME Cryptographic Signature --]
[-- Type: application/pkcs7-signature, Size: 4196 bytes --]
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] bnxt_en: Improve comment wording and error return code
2025-06-15 15:40 [PATCH] bnxt_en: Improve comment wording and error return code Alok Tiwari
2025-06-16 20:09 ` Michael Chan
@ 2025-06-17 23:20 ` patchwork-bot+netdevbpf
1 sibling, 0 replies; 3+ messages in thread
From: patchwork-bot+netdevbpf @ 2025-06-17 23:20 UTC (permalink / raw)
To: ALOK TIWARI
Cc: netdev, michael.chan, pavan.chebbi, andrew+netdev, davem,
edumazet, kuba, pabeni, darren.kenny, linux-kernel
Hello:
This patch was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:
On Sun, 15 Jun 2025 08:40:40 -0700 you wrote:
> Improved wording and grammar in several comments for clarity.
> "the must belongs" -> "it must belong"
> "mininum" -> "minimum"
> "fileds" -> "fields"
>
> Replaced return -1 with -EINVAL in hwrm_ring_alloc_send_msg()
> to return a proper error code.
>
> [...]
Here is the summary with links:
- bnxt_en: Improve comment wording and error return code
https://git.kernel.org/netdev/net-next/c/10f3829a1309
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2025-06-17 23:20 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-06-15 15:40 [PATCH] bnxt_en: Improve comment wording and error return code Alok Tiwari
2025-06-16 20:09 ` Michael Chan
2025-06-17 23:20 ` patchwork-bot+netdevbpf
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®