mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: patchwork-bot+netdevbpf@kernel.org
To: Breno Leitao <leitao@debian.org>
Cc: davem@davemloft.net, edumazet@google.com, kuba@kernel.org,
	pabeni@redhat.com, horms@kernel.org, andrew+netdev@lunn.ch,
	netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
	kernel-team@meta.com
Subject: Re: [PATCH net-next v3 0/5] netconsole: reuse netpoll_parse_ip_addr in configfs helpers
Date: Fri, 25 Jul 2025 22:17:43 +0000	[thread overview]
Message-ID: <175348186324.3265195.8269858440980471423.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20250723-netconsole_ref-v3-0-8be9b24e4a99@debian.org>

Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:

On Wed, 23 Jul 2025 10:20:28 -0700 you wrote:
> This patchset refactors the IP address parsing logic in the netconsole
> driver to eliminate code duplication and improve maintainability. The
> changes centralize IPv4 and IPv6 address parsing into a single function
> (netpoll_parse_ip_addr). For that, it needs to teach
> netpoll_parse_ip_addr() to handle strings with newlines, which is the
> type of string coming from configfs.
> 
> [...]

Here is the summary with links:
  - [net-next,v3,1/5] netpoll: Remove unused fields from inet_addr union
    https://git.kernel.org/netdev/net-next/c/33360f2508e0
  - [net-next,v3,2/5] netconsole: move netpoll_parse_ip_addr() earlier for reuse
    (no matching commit)
  - [net-next,v3,3/5] netconsole: add support for strings with new line in netpoll_parse_ip_addr
    (no matching commit)
  - [net-next,v3,4/5] netconsole: use netpoll_parse_ip_addr in local_ip_store
    (no matching commit)
  - [net-next,v3,5/5] netconsole: use netpoll_parse_ip_addr in local_ip_store
    (no matching commit)

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html



      parent reply	other threads:[~2025-07-25 22:17 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-23 17:20 Breno Leitao
2025-07-23 17:20 ` [PATCH net-next v3 1/5] netpoll: Remove unused fields from inet_addr union Breno Leitao
2025-07-23 17:20 ` [PATCH net-next v3 2/5] netconsole: move netpoll_parse_ip_addr() earlier for reuse Breno Leitao
2025-07-23 17:20 ` [PATCH net-next v3 3/5] netconsole: add support for strings with new line in netpoll_parse_ip_addr Breno Leitao
2025-07-25 20:42   ` Jakub Kicinski
2025-07-23 17:20 ` [PATCH net-next v3 4/5] netconsole: use netpoll_parse_ip_addr in local_ip_store Breno Leitao
2025-07-23 17:20 ` [PATCH net-next v3 5/5] " Breno Leitao
2025-07-25 22:17 ` patchwork-bot+netdevbpf [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=175348186324.3265195.8269858440980471423.git-patchwork-notify@kernel.org \
    --to=patchwork-bot+netdevbpf@kernel.org \
    --cc=andrew+netdev@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=horms@kernel.org \
    --cc=kernel-team@meta.com \
    --cc=kuba@kernel.org \
    --cc=leitao@debian.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®