mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [GIT PULL] power-supply changes for 6.17
@ 2025-08-01  1:01 Sebastian Reichel
  2025-08-01  4:53 ` pr-tracker-bot
  0 siblings, 1 reply; 2+ messages in thread
From: Sebastian Reichel @ 2025-08-01  1:01 UTC (permalink / raw)
  To: Linus Torvalds; +Cc: linux-kernel, linux-pm

[-- Attachment #1: Type: text/plain, Size: 6838 bytes --]

Hi Linus,

Some more power-supply core changes flow through the platform tree,
which needed some improvements in the power-supply extension API. No
merge conflicts have been found in linux-next and everything from my
tree has been in there for at least 3 weeks.

The following changes since commit e04c78d86a9699d136910cfc0bdcf01087e3267e:

  Linux 6.16-rc2 (2025-06-15 13:49:41 -0700)

are available in the Git repository at:

  https://git.kernel.org/pub/scm/linux/kernel/git/sre/linux-power-supply.git tags/for-v6.17

for you to fetch changes up to 7b41a2341fa62babda5d5c7a32c632e9eba2ee11:

  power: supply: core: fix static checker warning (2025-07-12 20:45:17 +0200)

----------------------------------------------------------------
power supply and reset changes for the 6.17 series

 * power-supply core
  - battery-info: replace any DT specific bits with fwnode usage
  - replace any device-tree code with generic fwnode based handling
 * power-supply drivers
  - ug3105_battery: use battery-info API
  - qcom_battmgr: report capacity
  - qcom_battmgr: support LiPo battery reporting
  - add missing missing power-supply ref to a bunch of DT bindings
  - update drivers regarding pm_runtime_autosuspend() usage
  - misc. minor fixes and cleanups
 * reset drivers
  - misc. minor cleanups

----------------------------------------------------------------
Abel Vesa (1):
      power: supply: qcom_battmgr: Add lithium-polymer entry

Casey Connolly (3):
      power: supply: qcom_pmi8998_charger: fix wakeirq
      power: supply: pmi8998_charger: rename to qcom_smbx
      MAINTAINERS: add myself as smbx charger driver maintainer

Charles Han (2):
      power: supply: cpcap-charger: Fix null check for power_supply_get_by_name
      power: supply: max14577: Handle NULL pdata when CONFIG_OF is not set

Geert Uytterhoeven (1):
      power: reset: POWER_RESET_TORADEX_EC should depend on ARCH_MXC

Hans de Goede (3):
      power: supply: ug3105_battery: Use psy->battery_info
      power: supply: ug3105_battery: Switch to power_supply_batinfo_ocv2cap()
      power: supply: bq24190: Free battery_info

Kornel Dulęba (1):
      power: supply: qcom_battmgr: Report battery capacity

Krzysztof Kozlowski (8):
      dt-bindings: power: supply: bq2515x: Add missing power-supply ref
      dt-bindings: power: supply: bq256xx: Add missing power-supply ref
      dt-bindings: power: supply: qcom,pmi8998: Add missing power-supply ref
      dt-bindings: power: supply: richtek,rt5033: Add missing power-supply ref
      dt-bindings: power: supply: summit,smb347: Add missing power-supply ref
      dt-bindings: power: supply: Drop redundant monitored-battery ref
      power: supply: bq256xx_charger: Constify reg_default array
      power: supply: bq25980_charger: Constify reg_default array

Lukas Bulwahn (1):
      MAINTAINERS: rectify file entry in QUALCOMM SMB CHARGER DRIVER

Mihai Sain (1):
      power: reset: at91-sama5d2_shdwc: Refactor wake-up source logging to use dev_info

Sakari Ailus (8):
      PM: runtime: Document return values of suspend-related API functions
      PM: runtime: Mark last busy stamp in pm_runtime_put_autosuspend()
      PM: runtime: Mark last busy stamp in pm_runtime_put_sync_autosuspend()
      PM: runtime: Mark last busy stamp in pm_runtime_autosuspend()
      PM: runtime: Mark last busy stamp in pm_request_autosuspend()
      Documentation: PM: *_autosuspend() functions update last busy time
      power: supply: bq24190: Remove redundant pm_runtime_mark_last_busy() calls
      power: supply: twl4030_charger: Remove redundant pm_runtime_mark_last_busy() calls

Sebastian Reichel (8):
      regulator: act8865-regulator: switch psy_cfg from of_node to fwnode
      Merge tag 'ib-regulator-psy-for-v6.17-signed' into psy-next
      power: supply: core: remove of_node from power_supply_config
      power: supply: core: battery-info: fully switch to fwnode
      power: supply: core: convert to fwnnode
      power: supply: core: rename power_supply_get_by_phandle to power_supply_get_by_reference
      Merge tag 'pm-runtime-6.17-rc1'
      power: supply: core: fix static checker warning

Taeyoung Kwon (1):
      power: reset: qcom-pon: Rename variables to use generic naming

Thomas Antoine (1):
      power: supply: max1720x correct capacity computation

Yuanjun Gong (1):
      power: return the correct error code

 .../devicetree/bindings/power/supply/bq24190.yaml  |   1 -
 .../devicetree/bindings/power/supply/bq2515x.yaml  |   7 +-
 .../devicetree/bindings/power/supply/bq256xx.yaml  |   5 +-
 .../devicetree/bindings/power/supply/bq25980.yaml  |   4 +-
 .../bindings/power/supply/cw2015_battery.yaml      |   5 +-
 .../power/supply/qcom,pmi8998-charger.yaml         |   7 +-
 .../power/supply/richtek,rt5033-charger.yaml       |   4 +-
 .../power/supply/stericsson,ab8500-btemp.yaml      |   4 +-
 .../power/supply/stericsson,ab8500-chargalg.yaml   |   4 +-
 .../power/supply/stericsson,ab8500-charger.yaml    |   4 +-
 .../power/supply/stericsson,ab8500-fg.yaml         |   4 +-
 .../power/supply/summit,smb347-charger.yaml        |   5 +-
 .../x-powers,axp20x-battery-power-supply.yaml      |   6 +-
 Documentation/power/runtime_pm.rst                 |  50 +++---
 MAINTAINERS                                        |   7 +
 drivers/phy/allwinner/phy-sun4i-usb.c              |   2 +-
 drivers/power/reset/Kconfig                        |   1 +
 drivers/power/reset/at91-sama5d2_shdwc.c           |   2 +-
 drivers/power/reset/qcom-pon.c                     |  30 ++--
 drivers/power/supply/Makefile                      |   2 +-
 drivers/power/supply/bq2415x_charger.c             |   2 +-
 drivers/power/supply/bq24190_charger.c             |  16 +-
 drivers/power/supply/bq256xx_charger.c             |   6 +-
 drivers/power/supply/bq25980_charger.c             |   6 +-
 drivers/power/supply/cpcap-charger.c               |   5 +-
 drivers/power/supply/max14577_charger.c            |   4 +-
 drivers/power/supply/max1720x_battery.c            |  13 +-
 drivers/power/supply/power_supply_core.c           | 185 ++++++++++----------
 drivers/power/supply/qcom_battmgr.c                |  25 +++
 .../supply/{qcom_pmi8998_charger.c => qcom_smbx.c} | 152 ++++++++---------
 drivers/power/supply/twl4030_charger.c             |   1 -
 drivers/power/supply/ug3105_battery.c              |  81 ++-------
 drivers/regulator/act8865-regulator.c              |   2 +-
 include/linux/pm_runtime.h                         | 187 ++++++++++++++++++---
 include/linux/power_supply.h                       |  16 +-
 35 files changed, 471 insertions(+), 384 deletions(-)
 rename drivers/power/supply/{qcom_pmi8998_charger.c => qcom_smbx.c} (88%)

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [GIT PULL] power-supply changes for 6.17
  2025-08-01  1:01 [GIT PULL] power-supply changes for 6.17 Sebastian Reichel
@ 2025-08-01  4:53 ` pr-tracker-bot
  0 siblings, 0 replies; 2+ messages in thread
From: pr-tracker-bot @ 2025-08-01  4:53 UTC (permalink / raw)
  To: Sebastian Reichel; +Cc: Linus Torvalds, linux-kernel, linux-pm

The pull request you sent on Fri, 1 Aug 2025 03:01:04 +0200:

> https://git.kernel.org/pub/scm/linux/kernel/git/sre/linux-power-supply.git tags/for-v6.17

has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/07b43820437bd96f31f5d7f9baf4453fcb7dedbf

Thank you!

-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/prtracker.html

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2025-08-01  4:53 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-08-01  1:01 [GIT PULL] power-supply changes for 6.17 Sebastian Reichel
2025-08-01  4:53 ` pr-tracker-bot

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®