mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Manivannan Sadhasivam <mani@kernel.org>
To: "Lorenzo Pieralisi" <lpieralisi@kernel.org>,
	"Krzysztof Wilczyński" <kwilczynski@kernel.org>,
	"Rob Herring" <robh@kernel.org>,
	"Bjorn Helgaas" <bhelgaas@google.com>,
	"Niklas Cassel" <cassel@kernel.org>,
	"Siddharth Vadapalli" <s-vadapalli@ti.com>,
	"Kishon Vijay Abraham I" <kishon@kernel.org>,
	"Hans Zhang" <18255117159@163.com>,
	"Sergio Paracuellos" <sergio.paracuellos@gmail.com>,
	"Jiri Slaby (SUSE)" <jirislaby@kernel.org>,
	linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org,
	"Qianfeng Rong" <rongqianfeng@vivo.com>
Subject: Re: [PATCH v2] PCI: keystone: Use kcalloc() instead of kzalloc()
Date: Wed, 27 Aug 2025 19:34:35 +0530	[thread overview]
Message-ID: <175630347585.12704.14542209032343661928.b4-ty@kernel.org> (raw)
In-Reply-To: <20250819131235.152967-1-rongqianfeng@vivo.com>


On Tue, 19 Aug 2025 21:12:33 +0800, Qianfeng Rong wrote:
> Replace calls of devm_kzalloc() with devm_kcalloc() in ks_pcie_probe().
> As noted in the kernel documentation [1], open-coded multiplication in
> allocator arguments is discouraged because it can lead to integer
> overflow.
> 
> Using devm_kcalloc() provides built-in overflow protection, making the
> memory allocation safer when calculating the allocation size compared
> to explicit multiplication.
> 
> [...]

Applied, thanks!

[1/1] PCI: keystone: Use kcalloc() instead of kzalloc()
      commit: ffdd27d36265be108827c606c9fbe81a5947547e

Best regards,
-- 
Manivannan Sadhasivam <mani@kernel.org>


      parent reply	other threads:[~2025-08-27 14:04 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-19 13:12 Qianfeng Rong
2025-08-19 13:18 ` Siddharth Vadapalli
2025-08-27 14:04 ` Manivannan Sadhasivam [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=175630347585.12704.14542209032343661928.b4-ty@kernel.org \
    --to=mani@kernel.org \
    --cc=18255117159@163.com \
    --cc=bhelgaas@google.com \
    --cc=cassel@kernel.org \
    --cc=jirislaby@kernel.org \
    --cc=kishon@kernel.org \
    --cc=kwilczynski@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lpieralisi@kernel.org \
    --cc=robh@kernel.org \
    --cc=rongqianfeng@vivo.com \
    --cc=s-vadapalli@ti.com \
    --cc=sergio.paracuellos@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®