* [PATCH v2] PCI: keystone: Use kcalloc() instead of kzalloc()
@ 2025-08-19 13:12 Qianfeng Rong
2025-08-19 13:18 ` Siddharth Vadapalli
2025-08-27 14:04 ` Manivannan Sadhasivam
0 siblings, 2 replies; 3+ messages in thread
From: Qianfeng Rong @ 2025-08-19 13:12 UTC (permalink / raw)
To: Lorenzo Pieralisi, Krzysztof Wilczyński,
Manivannan Sadhasivam, Rob Herring, Bjorn Helgaas, Niklas Cassel,
Siddharth Vadapalli, Kishon Vijay Abraham I, Hans Zhang,
Sergio Paracuellos, Jiri Slaby (SUSE),
linux-pci, linux-kernel
Cc: Qianfeng Rong
Replace calls of devm_kzalloc() with devm_kcalloc() in ks_pcie_probe().
As noted in the kernel documentation [1], open-coded multiplication in
allocator arguments is discouraged because it can lead to integer
overflow.
Using devm_kcalloc() provides built-in overflow protection, making the
memory allocation safer when calculating the allocation size compared
to explicit multiplication.
[1]: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
Signed-off-by: Qianfeng Rong <rongqianfeng@vivo.com>
---
v2: Modified the commit message.
---
drivers/pci/controller/dwc/pci-keystone.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/pci/controller/dwc/pci-keystone.c b/drivers/pci/controller/dwc/pci-keystone.c
index 7d7aede54ed3..3d10e1112131 100644
--- a/drivers/pci/controller/dwc/pci-keystone.c
+++ b/drivers/pci/controller/dwc/pci-keystone.c
@@ -1212,11 +1212,11 @@ static int ks_pcie_probe(struct platform_device *pdev)
if (ret)
num_lanes = 1;
- phy = devm_kzalloc(dev, sizeof(*phy) * num_lanes, GFP_KERNEL);
+ phy = devm_kcalloc(dev, num_lanes, sizeof(*phy), GFP_KERNEL);
if (!phy)
return -ENOMEM;
- link = devm_kzalloc(dev, sizeof(*link) * num_lanes, GFP_KERNEL);
+ link = devm_kcalloc(dev, num_lanes, sizeof(*link), GFP_KERNEL);
if (!link)
return -ENOMEM;
--
2.34.1
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH v2] PCI: keystone: Use kcalloc() instead of kzalloc()
2025-08-19 13:12 [PATCH v2] PCI: keystone: Use kcalloc() instead of kzalloc() Qianfeng Rong
@ 2025-08-19 13:18 ` Siddharth Vadapalli
2025-08-27 14:04 ` Manivannan Sadhasivam
1 sibling, 0 replies; 3+ messages in thread
From: Siddharth Vadapalli @ 2025-08-19 13:18 UTC (permalink / raw)
To: Qianfeng Rong
Cc: Lorenzo Pieralisi, Krzysztof Wilczyński,
Manivannan Sadhasivam, Rob Herring, Bjorn Helgaas, Niklas Cassel,
Siddharth Vadapalli, Kishon Vijay Abraham I, Hans Zhang,
Sergio Paracuellos, Jiri Slaby (SUSE),
linux-pci, linux-kernel
On Tue, Aug 19, 2025 at 09:12:33PM +0800, Qianfeng Rong wrote:
> Replace calls of devm_kzalloc() with devm_kcalloc() in ks_pcie_probe().
> As noted in the kernel documentation [1], open-coded multiplication in
> allocator arguments is discouraged because it can lead to integer
> overflow.
>
> Using devm_kcalloc() provides built-in overflow protection, making the
> memory allocation safer when calculating the allocation size compared
> to explicit multiplication.
>
> [1]: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Qianfeng Rong <rongqianfeng@vivo.com>
> ---
> v2: Modified the commit message.
Reviewed-by: Siddharth Vadapalli <s-vadapalli@ti.com>
Regards,
Siddharth.
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH v2] PCI: keystone: Use kcalloc() instead of kzalloc()
2025-08-19 13:12 [PATCH v2] PCI: keystone: Use kcalloc() instead of kzalloc() Qianfeng Rong
2025-08-19 13:18 ` Siddharth Vadapalli
@ 2025-08-27 14:04 ` Manivannan Sadhasivam
1 sibling, 0 replies; 3+ messages in thread
From: Manivannan Sadhasivam @ 2025-08-27 14:04 UTC (permalink / raw)
To: Lorenzo Pieralisi, Krzysztof Wilczyński, Rob Herring,
Bjorn Helgaas, Niklas Cassel, Siddharth Vadapalli,
Kishon Vijay Abraham I, Hans Zhang, Sergio Paracuellos,
Jiri Slaby (SUSE),
linux-pci, linux-kernel, Qianfeng Rong
On Tue, 19 Aug 2025 21:12:33 +0800, Qianfeng Rong wrote:
> Replace calls of devm_kzalloc() with devm_kcalloc() in ks_pcie_probe().
> As noted in the kernel documentation [1], open-coded multiplication in
> allocator arguments is discouraged because it can lead to integer
> overflow.
>
> Using devm_kcalloc() provides built-in overflow protection, making the
> memory allocation safer when calculating the allocation size compared
> to explicit multiplication.
>
> [...]
Applied, thanks!
[1/1] PCI: keystone: Use kcalloc() instead of kzalloc()
commit: ffdd27d36265be108827c606c9fbe81a5947547e
Best regards,
--
Manivannan Sadhasivam <mani@kernel.org>
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2025-08-27 14:04 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-08-19 13:12 [PATCH v2] PCI: keystone: Use kcalloc() instead of kzalloc() Qianfeng Rong
2025-08-19 13:18 ` Siddharth Vadapalli
2025-08-27 14:04 ` Manivannan Sadhasivam
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®