From: Neeraj Upadhyay <Neeraj.Upadhyay@amd.com>
To: Sean Christopherson <seanjc@google.com>
Cc: Borislav Petkov <bp@alien8.de>,
linux-kernel@vger.kernel.org, tglx@linutronix.de,
mingo@redhat.com, dave.hansen@linux.intel.com,
Thomas.Lendacky@amd.com, nikunj@amd.com, Santosh.Shukla@amd.com,
Vasant.Hegde@amd.com, Suravee.Suthikulpanit@amd.com,
David.Kaplan@amd.com, x86@kernel.org, hpa@zytor.com,
peterz@infradead.org, pbonzini@redhat.com, kvm@vger.kernel.org,
kirill.shutemov@linux.intel.com, huibo.wang@amd.com,
naveen.rao@amd.com, francescolavra.fl@gmail.com,
tiala@microsoft.com
Subject: Re: [RFC PATCH v6 07/32] KVM: x86: apic_test_vector() to common code
Date: Tue, 10 Jun 2025 09:56:03 +0530 [thread overview]
Message-ID: <175b29fa-40b4-46c7-b33f-ad6ffe89a33c@amd.com> (raw)
In-Reply-To: <aEM51U1RnYC0Dh_j@google.com>
On 6/7/2025 12:26 AM, Sean Christopherson wrote:
> On Fri, Jun 06, 2025, Sean Christopherson wrote:
>> Actually, looking at the end usage, just drop VEC_POS/REG_POS entirely. IIRC, I
>> suggested keeping the shorthand versions for KVM, but I didn't realize there would
>> literally be two helpers left. At that point, keeping VEC_POS and REG_POS is
>> pure stubborness :-)
>>
>> 1. Rename VEC_POS/REG_POS => APIC_VECTOR_TO_BIT_NUMBER/APIC_VECTOR_TO_REG_OFFSET
>> 2. Rename all of the KVM helpers you intend to move out of KVM.
>
> Looking at the earlier patches again, I vote to add a 4th:
>
> 2a. Replace all "char *" with "void *" in all affected helpers.
>
> Pointer arithmetic for "void *" and "char *" operate identically, and AFAICT that's
> the only reason why e.g. __kvm_lapic_set_reg64() takes a "char *". That way there
> is even less of a chance of doing the wrong thing, e.g. neglecting to cast and
> reading a byte instead of the desired size.
>
Sounds good. Will include this in the next version.
- Neeraj
>> 3. Move all of the helpers out of KVM.
next prev parent reply other threads:[~2025-06-10 4:26 UTC|newest]
Thread overview: 46+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-14 7:17 [RFC PATCH v6 00/32] AMD: Add Secure AVIC Guest Support Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 01/32] x86/apic: KVM: Deduplicate APIC vector => register+bit math Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 02/32] KVM: x86: Move find_highest_vector() to a common header Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 03/32] KVM: x86: Move lapic get/set_reg() helpers to common code Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 04/32] KVM: x86: Move lapic get/set_reg64() " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 05/32] KVM: x86: Move lapic set/clear_vector() " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 06/32] KVM: x86: Move {REG,VEC}_POS() macros to lapic.c Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 07/32] KVM: x86: apic_test_vector() to common code Neeraj Upadhyay
2025-05-24 12:12 ` Borislav Petkov
2025-05-26 3:00 ` Neeraj Upadhyay
2025-06-06 18:47 ` Sean Christopherson
2025-06-06 18:56 ` Sean Christopherson
2025-06-10 4:26 ` Neeraj Upadhyay [this message]
2025-06-10 4:25 ` Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 08/32] x86/apic: Remove redundant parentheses around 'bitmap' Neeraj Upadhyay
2025-05-24 12:14 ` Borislav Petkov
2025-05-26 3:01 ` Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 09/32] x86/apic: Rename 'reg_off' to 'reg' Neeraj Upadhyay
2025-06-09 6:35 ` Tianyu Lan
2025-05-14 7:17 ` [RFC PATCH v6 10/32] x86/apic: Change apic_*_vector() vector param to unsigned Neeraj Upadhyay
2025-05-24 12:15 ` Borislav Petkov
2025-05-26 3:01 ` Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 11/32] x86/apic: Change get/set reg operations reg " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 12/32] x86/apic: Unionize apic regs for 32bit/64bit access w/o type casting Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 13/32] x86/apic: Simplify bitwise operations on apic bitmap Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 14/32] x86/apic: Move apic_update_irq_cfg() calls to apic_update_vector() Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 15/32] x86/apic: Add new driver for Secure AVIC Neeraj Upadhyay
2025-06-10 6:52 ` Tianyu Lan
2025-05-14 7:17 ` [RFC PATCH v6 16/32] x86/apic: Initialize Secure AVIC APIC backing page Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 17/32] x86/apic: Populate .read()/.write() callbacks of Secure AVIC driver Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 18/32] x86/apic: Initialize APIC ID for Secure AVIC Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 19/32] x86/apic: Add update_vector() callback for apic drivers Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 20/32] x86/apic: Add update_vector() callback for Secure AVIC Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 21/32] x86/apic: Add support to send IPI " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 22/32] x86/apic: Support LAPIC timer " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 23/32] x86/sev: Initialize VGIF for secondary VCPUs " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 24/32] x86/apic: Add support to send NMI IPI " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 25/32] x86/apic: Allow NMI to be injected from hypervisor " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 26/32] x86/sev: Enable NMI support " Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 27/32] x86/apic: Read and write LVT* APIC registers from HV for SAVIC guests Neeraj Upadhyay
2025-05-14 7:17 ` [RFC PATCH v6 28/32] x86/apic: Handle EOI writes for Secure AVIC guests Neeraj Upadhyay
2025-05-14 7:18 ` [RFC PATCH v6 29/32] x86/apic: Add kexec support for Secure AVIC Neeraj Upadhyay
2025-05-14 7:18 ` [RFC PATCH v6 30/32] x86/apic: Enable Secure AVIC in Control MSR Neeraj Upadhyay
2025-05-14 7:18 ` [RFC PATCH v6 31/32] x86/sev: Prevent SECURE_AVIC_CONTROL MSR interception for Secure AVIC guests Neeraj Upadhyay
2025-06-09 7:40 ` Tianyu Lan
2025-05-14 7:18 ` [RFC PATCH v6 32/32] x86/sev: Indicate SEV-SNP guest supports Secure AVIC Neeraj Upadhyay
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=175b29fa-40b4-46c7-b33f-ad6ffe89a33c@amd.com \
--to=neeraj.upadhyay@amd.com \
--cc=David.Kaplan@amd.com \
--cc=Santosh.Shukla@amd.com \
--cc=Suravee.Suthikulpanit@amd.com \
--cc=Thomas.Lendacky@amd.com \
--cc=Vasant.Hegde@amd.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=francescolavra.fl@gmail.com \
--cc=hpa@zytor.com \
--cc=huibo.wang@amd.com \
--cc=kirill.shutemov@linux.intel.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=naveen.rao@amd.com \
--cc=nikunj@amd.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=seanjc@google.com \
--cc=tglx@linutronix.de \
--cc=tiala@microsoft.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®