* [PATCH] dmaengine: dw-edma: Fix confusing cleanup.h syntax
@ 2025-12-08 2:07 Krzysztof Kozlowski
2025-12-08 5:17 ` Manivannan Sadhasivam
2025-12-16 16:59 ` Vinod Koul
0 siblings, 2 replies; 3+ messages in thread
From: Krzysztof Kozlowski @ 2025-12-08 2:07 UTC (permalink / raw)
To: Manivannan Sadhasivam, Vinod Koul, dmaengine, linux-kernel
Cc: Krzysztof Kozlowski
Initializing automatic __free variables to NULL without need (e.g.
branches with different allocations), followed by actual allocation is
in contrary to explicit coding rules guiding cleanup.h:
"Given that the "__free(...) = NULL" pattern for variables defined at
the top of the function poses this potential interdependency problem the
recommendation is to always define and assign variables in one statement
and not group variable definitions at the top of the function when
__free() is used."
Code does not have a bug, but is less readable and uses discouraged
coding practice, so fix that by moving declaration to the place of
assignment.
Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
---
drivers/dma/dw-edma/dw-edma-pcie.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/dma/dw-edma/dw-edma-pcie.c b/drivers/dma/dw-edma/dw-edma-pcie.c
index 3371e0a76d3c..e9caf8adca1f 100644
--- a/drivers/dma/dw-edma/dw-edma-pcie.c
+++ b/drivers/dma/dw-edma/dw-edma-pcie.c
@@ -161,13 +161,13 @@ static int dw_edma_pcie_probe(struct pci_dev *pdev,
const struct pci_device_id *pid)
{
struct dw_edma_pcie_data *pdata = (void *)pid->driver_data;
- struct dw_edma_pcie_data *vsec_data __free(kfree) = NULL;
struct device *dev = &pdev->dev;
struct dw_edma_chip *chip;
int err, nr_irqs;
int i, mask;
- vsec_data = kmalloc(sizeof(*vsec_data), GFP_KERNEL);
+ struct dw_edma_pcie_data *vsec_data __free(kfree) =
+ kmalloc(sizeof(*vsec_data), GFP_KERNEL);
if (!vsec_data)
return -ENOMEM;
--
2.51.0
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] dmaengine: dw-edma: Fix confusing cleanup.h syntax
2025-12-08 2:07 [PATCH] dmaengine: dw-edma: Fix confusing cleanup.h syntax Krzysztof Kozlowski
@ 2025-12-08 5:17 ` Manivannan Sadhasivam
2025-12-16 16:59 ` Vinod Koul
1 sibling, 0 replies; 3+ messages in thread
From: Manivannan Sadhasivam @ 2025-12-08 5:17 UTC (permalink / raw)
To: Krzysztof Kozlowski; +Cc: Vinod Koul, dmaengine, linux-kernel
On Mon, Dec 08, 2025 at 03:07:30AM +0100, Krzysztof Kozlowski wrote:
> Initializing automatic __free variables to NULL without need (e.g.
> branches with different allocations), followed by actual allocation is
> in contrary to explicit coding rules guiding cleanup.h:
>
> "Given that the "__free(...) = NULL" pattern for variables defined at
> the top of the function poses this potential interdependency problem the
> recommendation is to always define and assign variables in one statement
> and not group variable definitions at the top of the function when
> __free() is used."
>
> Code does not have a bug, but is less readable and uses discouraged
> coding practice, so fix that by moving declaration to the place of
> assignment.
>
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
Reviewed-by: Manivannan Sadhasivam <mani@kernel.org>
- Mani
> ---
> drivers/dma/dw-edma/dw-edma-pcie.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/dma/dw-edma/dw-edma-pcie.c b/drivers/dma/dw-edma/dw-edma-pcie.c
> index 3371e0a76d3c..e9caf8adca1f 100644
> --- a/drivers/dma/dw-edma/dw-edma-pcie.c
> +++ b/drivers/dma/dw-edma/dw-edma-pcie.c
> @@ -161,13 +161,13 @@ static int dw_edma_pcie_probe(struct pci_dev *pdev,
> const struct pci_device_id *pid)
> {
> struct dw_edma_pcie_data *pdata = (void *)pid->driver_data;
> - struct dw_edma_pcie_data *vsec_data __free(kfree) = NULL;
> struct device *dev = &pdev->dev;
> struct dw_edma_chip *chip;
> int err, nr_irqs;
> int i, mask;
>
> - vsec_data = kmalloc(sizeof(*vsec_data), GFP_KERNEL);
> + struct dw_edma_pcie_data *vsec_data __free(kfree) =
> + kmalloc(sizeof(*vsec_data), GFP_KERNEL);
> if (!vsec_data)
> return -ENOMEM;
>
> --
> 2.51.0
>
--
மணிவண்ணன் சதாசிவம்
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] dmaengine: dw-edma: Fix confusing cleanup.h syntax
2025-12-08 2:07 [PATCH] dmaengine: dw-edma: Fix confusing cleanup.h syntax Krzysztof Kozlowski
2025-12-08 5:17 ` Manivannan Sadhasivam
@ 2025-12-16 16:59 ` Vinod Koul
1 sibling, 0 replies; 3+ messages in thread
From: Vinod Koul @ 2025-12-16 16:59 UTC (permalink / raw)
To: Manivannan Sadhasivam, dmaengine, linux-kernel, Krzysztof Kozlowski
On Mon, 08 Dec 2025 03:07:30 +0100, Krzysztof Kozlowski wrote:
> Initializing automatic __free variables to NULL without need (e.g.
> branches with different allocations), followed by actual allocation is
> in contrary to explicit coding rules guiding cleanup.h:
>
> "Given that the "__free(...) = NULL" pattern for variables defined at
> the top of the function poses this potential interdependency problem the
> recommendation is to always define and assign variables in one statement
> and not group variable definitions at the top of the function when
> __free() is used."
>
> [...]
Applied, thanks!
[1/1] dmaengine: dw-edma: Fix confusing cleanup.h syntax
commit: f9ef8dedee34e2d7828d5a6a0643cd969aaa8437
Best regards,
--
~Vinod
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2025-12-16 16:59 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-12-08 2:07 [PATCH] dmaengine: dw-edma: Fix confusing cleanup.h syntax Krzysztof Kozlowski
2025-12-08 5:17 ` Manivannan Sadhasivam
2025-12-16 16:59 ` Vinod Koul
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®