* [GIT PULL] Thermal control updates for v7.1-rc1
@ 2026-04-10 14:29 Rafael J. Wysocki
2026-04-14 3:10 ` pr-tracker-bot
0 siblings, 1 reply; 2+ messages in thread
From: Rafael J. Wysocki @ 2026-04-10 14:29 UTC (permalink / raw)
To: Linus Torvalds; +Cc: Linux PM, Linux Kernel Mailing List, Daniel Lezcano
Hi Linus,
This goes early because I will be traveling next week.
Please pull from the tag
git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git \
thermal-7.1-rc1
with top-most commit cd1a3b2ff0553e987de71ff0aa675e418de22898
Merge tag 'thermal-v7.1-rc1' of
ssh://gitolite.kernel.org/pub/scm/linux/kernel/git/thermal/linux
on top of commit 9e07e3b81807edd356e1f794cffa00a428eff443
thermal: core: Fix thermal zone device registration error path
to receive thermal control updates for 7.1-rc1.
These include thermal core fixes and simplifications, driver fixes and
new hardware support (SDM670, Eliza SoC), new driver features (hwmon
support in imx91, DDR data rate on Nova Lake in int340x), and a handful
of cleanups:
- Fix thermal core issues related to thermal zone removal and
registration errors that may lead to a use-after-free or a memory
leak in some cases (Rafael Wysocki)
- Drop a redundant check from thermal_zone_device_update(), adjust
thermal workqueue allocation flags, and switch over thermal_class
allocation to static (Rafael Wysocki)
- Relocate the suspend and resume of thermal zones closer to the
suspend and resume of devices, respectively (Rafael Wysocki)
- Remove a pointless variable used in the thermal core when
registering a cooling device (Daniel Lezcano)
- Replace sprintf() in thermal_bind_cdev_to_trip() and use
str_enabled_disabled() helper in mode_show() (Thorsten Blum)
- Replace cpumask_weight() in intel_hfi_offline() with cpumask_empty()
which is generally more efficient (Yury Norov)
- Add support for reading DDR data rate from PCI config space on Nova
Lake platforms to the int340x thermal driver (Srinivas Pandruvada)
- Add an OF node address to output message to make sensor names more
distinguishable (Alexander Stein)
- Add hwmon support for the i.MX97 thermal sensor (Alexander Stein)
- Clamp correctly the results when doing value/temperature conversion
in the Spreadtrum driver (Thorsten Blum)
- Add SDM670 compatible DT bindings for the Tsens and the lMH thermal
drivers (Richard Acayan)
- Add SM8750 compatible DT bindings for the Tsens thermal driver (Manaf
Meethalavalappu Pallikunhi)
- Add Eliza SoC compatible DT bindings for the Tsens driver (Krzysztof
Kozlowski)
- Fix inverted condition check on error in the Spear thermal control
driver (Gopi Krishna Menon)
- Convert DT bindings documentation into DT schema (Gopi Krishna Menon)
- Use max() macro to increase readability in the Broadcom STB thermal
sensor (Thorsten Blum)
- Remove a stale @trim_offset kernel-doc entry (John Madieu)
Thanks!
---------------
Alexander Stein (2):
thermal/of: Add OF node address to output message
thermal/drivers/imx91: Add hwmon support
Anas Iqbal (1):
thermal: devfreq_cooling: avoid unnecessary kfree of freq_table
Daniel Lezcano (1):
thermal/core: Remove pointless variable when registering a cooling device
Gopi Krishna Menon (2):
thermal/drivers/spear: Fix error condition for reading st,thermal-flags
dt-bindings: thermal: st,thermal-spear1340: convert to dtschema
John Madieu (1):
thermal: renesas: rzg3e: Remove stale @trim_offset kernel-doc entry
Krzysztof Kozlowski (1):
dt-bindings: thermal: qcom-tsens: Add Eliza SoC TSENS
Manaf Meethalavalappu Pallikunhi (1):
dt-bindings: thermal: qcom-tsens: Document the SM8750 Temperature Sensor
Rafael J. Wysocki (6):
thermal: core: Fix thermal zone governor cleanup issues
thermal: core: Free thermal zone ID later during removal
thermal: core: Drop redundant check from thermal_zone_device_update()
thermal: core: Adjust thermal_wq allocation flags
thermal: core: Allocate thermal_class statically
thermal: core: Suspend thermal zones later and resume them earlier
Richard Acayan (2):
dt-bindings: thermal: tsens: add SDM670 compatible
dt-bindings: thermal: lmh: Add SDM670 compatible
Srinivas Pandruvada (1):
thermal: intel: int340x: Read DDR data rate for Nova Lake
Thorsten Blum (6):
thermal: core: Replace sprintf() in thermal_bind_cdev_to_trip()
thermal/drivers/sprd: Fix temperature clamping in sprd_thm_temp_to_rawdata
thermal/drivers/sprd: Fix raw temperature clamping in
sprd_thm_rawdata_to_temp
thermal/drivers/sprd: Use min instead of clamp in sprd_thm_temp_to_rawdata
thermal: sysfs: Use str_enabled_disabled() helper in mode_show()
thermal/drivers/brcmstb_thermal: Use max to simplify brcmstb_get_temp
Yury Norov (1):
thermal: intel: hfi: use cpumask_empty() in intel_hfi_offline()
---------------
.../devicetree/bindings/thermal/qcom-lmh.yaml | 3 +
.../devicetree/bindings/thermal/qcom-tsens.yaml | 3 +
.../devicetree/bindings/thermal/spear-thermal.txt | 14 ---
.../bindings/thermal/st,thermal-spear1340.yaml | 36 ++++++
drivers/base/power/main.c | 5 +
drivers/thermal/broadcom/brcmstb_thermal.c | 8 +-
drivers/thermal/devfreq_cooling.c | 3 +-
drivers/thermal/imx91_thermal.c | 4 +
.../intel/int340x_thermal/processor_thermal_rfim.c | 25 ++++-
drivers/thermal/intel/intel_hfi.c | 2 +-
drivers/thermal/renesas/rzg3e_thermal.c | 1 -
drivers/thermal/spear_thermal.c | 2 +-
drivers/thermal/sprd_thermal.c | 6 +-
drivers/thermal/thermal_core.c | 121 ++++++++-------------
drivers/thermal/thermal_of.c | 20 ++--
drivers/thermal/thermal_sysfs.c | 7 +-
include/linux/thermal.h | 6 +
17 files changed, 143 insertions(+), 123 deletions(-)
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-04-14 3:10 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-04-10 14:29 [GIT PULL] Thermal control updates for v7.1-rc1 Rafael J. Wysocki
2026-04-14 3:10 ` pr-tracker-bot
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®