mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [GIT PULL] MMC/MEMSTICK updates for v7.2
@ 2026-06-15 12:37 Ulf Hansson
  2026-06-16  3:10 ` pr-tracker-bot
  0 siblings, 1 reply; 2+ messages in thread
From: Ulf Hansson @ 2026-06-15 12:37 UTC (permalink / raw)
  To: Linus, linux-mmc, linux-kernel; +Cc: Ulf Hansson

Hi Linus,

Here's the pull-request with updates for MMC and MEMSTICK for v7.2.
Details about the highlights are as usual found in the signed tag.

Please pull this in!

Kind regards
Ulf Hansson


The following changes since commit f595e8e77a51eee35e331f69321766593a845ef2:

  mmc: sdhci: add signal voltage switch in sdhci_resume_host (2026-05-29 15:02:47 +0200)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/ulfh/mmc.git tags/mmc-v7.2

for you to fetch changes up to 576e40d20e100ba62e21bfda94ad948820c90a23:

  mmc: Merge branch fixes into next (2026-05-29 16:42:41 +0200)

----------------------------------------------------------------
MMC core:
 - Validate host's max_segs to fail gracefully

MMC host:
 - davinci: Avoid potential NULL dereference in the IRQ handler
 - davinci: Call mmc_add_host() in the correct order during probe
 - dw_mmc-exynos: Increase DMA threshold for exynos7870
 - renesas_sdhi: Add support for RZ/G2E, RZ/G2N and R-Car M3Le variants
 - sdhci-msm: Add support for Hawi, Eliza and Shikra variants
 - sdhci-of-k1: Add support for SD UHS-I modes
 - sdhci-of-k1: Add support for tuning for eMMC HS200 and SD UHS-I

----------------------------------------------------------------
Abel Vesa (1):
      dt-bindings: mmc: sdhci-msm: Add Eliza compatible

Artem Shimko (2):
      mmc: sdhci-of-dwcmshc: remove redundant IS_ERR() check
      mmc: sdhci-of-dwcmshc: use dev_err_probe() to simplify error paths

Iker Pedrosa (4):
      dt-bindings: mmc: spacemit,sdhci: add pinctrl support for voltage switching
      mmc: sdhci-of-k1: enable essential clock infrastructure for SD operation
      mmc: sdhci-of-k1: add regulator and pinctrl voltage switching support
      mmc: sdhci-of-k1: add comprehensive SDR tuning support

Kaustabh Chakraborty (2):
      mmc: dw_mmc: implement option for configuring DMA threshold
      mmc: dw_mmc: exynos: increase DMA threshold value for exynos7870

Krzysztof Kozlowski (2):
      mmc: host: Move MODULE_DEVICE_TABLE next to the table itself
      memstick: Constify the driver id_table

Lad Prabhakar (2):
      mmc: renesas_sdhi: Add OF entry for RZ/G2N SoC
      mmc: renesas_sdhi: Add OF entry for RZ/G2E SoC

Manivannan Sadhasivam (1):
      dt-bindings: mmc: sdhci-msm: Rename the binding to include 'qcom' prefix

Marek Vasut (2):
      dt-bindings: mmc: renesas,sdhi: Document R-Car M3Le support
      mmc: renesas_sdhi: add R-Car M3Le compatibility string

Monish Chunara (1):
      dt-bindings: mmc: sdhci-msm: Document the Shikra compatible

Nitin Rawat (1):
      dt-bindings: mmc: sdhci-msm: qcom: Add Hawi compatible

Osama Abdelkader (1):
      mmc: davinci: fix mmc_add_host order in probe

Shawn Lin (3):
      mmc: core: Add validation for host-provided max_segs
      mmc: dw_mmc: Move misplaced comment
      mmc: dw_mmc: Add desc_num field for clarity

Stepan Ionichev (1):
      mmc: davinci: avoid NULL deref of host->data in IRQ handler

Ulf Hansson (3):
      mmc: Merge branch fixes into next
      mmc: Merge branch fixes into next
      mmc: Merge branch fixes into next

Uwe Kleine-König (The Capable Hub) (1):
      mmc: via-sdmmc: Simplify initialisation of pci_device_id array

 .../mmc/{sdhci-msm.yaml => qcom,sdhci-msm.yaml}    |   5 +-
 .../devicetree/bindings/mmc/renesas,sdhi.yaml      |   1 +
 .../devicetree/bindings/mmc/spacemit,sdhci.yaml    |  15 ++
 drivers/memstick/host/tifm_ms.c                    |   2 +-
 drivers/misc/tifm_core.c                           |   4 +-
 drivers/mmc/core/queue.c                           |   8 +-
 drivers/mmc/host/cavium-thunderx.c                 |   2 +-
 drivers/mmc/host/davinci_mmc.c                     |  16 +-
 drivers/mmc/host/dw_mmc-exynos.c                   |   1 +
 drivers/mmc/host/dw_mmc.c                          |  20 +-
 drivers/mmc/host/dw_mmc.h                          |   6 +-
 drivers/mmc/host/renesas_sdhi_internal_dmac.c      |   3 +
 drivers/mmc/host/sdhci-of-dwcmshc.c                |  36 ++-
 drivers/mmc/host/sdhci-of-k1.c                     | 257 +++++++++++++++++++++
 drivers/mmc/host/tifm_sd.c                         |   4 +-
 drivers/mmc/host/via-sdmmc.c                       |   5 +-
 drivers/mmc/host/wmt-sdmmc.c                       |   2 +-
 include/linux/tifm.h                               |   2 +-
 18 files changed, 332 insertions(+), 57 deletions(-)
 rename Documentation/devicetree/bindings/mmc/{sdhci-msm.yaml => qcom,sdhci-msm.yaml} (97%)

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2026-06-16  3:10 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-06-15 12:37 [GIT PULL] MMC/MEMSTICK updates for v7.2 Ulf Hansson
2026-06-16  3:10 ` pr-tracker-bot

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®