mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] drm/amdkfd: convert CRIU event-private allocation to kvcalloc()
@ 2026-06-01 19:55 William Theesfeld
  2026-06-03 16:16 ` Kuehling, Felix
  0 siblings, 1 reply; 2+ messages in thread
From: William Theesfeld @ 2026-06-01 19:55 UTC (permalink / raw)
  To: Felix Kuehling
  Cc: Alex Deucher, Christian König, David Airlie, Simona Vetter,
	amd-gfx, dri-devel, linux-kernel

criu_checkpoint_events() allocates the ev_privs[] array, sized by the
runtime count returned from kfd_get_num_events(), using the open-coded
kvzalloc(n * sizeof(*p), ...) form.  Switch to kvcalloc(), which
carries the same zero-on-allocation semantics and adds the standard
size_mul overflow check on the n * sizeof multiplication.

No functional change.

Signed-off-by: William Theesfeld <william@theesfeld.net>
---
 drivers/gpu/drm/amd/amdkfd/kfd_events.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_events.c b/drivers/gpu/drm/amd/amdkfd/kfd_events.c
index 44150a71f..9739214e2 100644
--- a/drivers/gpu/drm/amd/amdkfd/kfd_events.c
+++ b/drivers/gpu/drm/amd/amdkfd/kfd_events.c
@@ -543,7 +543,7 @@ int kfd_criu_checkpoint_events(struct kfd_process *p,
 	if (!num_events)
 		return 0;
 
-	ev_privs = kvzalloc(num_events * sizeof(*ev_privs), GFP_KERNEL);
+	ev_privs = kvcalloc(num_events, sizeof(*ev_privs), GFP_KERNEL);
 	if (!ev_privs)
 		return -ENOMEM;
 
-- 
2.54.0


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] drm/amdkfd: convert CRIU event-private allocation to kvcalloc()
  2026-06-01 19:55 [PATCH] drm/amdkfd: convert CRIU event-private allocation to kvcalloc() William Theesfeld
@ 2026-06-03 16:16 ` Kuehling, Felix
  0 siblings, 0 replies; 2+ messages in thread
From: Kuehling, Felix @ 2026-06-03 16:16 UTC (permalink / raw)
  To: William Theesfeld
  Cc: Alex Deucher, Christian König, David Airlie, Simona Vetter,
	amd-gfx, dri-devel, linux-kernel

On 2026-06-01 15:55, William Theesfeld wrote:
> [You don't often get email from william@theesfeld.net. Learn why this is important at https://aka.ms/LearnAboutSenderIdentification ]
>
> criu_checkpoint_events() allocates the ev_privs[] array, sized by the
> runtime count returned from kfd_get_num_events(), using the open-coded
> kvzalloc(n * sizeof(*p), ...) form.  Switch to kvcalloc(), which
> carries the same zero-on-allocation semantics and adds the standard
> size_mul overflow check on the n * sizeof multiplication.
>
> No functional change.
>
> Signed-off-by: William Theesfeld <william@theesfeld.net>

Reviewed-by: Felix Kuehling <felix.kuehling@amd.com>


> ---
>   drivers/gpu/drm/amd/amdkfd/kfd_events.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_events.c b/drivers/gpu/drm/amd/amdkfd/kfd_events.c
> index 44150a71f..9739214e2 100644
> --- a/drivers/gpu/drm/amd/amdkfd/kfd_events.c
> +++ b/drivers/gpu/drm/amd/amdkfd/kfd_events.c
> @@ -543,7 +543,7 @@ int kfd_criu_checkpoint_events(struct kfd_process *p,
>          if (!num_events)
>                  return 0;
>
> -       ev_privs = kvzalloc(num_events * sizeof(*ev_privs), GFP_KERNEL);
> +       ev_privs = kvcalloc(num_events, sizeof(*ev_privs), GFP_KERNEL);
>          if (!ev_privs)
>                  return -ENOMEM;
>
> --
> 2.54.0
>

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2026-06-03 16:16 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-06-01 19:55 [PATCH] drm/amdkfd: convert CRIU event-private allocation to kvcalloc() William Theesfeld
2026-06-03 16:16 ` Kuehling, Felix

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®