mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Linux PM <linux-pm@vger.kernel.org>
Cc: LKML <linux-kernel@vger.kernel.org>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	Lukasz Luba <lukasz.luba@arm.com>,
	Zhang Rui <rui.zhang@intel.com>,
	Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>
Subject: [PATCH v1 06/10] thermal: core: Move some trip processing to thermal_trip_crossed()
Date: Wed, 16 Oct 2024 13:29:14 +0200	[thread overview]
Message-ID: <1982859.PYKUYFuaPT@rjwysocki.net> (raw)
In-Reply-To: <4958885.31r3eYUQgx@rjwysocki.net>

From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>

Notice that some processing related to trip point crossing carried out
in handle_thermal_trip() and thermal_zone_set_trip_temp() may as well
be done in thermal_trip_crossed(), which allows code duplication to be
reduced, so change the code accordingly.

No intentional functional impact.

Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
---
 drivers/thermal/thermal_core.c |   21 ++++++++++-----------
 drivers/thermal/thermal_trip.c |   17 ++++++-----------
 2 files changed, 16 insertions(+), 22 deletions(-)

Index: linux-pm/drivers/thermal/thermal_core.c
===================================================================
--- linux-pm.orig/drivers/thermal/thermal_core.c
+++ linux-pm/drivers/thermal/thermal_core.c
@@ -460,11 +460,6 @@ static void handle_thermal_trip(struct t
 		if (tz->temperature < trip->temperature - trip->hysteresis) {
 			td->notify_temp = trip->temperature - trip->hysteresis;
 			move_trip_to_sorted_list(td, way_down_list);
-
-			if (trip->type == THERMAL_TRIP_PASSIVE) {
-				tz->passive--;
-				WARN_ON(tz->passive < 0);
-			}
 		} else {
 			td->threshold -= trip->hysteresis;
 		}
@@ -478,12 +473,6 @@ static void handle_thermal_trip(struct t
 		move_trip_to_sorted_list(td, way_up_list);
 
 		td->threshold -= trip->hysteresis;
-
-		if (trip->type == THERMAL_TRIP_PASSIVE)
-			tz->passive++;
-		else if (trip->type == THERMAL_TRIP_CRITICAL ||
-			 trip->type == THERMAL_TRIP_HOT)
-			handle_critical_trips(tz, trip);
 	}
 }
 
@@ -533,9 +522,19 @@ static void thermal_trip_crossed(struct
 	const struct thermal_trip *trip = &td->trip;
 
 	if (crossed_up) {
+		if (trip->type == THERMAL_TRIP_PASSIVE)
+			tz->passive++;
+		else if (trip->type == THERMAL_TRIP_CRITICAL ||
+			 trip->type == THERMAL_TRIP_HOT)
+			handle_critical_trips(tz, trip);
+
 		thermal_notify_tz_trip_up(tz, trip);
 		thermal_debug_tz_trip_up(tz, trip);
 	} else {
+		if (trip->type == THERMAL_TRIP_PASSIVE) {
+			tz->passive--;
+			WARN_ON(tz->passive < 0);
+		}
 		thermal_notify_tz_trip_down(tz, trip);
 		thermal_debug_tz_trip_down(tz, trip);
 	}
Index: linux-pm/drivers/thermal/thermal_trip.c
===================================================================
--- linux-pm.orig/drivers/thermal/thermal_trip.c
+++ linux-pm/drivers/thermal/thermal_trip.c
@@ -108,18 +108,13 @@ void thermal_zone_set_trip_temp(struct t
 	if (temp == THERMAL_TEMP_INVALID) {
 		struct thermal_trip_desc *td = trip_to_trip_desc(trip);
 
-		if (tz->temperature >= td->threshold) {
-			/*
-			 * The trip has been crossed on the way up, so some
-			 * adjustments are needed to compensate for the lack
-			 * of it going forward.
-			 */
-			if (trip->type == THERMAL_TRIP_PASSIVE) {
-				tz->passive--;
-				WARN_ON_ONCE(tz->passive < 0);
-			}
+		/*
+		 * If the trip has been crossed on the way up, some adjustments
+		 * are needed to compensate for the lack of it going forward.
+		 */
+		if (tz->temperature >= td->threshold)
 			thermal_zone_trip_down(tz, td);
-		}
+
 		/*
 		 * Invalidate the threshold to avoid triggering a spurious
 		 * trip crossing notification when the trip becomes valid.




  parent reply	other threads:[~2024-10-16 11:37 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-10-16 11:18 [PATCH v1 00/10] thermal: core: Use lists of trips for trip crossing detection and handling Rafael J. Wysocki
2024-10-16 11:21 ` [PATCH v1 01/10] thermal: core: Build sorted lists instead of sorting them later Rafael J. Wysocki
2024-10-24 10:14   ` Lukasz Luba
2024-10-16 11:23 ` [PATCH v1 02/10] thermal: core: Rename trip list node in struct thermal_trip_desc Rafael J. Wysocki
2024-10-24 10:16   ` Lukasz Luba
2024-10-16 11:24 ` [PATCH v1 03/10] thermal: core: Prepare for moving trips between sorted lists Rafael J. Wysocki
2024-10-24 10:19   ` Lukasz Luba
2024-10-16 11:26 ` [PATCH v1 04/10] thermal: core: Rearrange __thermal_zone_device_update() Rafael J. Wysocki
2024-10-24 10:20   ` Lukasz Luba
2024-10-16 11:27 ` [PATCH v1 05/10] thermal: core: Pass trip descriptor to thermal_trip_crossed() Rafael J. Wysocki
2024-10-24 10:22   ` Lukasz Luba
2024-10-16 11:29 ` Rafael J. Wysocki [this message]
2024-10-24 10:24   ` [PATCH v1 06/10] thermal: core: Move some trip processing " Lukasz Luba
2024-10-16 11:32 ` [PATCH v1 07/10] thermal: core: Relocate functions that update trip points Rafael J. Wysocki
2024-10-24 10:25   ` Lukasz Luba
2024-10-16 11:33 ` [PATCH v1 08/10] thermal: core: Eliminate thermal_zone_trip_down() Rafael J. Wysocki
2024-10-24 10:33   ` Lukasz Luba
2024-10-24 12:33     ` Rafael J. Wysocki
2024-10-24 13:39       ` Lukasz Luba
2024-10-16 11:35 ` [PATCH v1 09/10] thermal: core: Use trip lists for trip crossing detection Rafael J. Wysocki
2024-10-24 11:48   ` Lukasz Luba
2024-10-24 12:22     ` Rafael J. Wysocki
2024-10-16 11:36 ` [PATCH v1 10/10] thermal: core: Relocate thermal zone initialization routine Rafael J. Wysocki
2024-10-24 10:35   ` Lukasz Luba
2024-10-21 11:16 ` [PATCH v1 00/10] thermal: core: Use lists of trips for trip crossing detection and handling Rafael J. Wysocki
2024-10-22 22:52   ` Lukasz Luba
2024-10-23  8:53     ` Rafael J. Wysocki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1982859.PYKUYFuaPT@rjwysocki.net \
    --to=rjw@rjwysocki.net \
    --cc=daniel.lezcano@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=lukasz.luba@arm.com \
    --cc=rui.zhang@intel.com \
    --cc=srinivas.pandruvada@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®