From: Lukasz Luba <lukasz.luba@arm.com>
To: "Rafael J. Wysocki" <rafael@kernel.org>
Cc: "Rafael J. Wysocki" <rjw@rjwysocki.net>,
LKML <linux-kernel@vger.kernel.org>,
Linux PM <linux-pm@vger.kernel.org>,
Daniel Lezcano <daniel.lezcano@linaro.org>,
Zhang Rui <rui.zhang@intel.com>,
Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>
Subject: Re: [PATCH v1 08/10] thermal: core: Eliminate thermal_zone_trip_down()
Date: Thu, 24 Oct 2024 14:39:53 +0100 [thread overview]
Message-ID: <5e1aef31-4157-4094-a419-27810c172ce6@arm.com> (raw)
In-Reply-To: <CAJZ5v0j-T_ynbMsMrVndSHwCJP97A1-PX-p-NNskopO=i0xtpw@mail.gmail.com>
On 10/24/24 13:33, Rafael J. Wysocki wrote:
> On Thu, Oct 24, 2024 at 12:32 PM Lukasz Luba <lukasz.luba@arm.com> wrote:
>>
>>
>>
>> On 10/16/24 12:33, Rafael J. Wysocki wrote:
>>> From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
>>>
>>> Since thermal_zone_set_trip_temp() is not located in the same file
>>
>> nit: s/not/now
>
> Thanks, will fix when applying the patch.
>
>>> as thermal_trip_crossed(), it can invoke the latter directly without
>>> using the thermal_zone_trip_down() wrapper that has no other users.
>>>
>>> Update thermal_zone_set_trip_temp() accordingly and drop
>>> thermal_zone_trip_down().
>>>
>>> No functional impact.
>>>
>>> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
>>> ---
>>> drivers/thermal/thermal_core.c | 8 +-------
>>> drivers/thermal/thermal_core.h | 2 --
>>> 2 files changed, 1 insertion(+), 9 deletions(-)
>>>
>>> Index: linux-pm/drivers/thermal/thermal_core.c
>>> ===================================================================
>>> --- linux-pm.orig/drivers/thermal/thermal_core.c
>>> +++ linux-pm/drivers/thermal/thermal_core.c
>>> @@ -565,7 +565,7 @@ void thermal_zone_set_trip_temp(struct t
>>> * are needed to compensate for the lack of it going forward.
>>> */
>>> if (tz->temperature >= td->threshold)
>>> - thermal_zone_trip_down(tz, td);
>>> + thermal_trip_crossed(tz, td, thermal_get_tz_governor(tz), false);
>>
>> minor thing:
>> won't that be too long line?
>
> It is longer than 80 characters, but this is not a hard boundary - see
> "2) Breaking long lines and strings" in
> Documentation/process/coding-style.rst).
>
> Well, you can argue about the "hide information" part, but IMV this
> line just looks cleaner the way it is than when it would be broken in
> any way.
>
>> IMHO we can add somewhere earlier:
>> struct thermal_governor *gov = thermal_get_tz_governor(tz);
>> and use it here
>
> That would have been harder to follow than the current code IMO.
fair enough
next prev parent reply other threads:[~2024-10-24 13:38 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-16 11:18 [PATCH v1 00/10] thermal: core: Use lists of trips for trip crossing detection and handling Rafael J. Wysocki
2024-10-16 11:21 ` [PATCH v1 01/10] thermal: core: Build sorted lists instead of sorting them later Rafael J. Wysocki
2024-10-24 10:14 ` Lukasz Luba
2024-10-16 11:23 ` [PATCH v1 02/10] thermal: core: Rename trip list node in struct thermal_trip_desc Rafael J. Wysocki
2024-10-24 10:16 ` Lukasz Luba
2024-10-16 11:24 ` [PATCH v1 03/10] thermal: core: Prepare for moving trips between sorted lists Rafael J. Wysocki
2024-10-24 10:19 ` Lukasz Luba
2024-10-16 11:26 ` [PATCH v1 04/10] thermal: core: Rearrange __thermal_zone_device_update() Rafael J. Wysocki
2024-10-24 10:20 ` Lukasz Luba
2024-10-16 11:27 ` [PATCH v1 05/10] thermal: core: Pass trip descriptor to thermal_trip_crossed() Rafael J. Wysocki
2024-10-24 10:22 ` Lukasz Luba
2024-10-16 11:29 ` [PATCH v1 06/10] thermal: core: Move some trip processing " Rafael J. Wysocki
2024-10-24 10:24 ` Lukasz Luba
2024-10-16 11:32 ` [PATCH v1 07/10] thermal: core: Relocate functions that update trip points Rafael J. Wysocki
2024-10-24 10:25 ` Lukasz Luba
2024-10-16 11:33 ` [PATCH v1 08/10] thermal: core: Eliminate thermal_zone_trip_down() Rafael J. Wysocki
2024-10-24 10:33 ` Lukasz Luba
2024-10-24 12:33 ` Rafael J. Wysocki
2024-10-24 13:39 ` Lukasz Luba [this message]
2024-10-16 11:35 ` [PATCH v1 09/10] thermal: core: Use trip lists for trip crossing detection Rafael J. Wysocki
2024-10-24 11:48 ` Lukasz Luba
2024-10-24 12:22 ` Rafael J. Wysocki
2024-10-16 11:36 ` [PATCH v1 10/10] thermal: core: Relocate thermal zone initialization routine Rafael J. Wysocki
2024-10-24 10:35 ` Lukasz Luba
2024-10-21 11:16 ` [PATCH v1 00/10] thermal: core: Use lists of trips for trip crossing detection and handling Rafael J. Wysocki
2024-10-22 22:52 ` Lukasz Luba
2024-10-23 8:53 ` Rafael J. Wysocki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5e1aef31-4157-4094-a419-27810c172ce6@arm.com \
--to=lukasz.luba@arm.com \
--cc=daniel.lezcano@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rafael@kernel.org \
--cc=rjw@rjwysocki.net \
--cc=rui.zhang@intel.com \
--cc=srinivas.pandruvada@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®