mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* irq.h changes in 2.3.14
@ 1999-08-19  9:14 Jes Sorensen
  1999-08-19 17:45 ` Linus Torvalds
  0 siblings, 1 reply; 2+ messages in thread
From: Jes Sorensen @ 1999-08-19  9:14 UTC (permalink / raw)
  To: torvalds; +Cc: x-linux-kernel

Hi

I noticed the moving of arch/i386/kernel/irq.h to include/linux/irq.h in
the 2.3.14 final patch.

I really don't think it is a good idea to move this very i386 specific
definitions in there since the interrupt subsystems on other
architectures are very different from that of the i386. Ie. on the m68k
we do not use the same types or irq descriptors, the IRQ line statuses
make no sense etc. and I am sure it is the same for some of the other
non x86 architectures.

I see that it expects asm/hw_irq.h to be the architecture dependant
stuff, but even the things that made it into include/linux/irq.h are way
to architecture specific.

Putting this include file in include/linux/irq.h with a generic name
like that means someone is going to use it in the generic kernel code at
some point. Having the common kernel code relying on such x86 specific
features is going to be a pain for us to handle at that point.

The only things I can see being architecture independant is the
irq_{enter,exit}() stuff and even then I am not sure the SMP versions
are portable enough for non x86 machines (being able to do test_bit() on
a spin lock is fairly implementation specific).

I really think those bits should be moved out of the generic header
files to avoid problems.

Jes

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~1999-08-19 17:47 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
1999-08-19  9:14 irq.h changes in 2.3.14 Jes Sorensen
1999-08-19 17:45 ` Linus Torvalds

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®