From: James Bottomley <James.Bottomley@SteelEye.com>
To: Greg KH <greg@kroah.com>
Cc: James Bottomley <James.Bottomley@SteelEye.com>,
mochel@osdl.org, linux-kernel@vger.kernel.org
Subject: Re: Problems with 2.5.14 PCI reorg and non-PCI architectures
Date: Thu, 09 May 2002 12:47:46 -0400 [thread overview]
Message-ID: <200205091647.g49GlkG02757@localhost.localdomain> (raw)
In-Reply-To: Message from Greg KH <greg@kroah.com> of "Thu, 09 May 2002 08:23:29 PDT." <20020509152329.GC17158@kroah.com>
greg@kroah.com said:
> No wait, the NCR driver needs Microchannel, is that true?
Correct. the two drivers (lasi700 and NCR_D700) both use 53c700 to drive the
chip core, but they take care of interfacing to the local bus, whatever it is.
The chip core (which is bus independent) still has to allocate consistent
memory for the chip mailbox (although I suppose I could alter the bus drivers
to pass in a pointer to a pre-allocated region). I can't get away without
using pci_sync_single et al. in the bus independent driver, though.
> I would like to push back and ask why you are calling a pci_* function
> from a driver that does not need pci. Yes, I know it's a nice,
> generic function, but that hasn't stopped people from rewriting that
> same function a number of times in different forms in different places
> in the tree:)
The 53c700 core must be able to use synchronous memory (if it can) on parisc.
The only global call for this is pci_alloc_consistent (and its use is advised
in Documentation/DMA-mapping.txt). Obviously, x86 is fully synchronous
anyway, so it only needs to support the call as a type of nop.
> In a perfect world, we should probably create a function like:
> void *alloc_consistent (int flags, size_t size, dma_addr_t
> *dma_handle); to solve everyone's needs, but I'm not volunteering to
> do that :)
I agree with this. Debate around this naming issue came up in the parisc
groups (again because we need consistent allocations and some legacy machines
don't have PCI busses). The official response them was use
pci_alloc_consistent and don't worry about it seeming to be a pci specific
function. Really, it is only legacy machines that are non-pci, so I suppose
it does make some sense to have them as special cases of pci specific
functions.
> I'll go move the file and send the changeset to Linus.
Thanks!
James
next prev parent reply other threads:[~2002-05-09 16:47 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2002-05-08 23:11 James Bottomley
2002-05-09 8:44 ` Greg KH
2002-05-09 13:00 ` James Bottomley
2002-05-09 15:23 ` Greg KH
2002-05-09 16:47 ` James Bottomley [this message]
2002-05-09 16:52 ` [BK PATCH] PCI reorg fix Greg KH
2002-05-09 18:06 ` Patrick Mochel
2002-05-09 17:15 ` Greg KH
2002-05-09 18:26 ` James Bottomley
2002-05-09 18:23 ` Kai Germaschewski
2002-05-09 18:26 ` Patrick Mochel
2002-05-09 18:46 ` Kai Germaschewski
2002-05-09 19:45 ` Martin Dalecki
2002-05-09 21:34 ` James Bottomley
2002-05-09 20:51 ` Martin Dalecki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200205091647.g49GlkG02757@localhost.localdomain \
--to=james.bottomley@steeleye.com \
--cc=greg@kroah.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mochel@osdl.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®