mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jean Tourrilhes <jt@bougret.hpl.hp.com>
To: Adrian Bunk <bunk@fs.tum.de>
Cc: James McKenzie <james@fishsoup.dhs.org>,
	linux-kernel@vger.kernel.org, trivial@rustcorp.com.au
Subject: Re: [2.5 patch] allow only one Toshiba Type-O IR Port driver in the kernel
Date: Mon, 21 Oct 2002 10:32:33 -0700	[thread overview]
Message-ID: <20021021173233.GA20616@bougret.hpl.hp.com> (raw)
In-Reply-To: <Pine.NEB.4.44.0210201640090.28761-100000@mimas.fachschaften.tu-muenchen.de>

On Sun, Oct 20, 2002 at 04:44:11PM +0200, Adrian Bunk wrote:
> 
> Trying to compile both Toshiba Type-O IR Port drivers into the kernel
> fails with the following error:
> 
> <--  snip  -->
> 
> ...
>    ld -m elf_i386  -r -o drivers/net/irda/built-in.o ...
> drivers/net/irda/donauboe.o: In function `toshoboe_init':
> drivers/net/irda/donauboe.o(.init.text+0x0): multiple definition of
> `toshoboe_init'
> drivers/net/irda/toshoboe.o(.init.text+0x0): first defined here
> make[3]: *** [drivers/net/irda/built-in.o] Error 1
> 
> <--  snip  -->
> 
> The following patch allows the builing of the old driver only when the new
> one isn't compiled into the kernel.
> 
> Additionally it indents three lines inside an if ... fi that weren't
> indented.

	Adrian,

	Thanks very much for the report. I personally uses modules,
and I would prefer the ability to compile both modules, so that people
can try both without having to recompile their kernel.
	I think a much better patch (and simpler in the long term)
would be to just rename 'toshoboe_init' to 'donauboe_init' (plus the
few other offending function). This is a case where the name doesn't
really matter.
	What do you think ?

	Jean

  reply	other threads:[~2002-10-21 17:26 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2002-10-20 14:44 Adrian Bunk
2002-10-21 17:32 ` Jean Tourrilhes [this message]
2002-10-29 15:26   ` Adrian Bunk
2002-10-29 17:29     ` Jean Tourrilhes
2002-10-30 12:14       ` Adrian Bunk

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20021021173233.GA20616@bougret.hpl.hp.com \
    --to=jt@bougret.hpl.hp.com \
    --cc=bunk@fs.tum.de \
    --cc=james@fishsoup.dhs.org \
    --cc=jt@hpl.hp.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=trivial@rustcorp.com.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®