mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* 2.5.49: "hdb: cannot handle device with more than 16 heads"
@ 2002-11-26 17:50 Eric Buddington
  2002-11-26 18:38 ` Alan Cox
  2002-11-26 18:53 ` Andries Brouwer
  0 siblings, 2 replies; 6+ messages in thread
From: Eric Buddington @ 2002-11-26 17:50 UTC (permalink / raw)
  To: linux-kernel

This is 2.5.49, compiled for i386 with almost all modules using
gcc-3.2.  On my PII Omnibook 4100, the messages stop after the first
hda: message (where it would normally identify the drive). The same
problem existed in 2.4.48.

When booting on my Athlon (hda:Maxtor 5T040H4, hdb: Maxtor 90840D6), I
get the following boot messages:

pty: 256 Unix98 ptys configured
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 66MHz system bus speed for PIO modes
hdc: _NEC CD-RW NR-7800A, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
end_request: I/O error, dev hdc, sector 0
hdc: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.12
hda: 8032MB, CHS=1024/255/63
hdb: 8008MB, CHS=1021/255/63
 hda:hda: read_intr: status=0x59.
hda: read_intr: error=0x10.
hda: read_intr: status=0x59.
hda: read_intr: error=0x10.
hda: read_intr: status=0x59.
hda: read_intr: error=0x10.
hda: read_intr: status=0x59.
hda: read_intr: error=0x10.
hda: cannot handle device with more than 16 heads - giving up
end_request: I/O error, dev hda, sector 16450552
Buffer I/O error on device hd(3,0), logical block 2056319
hda: read_intr: status=0x59.
hda: read_intr: error=0x10.
hda: read_intr: status=0x59.
hda: read_intr: error=0x10.
hda: read_intr: status=0x59.
hda: read_intr: error=0x10.
hda: read_intr: status=0x59.
hda: read_intr: error=0x10.
hda: cannot handle device with more than 16 heads - giving up
end_request: I/O error, dev hda, sector 16450552
Buffer I/O error on device hd(3,0),
...
hdb: read_intr: status=0x59.
hdb: read_intr: error=0x10.
hdb: read_intr: status=0x59.
hdb: read_intr: error=0x10.
hdb: read_intr: status=0x59.
hdb: read_intr: error=0x10.
hdb: read_intr: status=0x59.
hdb: read_intr: error=0x10.
hdb: cannot handle device with more than 16 heads - giving up
end_request: I/O error, dev hdb, sector 16402361
Buffer I/O error on device hd(3,64), logical block 16402361
...

...and eventually panics for lack of a root fs.


-Eric




^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: 2.5.49: "hdb: cannot handle device with more than 16 heads"
  2002-11-26 17:50 2.5.49: "hdb: cannot handle device with more than 16 heads" Eric Buddington
@ 2002-11-26 18:38 ` Alan Cox
  2002-11-26 20:30   ` Eric Buddington
  2002-11-26 18:53 ` Andries Brouwer
  1 sibling, 1 reply; 6+ messages in thread
From: Alan Cox @ 2002-11-26 18:38 UTC (permalink / raw)
  To: ebuddington; +Cc: Linux Kernel Mailing List

On Tue, 2002-11-26 at 17:50, Eric Buddington wrote:
> This is 2.5.49, compiled for i386 with almost all modules using
> gcc-3.2.  On my PII Omnibook 4100, the messages stop after the first
> hda: message (where it would normally identify the drive). The same
> problem existed in 2.4.48.
> 
> When booting on my Athlon (hda:Maxtor 5T040H4, hdb: Maxtor 90840D6), I
> get the following boot messages:

Looks like you used the old MFM/RLL driver for hda. That wont work with
new drives. 


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: 2.5.49: "hdb: cannot handle device with more than 16 heads"
  2002-11-26 17:50 2.5.49: "hdb: cannot handle device with more than 16 heads" Eric Buddington
  2002-11-26 18:38 ` Alan Cox
@ 2002-11-26 18:53 ` Andries Brouwer
  1 sibling, 0 replies; 6+ messages in thread
From: Andries Brouwer @ 2002-11-26 18:53 UTC (permalink / raw)
  To: ebuddington; +Cc: linux-kernel

On Tue, Nov 26, 2002 at 12:50:19PM -0500, Eric Buddington wrote:

> This is 2.5.49, compiled for i386 with almost all modules using
> gcc-3.2.  On my PII Omnibook 4100, the messages stop after the first
> hda: message (where it would normally identify the drive). The same
> problem existed in 2.4.48.
> 
> When booting on my Athlon (hda:Maxtor 5T040H4, hdb: Maxtor 90840D6), I
> get the following boot messages:
> 
> hda: cannot handle device with more than 16 heads - giving up

You don't want to use the new ide driver instead of the legacy hd one?

Andries

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: 2.5.49: "hdb: cannot handle device with more than 16 heads"
  2002-11-26 18:38 ` Alan Cox
@ 2002-11-26 20:30   ` Eric Buddington
  2002-11-27  0:33     ` Alan Cox
  0 siblings, 1 reply; 6+ messages in thread
From: Eric Buddington @ 2002-11-26 20:30 UTC (permalink / raw)
  To: Linux Kernel Mailing List

On Tue, Nov 26, 2002 at 06:38:25PM +0000, Alan Cox wrote:
> On Tue, 2002-11-26 at 17:50, Eric Buddington wrote:
> > This is 2.5.49, compiled for i386 with almost all modules using
> > gcc-3.2.  On my PII Omnibook 4100, the messages stop after the first
> > hda: message (where it would normally identify the drive). The same
> > problem existed in 2.4.48.
> > 
> > When booting on my Athlon (hda:Maxtor 5T040H4, hdb: Maxtor 90840D6), I
> > get the following boot messages:
> 
> Looks like you used the old MFM/RLL driver for hda. That wont work with
> new drives. 

Thanks. Disks and partitions are now recognized, but root still won't
mount. Reiserfs (the root fs) is compiled in, along with IDE disk
support.  I tried getting rid of the advanced partitopn types options,
which eliminated the MS-DOS partition table message, but did not
otherwise change things.

The hdc error is also unexpected, unless it's simply the result of no
CD in the drive.

I hope this isn't another silly thing I'm missing.

-Eric

---------------------------------------------------------------------

pty: 256 Unix98 ptys configured
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 66MHz system bus speed for PIO modes
hda: Maxtor 5T040H4, ATA DISK drive
hdb: Maxtor 90840D6, ATA DISK drive
hdc: _NEC CD-RW NR-7800A, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: host protected area => 1
hda: 80043264 sectors (40982 MB) w/2048KiB Cache, CHS=4982/255/63
 /dev/ide/host0/bus0/target0/lun0:<7>ldm_validate_partition_table(): Found an MS
-DOS partition table, not a dynamic disk.
 p1 p4
hdb: host protected area => 1
hdb: 16406208 sectors (8400 MB) w/256KiB Cache, CHS=1021/255/63
 /dev/ide/host0/bus0/target1/lun0:<7>ldm_validate_partition_table(): Found an MS
-DOS partition table, not a dynamic disk.
 p1
end_request: I/O error, dev hdc, sector 0
hdc: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.12
serio: i8042 AUX port at 0x60,0x64 irq 12
input: AT Set 2 keyboard on isa0060/serio0
serio: i8042 KBD port at 0x60,0x64 irq 1
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
Linux IP multicast router 0.06 plus PIM-SM
VFS: Cannot open root device "hda1" or 03:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 03:01

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: 2.5.49: "hdb: cannot handle device with more than 16 heads"
  2002-11-26 20:30   ` Eric Buddington
@ 2002-11-27  0:33     ` Alan Cox
  2002-11-27  3:32       ` Eric Buddington
  0 siblings, 1 reply; 6+ messages in thread
From: Alan Cox @ 2002-11-27  0:33 UTC (permalink / raw)
  To: ebuddington; +Cc: Linux Kernel Mailing List

On Tue, 2002-11-26 at 20:03, Eric Buddington wrote:
> Thanks. Disks and partitions are now recognized, but root still won't
> mount. Reiserfs (the root fs) is compiled in, along with IDE disk
> support.  I tried getting rid of the advanced partitopn types options,
> which eliminated the MS-DOS partition table message, but did not
> otherwise change things.
> 
> The hdc error is also unexpected, unless it's simply the result of no
> CD in the drive.
> 
> I hope this isn't another silly thing I'm missing.

I'd start by turning off devfs


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: 2.5.49: "hdb: cannot handle device with more than 16 heads"
  2002-11-27  0:33     ` Alan Cox
@ 2002-11-27  3:32       ` Eric Buddington
  0 siblings, 0 replies; 6+ messages in thread
From: Eric Buddington @ 2002-11-27  3:32 UTC (permalink / raw)
  To: Alan Cox; +Cc: ebuddington, Linux Kernel Mailing List

On Wed, Nov 27, 2002 at 12:33:23AM +0000, Alan Cox wrote:
> On Tue, 2002-11-26 at 20:03, Eric Buddington wrote:
> > Thanks. Disks and partitions are now recognized, but root still won't
> > mount. Reiserfs (the root fs) is compiled in, along with IDE disk
> > support.  I tried getting rid of the advanced partitopn types options,
> > which eliminated the MS-DOS partition table message, but did not
> > otherwise change things.
> > 
> > The hdc error is also unexpected, unless it's simply the result of no
> > CD in the drive.
> > 
> > I hope this isn't another silly thing I'm missing.
> 
> I'd start by turning off devfs

This eliminates the problem, at least enough to mount the root fs. My
system relies on devfs though (/dev is unpopulated), so I can't say
much more than that.

I should mention that the kernel was being passed "root=/dev/hda1" as
an option.

-Eric


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2002-11-27  3:25 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2002-11-26 17:50 2.5.49: "hdb: cannot handle device with more than 16 heads" Eric Buddington
2002-11-26 18:38 ` Alan Cox
2002-11-26 20:30   ` Eric Buddington
2002-11-27  0:33     ` Alan Cox
2002-11-27  3:32       ` Eric Buddington
2002-11-26 18:53 ` Andries Brouwer

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®