From: Manuel Estrada Sainz <ranty-bulk@ranty.pantax.net>
To: Pavel Roskin <proski@gnu.org>
Cc: LKML <linux-kernel@vger.kernel.org>,
Jeff Garzik <jgarzik@pobox.com>,
orinoco-devel@lists.sourceforge.net, jt@hpl.hp.com
Subject: Re: [Orinoco-devel] orinoco_usb Request For Comments
Date: Sat, 28 Jun 2003 00:16:06 +0200 [thread overview]
Message-ID: <20030627221605.GB1783@ranty.pantax.net> (raw)
In-Reply-To: <Pine.LNX.4.56.0306271736190.12316@marabou.research.att.com>
On Fri, Jun 27, 2003 at 05:49:59PM -0400, Pavel Roskin wrote:
> On Fri, 27 Jun 2003, Manuel Estrada Sainz wrote:
>
> > Actually, orinoco-exp could be used as a test bed for monitor mode,
> > scanning, hermesap, ... and merge it back to the standard orinoco as it
> > probes to work right. For now it should be a test bed for USB support :)
> [snip]
> > > If you are going to create a separate driver, you should rename the
> > > module. I wouldn't bother with separate modules. Just link hermes,
> > > orinoco and orinoco_usb to one driver, say orinoco-usb.
> >
> > No, I want to stay as similar to standard orinoco as possible to make
> > merging easier.
>
> OK, I understand you are suggesting to fork an experimental branch. Then
> I suggest that we stop this discussion in LKML and return to orinoco-devel
> to discuss the situation.
>
> There is nothing wrong with the fork if all other ways to keep the code
> together have been exhausted. But since this wasn't discussed in the
> orinoco-devel mailing list, I think it's too early to fork.
>
> One thing we haven't considered is restructuring the code to separate
> common and different parts of the USB and the non-USB drivers.
>
> The firmware issue has been solved in the 2.5 kernels, so it shouldn't
> prevent David from including your code.
Monday the latest I'll start a thread in orinoco-devel, unless you do
it first :)
Regards
Manuel
--
--- Manuel Estrada Sainz <ranty@debian.org>
<ranty@bigfoot.com>
<ranty@users.sourceforge.net>
------------------------ <manuel.estrada@hispalinux.es> -------------------
Let us have the serenity to accept the things we cannot change, courage to
change the things we can, and wisdom to know the difference.
next prev parent reply other threads:[~2003-06-27 22:02 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2003-06-26 20:58 Manuel Estrada Sainz
2003-06-26 21:41 ` Oliver Neukum
2003-06-26 23:09 ` Manuel Estrada Sainz
2003-06-27 8:27 ` Manuel Estrada Sainz
[not found] ` <Pine.LNX.4.53.0306271213350.5135@fachschaft.cup.uni-muenchen.de>
2003-07-02 10:17 ` Manuel Estrada Sainz
2003-07-02 14:02 ` Oliver Neukum
2003-06-26 22:03 ` [Orinoco-devel] " Pavel Roskin
2003-06-26 22:50 ` Manuel Estrada Sainz
2003-06-27 21:49 ` Pavel Roskin
2003-06-27 22:16 ` Manuel Estrada Sainz [this message]
2003-06-27 2:55 ` David Gibson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20030627221605.GB1783@ranty.pantax.net \
--to=ranty-bulk@ranty.pantax.net \
--cc=jgarzik@pobox.com \
--cc=jt@hpl.hp.com \
--cc=linux-kernel@vger.kernel.org \
--cc=orinoco-devel@lists.sourceforge.net \
--cc=proski@gnu.org \
--cc=ranty@debian.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®