mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* nfs errors with xfs filesystem (2.4.x kernel)
@ 2004-03-29 20:51 F. Baker
  2004-03-30  0:57 ` Trond Myklebust
  0 siblings, 1 reply; 2+ messages in thread
From: F. Baker @ 2004-03-29 20:51 UTC (permalink / raw)
  To: linux-kernel


We have several Linux x86 workstations here.  In "dmesg" on
these PCs I see a lot of errors that read:

NFS: Server wrote less than requested.

 AND

eth0: TX underrun, threshold adjusted.

This message appears whenever someone logged into the
Mandrake/RH/whatever box (with NFS autofs mounting in his/her home
directory) tries to write something to an nfs-mounted directory
(usually the home directory).  Even small files of 1.5 MB or so often
generate something such as "I/O error" when saving a file (really 
small files usually get saved fine).  And the home directory is always
based in an SGI (O2, Indy, Onyx) with xfs file system. 

Intra-SGI these transfer take place perfectly, but
Mandrake/RH/OtherLinux generates these problems.

Has anyone seen this error before and does anyone know how 
to get around it?  The kernel used is 2.4.22-28 for most
of the Mandrake boxes, or at least 2.4.x anyway.  We have not
gone to 2.6.x yet.

Thanks in advance.

baker@deslab.mit.edu

PS: Interestingly:

	cp file1 file2
where file1 is sufficiently large (1 MB or bigger) always fails the 
first time, but often does a partial write.  

If you then delete file2 and try the command anew, it works fine.
Very strange indeed.


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: nfs errors with xfs filesystem (2.4.x kernel)
  2004-03-29 20:51 nfs errors with xfs filesystem (2.4.x kernel) F. Baker
@ 2004-03-30  0:57 ` Trond Myklebust
  0 siblings, 0 replies; 2+ messages in thread
From: Trond Myklebust @ 2004-03-30  0:57 UTC (permalink / raw)
  To: F. Baker; +Cc: linux-kernel

På må , 29/03/2004 klokka 15:51, skreiv F. Baker:

> PS: Interestingly:
> 
> 	cp file1 file2
> where file1 is sufficiently large (1 MB or bigger) always fails the 
> first time, but often does a partial write.  
> 
> If you then delete file2 and try the command anew, it works fine.
> Very strange indeed.

Have you read the FAQ entry on http://nfs.sourceforge.net/#faq_e4

Cheers,
  Trond

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2004-03-30  0:57 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2004-03-29 20:51 nfs errors with xfs filesystem (2.4.x kernel) F. Baker
2004-03-30  0:57 ` Trond Myklebust

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®