mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Randy.Dunlap" <rddunlap@osdl.org>
To: Ryan Arnold <rsa@us.ibm.com>
Cc: akpm@osdl.org, linux-kernel@vger.kernel.org, paulus@samba.org
Subject: Re: [announce][draft3] HVCS for inclusion in 2.6 tree
Date: Tue, 27 Jul 2004 15:50:11 -0700	[thread overview]
Message-ID: <20040727155011.77897e68.rddunlap@osdl.org> (raw)
In-Reply-To: <1090958938.14771.35.camel@localhost>

On Tue, 27 Jul 2004 15:08:58 -0500 Ryan Arnold wrote:

| Ok Andrew, here is draft3 of my patch.  This patch contains fixes for
| the following items:
| 
| 
| Thanks for the kthread suggestions.  The kthread API is awesome.  My
| stress tests seem to be going very well.  So, if you don't have any more
| comments....

I do.  (this is for the first 1000 lines of the patch... more to come)

+struct hvcs_partner_info {
+	/* list management */
+	struct list_head node;
+	/* partner unit address */
+	unsigned int unit_address;
+	/*partner partition ID */
+	unsigned int partition_ID;
+	/* CLC (79 chars) + 1 Null-term char */
+	char location_code[HVCS_CLC_LENGTH + 1];
+};

Ugly comments style.  Which comment goes with which
data?  Commenting data can be very helpful, but most of these
are close to useless since they are so obvious.
And put a space after "/*".

+/* Convert arch specific return codes into relevant errnos.  The hvcs
+ * functions aren't performance sensitive, so this conversion isn't an
+ * issue. */

Long-comment style is
/*
 * line1
 * line2
 * lineN
 */
(in multiple places).


+int hvcs_convert(long to_convert)
+{
+	switch (to_convert) {
+		case H_Success:
+			return 0;
+		case H_Parameter:
+			return -EINVAL;
+		case H_Hardware:
+			return -EIO;
+		case H_Busy:

Can these H_values be converted from that coding style?

+/* Helper function for hvcs_get_partner_info */
+int hvcs_next_partner(unsigned int unit_address, unsigned long last_p_partition_ID, unsigned long last_p_unit_address, unsigned long *pi_buff)

Split the function line. (multiple places)

+	memset(pi_buff,0x00,PAGE_SIZE);

Use spaces after commas.


+		/* This is a very small struct and will be freed soon */
+		next_partner_info = kmalloc(sizeof(struct hvcs_partner_info),
+				GFP_ATOMIC);

Where is it freed?

+	  will depend on arch specific apis exported from hvcserver.ko

"APIs"

+	  To compile this driver as a module, choose M here: the
+	  module will be called hvcs.ko.  Additionally, this module
+	  will depend on arch specific apis exported from hvcserver.ko
+	  which will also be compiled when this driver is built as a
+	  module.
+
 config PC9800_OLDLP

This patch segment won't apply since PC9800 has been removed.

+#define __ALIGNED__	__attribute__((__aligned__(8)))

Why aligned? why 8?  (just curious)  Could use a comment if it's important.



+			 * we commited to delivering it.  But don't try to wake
+			 * a non-existant tty. */

				non-existent


+	/* remove the read masks*/
			   masks */

+		for (i=0;got && i<got;i++)

	add spaces for readability:
		for (i = 0; got && i < got; i++)

+	if (!got){
	if (!got) {



--
~Randy

  reply	other threads:[~2004-07-27 23:12 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-07-14 15:42 [announce] " Ryan Arnold
2004-07-18  2:00 ` Paul Mackerras
2004-07-19 15:54   ` Ryan Arnold
2004-07-22 20:26   ` Ryan Arnold
2004-07-23  1:57     ` Andrew Morton
2004-07-26 14:41       ` Ryan Arnold
2004-07-23  2:16     ` Andrew Morton
2004-07-27 20:08       ` [announce][draft3] " Ryan Arnold
2004-07-27 22:50         ` Randy.Dunlap [this message]
2004-07-28 16:39           ` Ryan Arnold
2004-07-28 20:12             ` Randy.Dunlap
2004-07-28 20:18               ` [announce][draft4] " Ryan Arnold
2004-07-29 17:41                 ` Jeff Garzik
2004-08-02 14:24                   ` Ryan Arnold
2004-07-28 20:36               ` [announce][draft3] " Paul Mackerras
2004-07-28 17:00           ` Ryan Arnold
2004-07-27 23:02         ` Randy.Dunlap
2004-07-23  2:21     ` [announce] " Andrew Morton
2004-07-26 12:57       ` Ryan Arnold
2004-07-23  2:29     ` Andrew Morton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20040727155011.77897e68.rddunlap@osdl.org \
    --to=rddunlap@osdl.org \
    --cc=akpm@osdl.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=paulus@samba.org \
    --cc=rsa@us.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®