mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg KH <greg@kroah.com>
To: David Brownell <david-b@pacbell.net>
Cc: linux-usb-devel@lists.sourceforge.net, linux-kernel@vger.kernel.org
Subject: Re: [linux-usb-devel] [RFC PATCH] debugfs - yet another in-kernel file system
Date: Fri, 10 Dec 2004 17:39:30 -0800	[thread overview]
Message-ID: <20041211013930.GB12846@kroah.com> (raw)
In-Reply-To: <200412101729.01155.david-b@pacbell.net>

On Fri, Dec 10, 2004 at 05:29:01PM -0800, David Brownell wrote:
> On Thursday 09 December 2004 4:50 pm, Greg KH wrote:
> > What if there was a in-kernel filesystem that was explicitly just for
> > putting debugging stuff? ?Some place other than proc and sysfs, and that
> > was easier than both of them to use. ?Yet it needed to also be able to
> > handle complex stuff like seq file and raw file_ops if needed.
> 
> The problem with sysfs here is:  no seq_file support.
> Otherwise it solves the basic "where to put the debug
> files associated with "device X" or "driver Y" problems
> in a good non-confusing way:  there are directories
> already set up for devices and for drivers.

Yes, but that's a design decision for sysfs.  no seq_file support is a
feature, not a shortcoming :)

> The problem with procfs here is that it doesn't have
> such a naming solution:  there's no automatic mapping
> betwen a /proc/driver/...file and its device, or vice
> versa.  That issue is shared with debugfs.

Agreed.

> Couldn't debugfs just be a thin shim on top of sysfs,
> adding seq_file support?  Or on top of procfs, adding
> device/driver naming domains, and maybe file-per-value
> read/write support for drivers that want them?

Ick.

> What I'd really want out of a debug file API is to resolve
> the naming issues, work with seq_file, and "softly and
> silently vanish away".  I think this patch has the last
> two, but not the first one!

I considered adding a kobject as a paramater to the debugfs interface.
The file created would be equal to the path that the kobject has.  Would
that work for you?

thanks,

greg k-h

  reply	other threads:[~2004-12-11  1:40 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-12-10  0:50 Greg KH
2004-12-10  0:55 ` [RFC PATCH] convert uhci-hcd to use debugfs Greg KH
2004-12-10 14:15   ` Josh Boyer
2004-12-10 15:27     ` Greg KH
2004-12-10 16:21       ` Josh Boyer
2004-12-10 17:17         ` Comments on new kernel dev. model Peter Karlsson
2004-12-10 23:44           ` Greg KH
2004-12-10  7:07 ` [RFC PATCH] debugfs - yet another in-kernel file system Jan Engelhardt
2004-12-10  7:54   ` Greg KH
2004-12-10  8:00     ` Jan Engelhardt
2004-12-10 16:02       ` Greg KH
2004-12-10 14:46 ` Josh Boyer
2004-12-10 15:30   ` Greg KH
2004-12-10 16:26     ` Josh Boyer
2004-12-10 17:21 ` Jörn Engel
2004-12-10 17:35   ` Greg KH
2004-12-10 18:29     ` Jörn Engel
2004-12-10 19:38 ` Roland Dreier
2004-12-11  1:29 ` [linux-usb-devel] " David Brownell
2004-12-11  1:39   ` Greg KH [this message]
2004-12-11  2:02     ` David Brownell
2004-12-11  2:05       ` Greg KH
2004-12-11  2:26     ` Roland Dreier
2004-12-11  2:32       ` Greg KH
2004-12-11 13:23         ` Roland Dreier

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20041211013930.GB12846@kroah.com \
    --to=greg@kroah.com \
    --cc=david-b@pacbell.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb-devel@lists.sourceforge.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome