mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Pavel Machek <pavel@ucw.cz>
To: Christoph Lameter <christoph@lameter.com>
Cc: akpm@osdl.org, torvalds@osdl.org, linux-kernel@vger.kernel.org
Subject: Re: Alternative to TIF_FREEZE -> a notifier in the task_struct?
Date: Thu, 28 Jul 2005 21:34:34 +0200	[thread overview]
Message-ID: <20050728193433.GA1856@elf.ucw.cz> (raw)
In-Reply-To: <Pine.LNX.4.62.0507280804310.23907@graphe.net>

Hi!

> > I guess I'd prefer if you left "refrigerator()" and "try_to_freeze()"
> > functions in; there are about 1000 drivers that know/use them, and
> > some patches are probably in the queue....
> 
> Yeah but then other uses also could benefit from that.

Just don't rename try_to_freeze() to whatever... make it do whatever
you need, but don't change the name so that we don't have to fix it at
1000 places...

Or introduce new name, but keep try_to_freeze in, just calling "new"
function, so all 1000 usews don't have to be changed at the same time.

								Pavel
-- 
teflon -- maybe it is a trademark, but it should not be.

  reply	other threads:[~2005-07-28 19:38 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <200507260340.j6Q3eoGh029135@shell0.pdx.osdl.net>
2005-07-28  3:30 ` Christoph Lameter
2005-07-28  7:41   ` Pavel Machek
2005-07-28 15:05     ` Christoph Lameter
2005-07-28 19:34       ` Pavel Machek [this message]
2005-07-28 19:49         ` Christoph Lameter
2005-07-28 19:54         ` [PATCH 1/4] Task notifier: Allow the removal of a notifier from the notifier handler Christoph Lameter
2005-07-28 19:55           ` [PATCH 2/4] Task notifier: Implement todo list in task_struct Christoph Lameter
2005-07-28 19:57             ` [PATCH 3/4] Task notifier: Make suspend code SMP safe using the todo list in the task struct Christoph Lameter
2005-07-28 19:59               ` [PATCH 4/4] Task notifier: s/try_to_freeze/try_todo_list/ in some drivers [optional] Christoph Lameter
2005-07-28 21:27             ` [PATCH 2/4] Task notifier: Implement todo list in task_struct Pavel Machek
2005-07-28 21:32               ` Pavel Machek
2005-07-28 21:57                 ` Christoph Lameter
2005-07-28 22:12                   ` Pavel Machek
2005-07-28 23:02                     ` Christoph Lameter
2005-07-28 23:27                       ` Andrew Morton
2005-07-29  0:19                         ` Christoph Lameter
2005-08-09  1:32                   ` Nigel Cunningham
2005-08-09  2:01                     ` Christoph Lameter
2005-08-09  3:51                       ` Nigel Cunningham
2005-08-09  4:21                         ` Nigel Cunningham
2005-08-09 17:05                         ` Christoph Lameter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050728193433.GA1856@elf.ucw.cz \
    --to=pavel@ucw.cz \
    --cc=akpm@osdl.org \
    --cc=christoph@lameter.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=torvalds@osdl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®