* [PATCH] mm trivial ia64/acpi breakage
@ 2005-10-17 20:28 Alex Williamson
2005-10-22 3:18 ` Paul Jackson
0 siblings, 1 reply; 2+ messages in thread
From: Alex Williamson @ 2005-10-17 20:28 UTC (permalink / raw)
To: akpm; +Cc: linux-kernel
The git-acpi.patch changed the name of the "id" member of the
acpi_resource structure, but missed the below user. Updating to the new
name.
Signed-off-by: Alex Williamson <alex.williamson@hp.com>
diff -r 6bf6e9fcc962 arch/ia64/kernel/acpi-ext.c
--- a/arch/ia64/kernel/acpi-ext.c Sun Oct 16 22:44:53 2005
+++ b/arch/ia64/kernel/acpi-ext.c Mon Oct 17 14:27:14 2005
@@ -35,7 +35,7 @@
struct acpi_vendor_descriptor *descriptor;
u32 length;
- if (resource->id != ACPI_RSTYPE_VENDOR)
+ if (resource->type != ACPI_RSTYPE_VENDOR)
return AE_OK;
vendor = (struct acpi_resource_vendor *)&resource->data;
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] mm trivial ia64/acpi breakage
2005-10-17 20:28 [PATCH] mm trivial ia64/acpi breakage Alex Williamson
@ 2005-10-22 3:18 ` Paul Jackson
0 siblings, 0 replies; 2+ messages in thread
From: Paul Jackson @ 2005-10-22 3:18 UTC (permalink / raw)
To: Alex Williamson; +Cc: akpm, linux-kernel
Alex wrote:
> - if (resource->id != ACPI_RSTYPE_VENDOR)
> + if (resource->type != ACPI_RSTYPE_VENDOR)
Yup - ia64 *.mm builds much better with this. Thanks.
--
I won't rest till it's the best ...
Programmer, Linux Scalability
Paul Jackson <pj@sgi.com> 1.925.600.0401
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2005-10-22 3:19 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2005-10-17 20:28 [PATCH] mm trivial ia64/acpi breakage Alex Williamson
2005-10-22 3:18 ` Paul Jackson
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome