mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] i386 rename X86_FEATURE_DTES to X86_FEATURE_DS
@ 2006-10-06  9:35 Stephane Eranian
  0 siblings, 0 replies; only message in thread
From: Stephane Eranian @ 2006-10-06  9:35 UTC (permalink / raw)
  To: linux-kernel; +Cc: Stephane Eranian

Hi,

Here is a patch (used by perfmon2) that renames X86_FEATURE_DTES
to X86_FEATURE_DS to match Intel's documentation for the Debug Store
save area on i386. The patch also adds cpu_has_ds.

changelog:
        - rename X86_FEATURE_DTES to X86_FEATURE_DS to match documentation
        - adds cpu_has_ds to test for X86_FEATURE_DS

signed-off-by: stephane eranian <eranian@hpl.hp.com>


diff --git a/include/asm-i386/cpufeature.h b/include/asm-i386/cpufeature.h
index d314ebb..69ce350 100644
--- a/include/asm-i386/cpufeature.h
+++ b/include/asm-i386/cpufeature.h
@@ -31,7 +31,7 @@ #define X86_FEATURE_PAT		(0*32+16) /* Pa
 #define X86_FEATURE_PSE36	(0*32+17) /* 36-bit PSEs */
 #define X86_FEATURE_PN		(0*32+18) /* Processor serial number */
 #define X86_FEATURE_CLFLSH	(0*32+19) /* Supports the CLFLUSH instruction */
-#define X86_FEATURE_DTES	(0*32+21) /* Debug Trace Store */
+#define X86_FEATURE_DS		(0*32+21) /* Debug Store */
 #define X86_FEATURE_ACPI	(0*32+22) /* ACPI via MSR */
 #define X86_FEATURE_MMX		(0*32+23) /* Multimedia Extensions */
 #define X86_FEATURE_FXSR	(0*32+24) /* FXSAVE and FXRSTOR instructions (fast save and restore */
@@ -134,6 +134,7 @@ #define cpu_has_phe		boot_cpu_has(X86_FE
 #define cpu_has_phe_enabled	boot_cpu_has(X86_FEATURE_PHE_EN)
 #define cpu_has_pmm		boot_cpu_has(X86_FEATURE_PMM)
 #define cpu_has_pmm_enabled	boot_cpu_has(X86_FEATURE_PMM_EN)
+#define cpu_has_ds		boot_cpu_has(X86_FEATURE_DS)
 
 #endif /* __ASM_I386_CPUFEATURE_H */
 

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2006-10-06  9:35 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-10-06  9:35 [PATCH] i386 rename X86_FEATURE_DTES to X86_FEATURE_DS Stephane Eranian

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®