From: Josef Sipek <jsipek@fsl.cs.sunysb.edu>
To: "Josef 'Jeff' Sipek" <jsipek@cs.sunysb.edu>
Cc: linux-kernel@vger.kernel.org, torvalds@osdl.org, akpm@osdl.org,
hch@infradead.org, viro@ftp.linux.org.uk,
linux-fsdevel@vger.kernel.org, mhalcrow@us.ibm.com
Subject: Re: Unionfs: Stackable namespace unification filesystem
Date: Tue, 5 Dec 2006 10:13:24 -0500 [thread overview]
Message-ID: <20061205151323.GC20520@filer.fsl.cs.sunysb.edu> (raw)
In-Reply-To: <1165235468365-git-send-email-jsipek@cs.sunysb.edu>
On Mon, Dec 04, 2006 at 07:30:33AM -0500, Josef 'Jeff' Sipek wrote:
> The following patches are in a git repo at:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/jsipek/unionfs.git
>
> (master.kernel.org:/pub/scm/linux/kernel/git/jsipek/unionfs.git)
>
> The repository contains the following 35 commits (also available as patches
> in replies to this email).
Wow, I completely forgot to say what changed since the previous posting...
- Added more comments (akpm)
- Cleaned up inode/dentry/file/sb private data structure member names
- Moved struct inode from unionfs_inode_container into unionfs_inode_info
(following ext2's example)
- Renamed {d,i,f,s}topd to UNIONFS_{D,I,F,S} (following almost any fs's
example)
- Removed *_ptr and *_lhs macros, open-coding the assignments (Pekka Enberg)
- Kill wrappers (e.g., unionfs_kill_block_super) (Pekka Enberg)
- Few tiny coding style fixes
- Removed some unnecessary complexity (no need to pass struct file and a
struct dentry for that file to a function - just pass a struct file
and dereference in the function, etc.)
- Removed some unnecessary checks (if (foo) kfree(foo); is completely
redundant as kfree has a null check)
- Changed C++-style comments to C-style comments (Pekka Enberg)
- Use struct kmem_cache instead of kmem_cache_t (Pekka Enberg)
- Use anonymous unions for sioq (Jan Engelhardt)
- Moved some functionality into fsstack (most of it is in -mm already)
All in all about 1/8th of the code was touched in one way or another.
Josef "Jeff" Sipek.
prev parent reply other threads:[~2006-12-05 15:15 UTC|newest]
Thread overview: 76+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-12-04 12:30 Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 01/35] fsstack: Introduce fsstack_copy_{attr,inode}_* Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 02/35] fsstack: Remove unneeded wrapper Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 03/35] eCryptfs: Use fsstack's generic copy inode attr functions Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 04/35] fsstack: Fix up eCryptfs compilation Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 05/35] struct path: Rename Reiserfs's struct path Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 06/35] struct path: Rename DM's " Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 07/35] struct path: Move struct path from fs/namei.c into include/linux Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 08/35] struct path: make eCryptfs a user of struct path Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 09/35] fs/stack.c should #include <linux/fs_stack.h> Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 10/35] fsstack: Make fsstack_copy_attr_all copy inode size Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 11/35] fsstack: Fix up ecryptfs's fsstack usage Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 12/35] Unionfs: Documentation Josef 'Jeff' Sipek
2006-12-05 20:52 ` Jan Engelhardt
2006-12-04 12:30 ` [PATCH 13/35] lookup_one_len_nd - lookup_one_len with nameidata argument Josef 'Jeff' Sipek
2006-12-05 20:53 ` Jan Engelhardt
2006-12-04 12:30 ` [PATCH 14/35] Unionfs: Branch management functionality Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 15/35] Unionfs: Common file operations Josef 'Jeff' Sipek
2006-12-05 21:02 ` Jan Engelhardt
2006-12-08 4:16 ` Josef Sipek
2006-12-08 10:51 ` Jan Engelhardt
2006-12-04 12:30 ` [PATCH 16/35] Unionfs: Copyup Functionality Josef 'Jeff' Sipek
2006-12-05 21:09 ` Jan Engelhardt
2006-12-08 4:43 ` Josef Sipek
2006-12-04 12:30 ` [PATCH 17/35] Unionfs: Dentry operations Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 18/35] Unionfs: File operations Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 19/35] Unionfs: Directory file operations Josef 'Jeff' Sipek
2006-12-05 21:17 ` Jan Engelhardt
2006-12-04 12:30 ` [PATCH 20/35] Unionfs: Directory manipulation helper functions Josef 'Jeff' Sipek
2006-12-05 21:21 ` Jan Engelhardt
2006-12-04 12:30 ` [PATCH 21/35] Unionfs: Inode operations Josef 'Jeff' Sipek
2006-12-05 21:27 ` Jan Engelhardt
2006-12-05 21:50 ` Andrew Morton
2006-12-05 21:53 ` David Miller
2006-12-06 4:12 ` Randy Dunlap
2006-12-07 14:04 ` Theodore Tso
2006-12-07 17:07 ` Andrew Morton
2006-12-07 22:42 ` Randy Dunlap
2006-12-04 12:30 ` [PATCH 22/35] Unionfs: Lookup helper functions Josef 'Jeff' Sipek
2006-12-05 21:29 ` Jan Engelhardt
2006-12-04 12:30 ` [PATCH 23/35] Unionfs: Main module functions Josef 'Jeff' Sipek
2006-12-05 21:32 ` Jan Engelhardt
2006-12-04 12:30 ` [PATCH 24/35] Unionfs: Readdir state Josef 'Jeff' Sipek
2006-12-05 21:40 ` Jan Engelhardt
2006-12-04 12:30 ` [PATCH 25/35] Unionfs: Rename Josef 'Jeff' Sipek
2006-12-04 12:30 ` [PATCH 26/35] Unionfs: Privileged operations workqueue Josef 'Jeff' Sipek
2006-12-05 19:27 ` Jan Engelhardt
2006-12-05 19:50 ` Josef Sipek
2006-12-06 17:32 ` Josef Sipek
2006-12-06 18:46 ` Jan Engelhardt
2006-12-08 2:17 ` Josef Sipek
2006-12-08 10:38 ` Jan Engelhardt
2006-12-08 16:00 ` Josef Sipek
2006-12-08 17:02 ` Jan Engelhardt
2006-12-08 17:43 ` Josef Sipek
2006-12-08 18:03 ` Jan Engelhardt
2006-12-08 18:24 ` Josef Sipek
2006-12-04 12:31 ` [PATCH 27/35] Unionfs: Handling of stale inodes Josef 'Jeff' Sipek
2006-12-04 12:31 ` [PATCH 28/35] Unionfs: Miscellaneous helper functions Josef 'Jeff' Sipek
2006-12-04 12:31 ` [PATCH 29/35] Unionfs: Superblock operations Josef 'Jeff' Sipek
2006-12-07 10:59 ` Jan Engelhardt
2006-12-04 12:31 ` [PATCH 30/35] Unionfs: Helper macros/inlines Josef 'Jeff' Sipek
2006-12-07 11:00 ` Jan Engelhardt
2006-12-04 12:31 ` [PATCH 31/35] Unionfs: Internal include file Josef 'Jeff' Sipek
2006-12-05 19:41 ` Jan Engelhardt
2006-12-04 12:31 ` [PATCH 32/35] Unionfs: Include file Josef 'Jeff' Sipek
2006-12-07 11:01 ` Jan Engelhardt
2006-12-04 12:31 ` [PATCH 33/35] Unionfs: Unlink Josef 'Jeff' Sipek
2006-12-04 12:31 ` [PATCH 34/35] Unionfs: Kconfig and Makefile Josef 'Jeff' Sipek
2006-12-04 12:31 ` [PATCH 35/35] Unionfs: Extended Attributes support Josef 'Jeff' Sipek
2006-12-07 11:04 ` Jan Engelhardt
2006-12-08 5:35 ` Josef Sipek
2006-12-08 10:53 ` Jan Engelhardt
2006-12-04 12:57 ` Unionfs: Stackable namespace unification filesystem bert hubert
2006-12-04 13:04 ` Josef Sipek
2006-12-05 15:13 ` Josef Sipek [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20061205151323.GC20520@filer.fsl.cs.sunysb.edu \
--to=jsipek@fsl.cs.sunysb.edu \
--cc=akpm@osdl.org \
--cc=hch@infradead.org \
--cc=jsipek@cs.sunysb.edu \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mhalcrow@us.ibm.com \
--cc=torvalds@osdl.org \
--cc=viro@ftp.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®