From: Randy Dunlap <randy.dunlap@oracle.com>
To: Roland Dreier <rdreier@cisco.com>
Cc: "Ahmed S. Darwish" <darwish.07@gmail.com>,
Richard Knutsson <ricknu-0@student.ltu.se>,
linux-kernel@vger.kernel.org
Subject: Re: A CodingStyle suggestion
Date: Sat, 3 Feb 2007 16:40:42 -0800 [thread overview]
Message-ID: <20070203164042.237f156b.randy.dunlap@oracle.com> (raw)
In-Reply-To: <aday7neydq9.fsf@cisco.com>
On Sat, 03 Feb 2007 16:21:18 -0800 Roland Dreier wrote:
> > Good catch :). A small grep of `access_ok' reveals that it's always used in the
> > form of:
> > if (!access_ok()) { .. }
> >
> > I can conclude that verbal/imperative methods like `kmalloc, add_work' be
> > checked as:
> > ret = do_work();
> > if (ret) { ... }
> > and predicate methods like `acess_ok, pci_dev_present' be checked like:
> > if (!access_ok) { ... }
> > if (pci_dev_present) { ...}
> >
> > Any comments ?
>
> I don't think that's really the distinction that matters. I think
> really the issue is that assignment within an if is hard to read, so
>
> ret = foo(a, b);
> if (ret) { ... }
>
> is clearly preferred to
>
> if ((ret = foo(a,b))) { ... }
>
> However, in my opinion something like
>
> if (foo(a,b)) { ... }
>
> if perfectly fine if the return value of foo is not needed anywhere
> else. In other words, there's no sense introducing a temporary
> variable to hold the return value if you're never going to do anything
> with it other than check it on the next line.
I agree with Roland's comments here.
And with Tim's about side effects.
---
~Randy
next prev parent reply other threads:[~2007-02-04 0:44 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-02-03 21:58 Ahmed S. Darwish
2007-02-03 21:59 ` Randy Dunlap
2007-02-04 12:48 ` Theodore Tso
2007-02-04 12:55 ` Manu Abraham
2007-02-04 12:57 ` Robert P. J. Day
2007-02-03 22:56 ` Richard Knutsson
2007-02-04 0:05 ` Ahmed S. Darwish
2007-02-04 0:21 ` Roland Dreier
2007-02-04 0:40 ` Randy Dunlap [this message]
2007-02-04 6:35 ` Willy Tarreau
2007-02-04 0:22 ` Tim Schmielau
2007-02-04 0:39 ` Richard Knutsson
2007-02-04 12:10 ` Ahmed S. Darwish
2007-02-04 12:36 ` Manu Abraham
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070203164042.237f156b.randy.dunlap@oracle.com \
--to=randy.dunlap@oracle.com \
--cc=darwish.07@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=rdreier@cisco.com \
--cc=ricknu-0@student.ltu.se \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®