mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/5] partitions: Changes to fs/partitions for readability and efficiency
@ 2007-04-08  3:33 John Anthony Kazos Jr.
  2007-04-08  3:38 ` [PATCH 1/5] partitions: Touch up comments for check.h and ibm.h John Anthony Kazos Jr.
                   ` (5 more replies)
  0 siblings, 6 replies; 11+ messages in thread
From: John Anthony Kazos Jr. @ 2007-04-08  3:33 UTC (permalink / raw)
  To: aeb; +Cc: linux-kernel

In addition to the Kconfig help text patch I submitted earlier, this is a 
set of patches to touch up the partition handling files and also to change 
the "array of function pointers" algorithm of the main checking function 
to "list of calls to possible stub functions" to better fit in with the 
rest of the kernel code, to reduce memory usage by a few dozen bytes, and 
to generally be easier (in my opinion) to understand.

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2007-04-08 10:42 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-04-08  3:33 [PATCH 0/5] partitions: Changes to fs/partitions for readability and efficiency John Anthony Kazos Jr.
2007-04-08  3:38 ` [PATCH 1/5] partitions: Touch up comments for check.h and ibm.h John Anthony Kazos Jr.
2007-04-08  9:46   ` Christoph Hellwig
2007-04-08  3:39 ` [PATCH 2/5] partitions: Add Kconfig dependency to clear benign compiler warning John Anthony Kazos Jr.
2007-04-08  3:40 ` [PATCH 3/5] partitions: Add conditionals to acorn.c to clear benign compiler warnings John Anthony Kazos Jr.
2007-04-08  3:40 ` [PATCH 4/5] partitions: Add conditionals and static inline stubs to helpers in headers John Anthony Kazos Jr.
2007-04-08  4:01   ` Randy Dunlap
2007-04-08  9:47   ` Christoph Hellwig
2007-04-08  3:42 ` [PATCH 5/5] partitions: Rewrite check_partition to remove necessity of check_part John Anthony Kazos Jr.
2007-04-08  4:09   ` Randy Dunlap
2007-04-08 10:42 ` [PATCH 0/5] partitions: Changes to fs/partitions for readability and efficiency Russell King

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome