mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andi Kleen <ak@suse.de>
To: stefanr@s5r6.in-berlin.de, mingo@elte.hu, ak@suse.de,
	rpjday@mindspring.com, linux-kernel@vger.kernel.org
Subject: [PATCH for review] [33/48] i386: remove old IRQ balancing debug cruft
Date: Thu, 19 Jul 2007 15:49:03 +0200 (CEST)	[thread overview]
Message-ID: <20070719134903.A60C014E71@wotan.suse.de> (raw)
In-Reply-To: <20070719348.540885000@suse.de>


From: Stefan Richter <stefanr@s5r6.in-berlin.de>

Dead or misnamed CONFIG_BALANCED_IRQ_DEBUG found by Robert P. J. Day.
It's not a Kconfig variable.

Since this debug code is ancient, I suggest to get rid of this
misleading CONFIG_ macro by deleting all of this debug code.

Signed-off-by: Stefan Richter <stefanr@s5r6.in-berlin.de>
Signed-off-by: Andi Kleen <ak@suse.de>
Cc: Ingo Molnar <mingo@elte.hu>
Cc: Andi Kleen <ak@suse.de>
Cc: "Robert P. J. Day" <rpjday@mindspring.com>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
---

 arch/i386/kernel/io_apic.c |   24 ++----------------------
 1 file changed, 2 insertions(+), 22 deletions(-)

Index: linux/arch/i386/kernel/io_apic.c
===================================================================
--- linux.orig/arch/i386/kernel/io_apic.c
+++ linux/arch/i386/kernel/io_apic.c
@@ -353,14 +353,6 @@ static void set_ioapic_affinity_irq(unsi
 # include <linux/slab.h>		/* kmalloc() */
 # include <linux/timer.h>	/* time_after() */
  
-#ifdef CONFIG_BALANCED_IRQ_DEBUG
-#  define TDprintk(x...) do { printk("<%ld:%s:%d>: ", jiffies, __FILE__, __LINE__); printk(x); } while (0)
-#  define Dprintk(x...) do { TDprintk(x); } while (0)
-# else
-#  define TDprintk(x...) 
-#  define Dprintk(x...) 
-# endif
-
 #define IRQBALANCE_CHECK_ARCH -999
 #define MAX_BALANCED_IRQ_INTERVAL	(5*HZ)
 #define MIN_BALANCED_IRQ_INTERVAL	(HZ/2)
@@ -443,7 +435,7 @@ static inline void balance_irq(int cpu, 
 static inline void rotate_irqs_among_cpus(unsigned long useful_load_threshold)
 {
 	int i, j;
-	Dprintk("Rotating IRQs among CPUs.\n");
+
 	for_each_online_cpu(i) {
 		for (j = 0; j < NR_IRQS; j++) {
 			if (!irq_desc[j].action)
@@ -560,19 +552,11 @@ tryanothercpu:
 	max_loaded = tmp_loaded;	/* processor */
 	imbalance = (max_cpu_irq - min_cpu_irq) / 2;
 	
-	Dprintk("max_loaded cpu = %d\n", max_loaded);
-	Dprintk("min_loaded cpu = %d\n", min_loaded);
-	Dprintk("max_cpu_irq load = %ld\n", max_cpu_irq);
-	Dprintk("min_cpu_irq load = %ld\n", min_cpu_irq);
-	Dprintk("load imbalance = %lu\n", imbalance);
-
 	/* if imbalance is less than approx 10% of max load, then
 	 * observe diminishing returns action. - quit
 	 */
-	if (imbalance < (max_cpu_irq >> 3)) {
-		Dprintk("Imbalance too trivial\n");
+	if (imbalance < (max_cpu_irq >> 3))
 		goto not_worth_the_effort;
-	}
 
 tryanotherirq:
 	/* if we select an IRQ to move that can't go where we want, then
@@ -629,9 +613,6 @@ tryanotherirq:
 	cpus_and(tmp, target_cpu_mask, allowed_mask);
 
 	if (!cpus_empty(tmp)) {
-
-		Dprintk("irq = %d moved to cpu = %d\n",
-				selected_irq, min_loaded);
 		/* mark for change destination */
 		set_pending_irq(selected_irq, cpumask_of_cpu(min_loaded));
 
@@ -651,7 +632,6 @@ not_worth_the_effort:
 	 */
 	balanced_irq_interval = min((long)MAX_BALANCED_IRQ_INTERVAL,
 		balanced_irq_interval + BALANCED_IRQ_MORE_DELTA);	
-	Dprintk("IRQ worth rotating not found\n");
 	return;
 }
 

  parent reply	other threads:[~2007-07-19 14:04 UTC|newest]

Thread overview: 60+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-07-19 13:48 [PATCH for review] [0/48] Second batch of x86 patches for .23 Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [1/48] i386: pgd_{c,d}tor() static Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [2/48] i386: fix section mismatch warning in intel_cacheinfo Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [3/48] i386: do not restore reserved memory after hibernation Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [4/48] i386: DMI_MATCH patch in reboot.c for SFF Dell OptiPlex 745 - fixes hang on reboot Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [5/48] i386: HPET, check if the counter works Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [6/48] x86: trim memory not covered by WB MTRRs Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [7/48] i386: divorce CONFIG_X86_PAE from CONFIG_HIGHMEM64G Andi Kleen
2007-07-19 14:46   ` Dave Jones
2007-07-19 17:06     ` Andi Kleen
2007-07-19 14:52   ` Christoph Hellwig
2007-07-20  0:45     ` William Lee Irwin III
2007-07-19 13:48 ` [PATCH for review] [8/48] i386: Remove unneeded test of 'task' in dump_trace() Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [9/48] i386: move the kernel to 16MB for NUMA-Q Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [10/48] x86_64: Move functions declarations to header file Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [11/48] x86_64: During VM oom condition, kill all threads in process group Andi Kleen
2007-07-19 14:04   ` Christoph Hellwig
2007-07-19 14:14     ` Geert Uytterhoeven
2007-07-19 15:03       ` Will Schmidt
2007-07-23 18:09       ` [PATCH respin, was PATCH for review] " Will Schmidt
2007-07-23 21:16         ` Andrew Morton
2007-07-24 14:28           ` Will Schmidt
2007-07-24 14:31             ` Christoph Hellwig
2007-07-31  9:31         ` Pavel Machek
2007-07-31 14:55           ` Will Schmidt
2007-07-19 13:48 ` [PATCH for review] [12/48] x86_64: use the global PIT lock Andi Kleen
2007-07-19 15:22   ` Dmitry Torokhov
2007-07-19 17:29     ` Andi Kleen
2007-07-19 19:23       ` Dmitry Torokhov
2007-07-19 19:52         ` Andi Kleen
2007-07-20  4:24           ` Dmitry Torokhov
2007-07-20  8:25             ` Andi Kleen
2007-07-20 12:50               ` Dmitry Torokhov
2007-07-19 13:48 ` [PATCH for review] [13/48] x86_64: fix typo in acpi_pm.c Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [14/48] x86_64: lower printk severity Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [15/48] x86_64: fix wrong comment regarding set_fixmap() Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [16/48] x86_64: Geode HW Random Number Generator depends on X86_32 Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [17/48] x86_64: change _map_single to static in pci_gart.c etc Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [18/48] x86_64: flush_tlb_kernel_range() warning fix Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [19/48] i386: add cpu_relax() to cmos_lock() Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [20/48] i386: replace hard-coded constant with appropriate macro from kernel.h Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [21/48] x86_64: disable the GART in shutdown Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [22/48] x86_64: fix e820_hole_size based on address ranges Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [23/48] x86_64: disable srat when numa emulation succeeds Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [24/48] x86_64: move iommu declaration from proto to iommu.h Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [25/48] i386: remove volatile in apic.c Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [26/48] i386: hpet assumes boot cpu is 0 Andi Kleen
2007-07-19 16:23   ` Jeremy Fitzhardinge
2007-07-19 13:48 ` [PATCH for review] [27/48] i386: move PIT function declarations and constants to correct header file Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [28/48] i386: fix iounmap's use of vm_struct's size field Andi Kleen
2007-07-19 13:48 ` [PATCH for review] [29/48] x86_64: arch/x86_64/kernel/aperture.c lower printk severity Andi Kleen
2007-07-19 13:49 ` [PATCH for review] [30/48] x86_64: arch/x86_64/kernel/e820.c " Andi Kleen
2007-07-19 13:49 ` [PATCH for review] [31/48] i386: basic infrastructure support for AMD geode-class machines Andi Kleen
2007-07-19 13:49 ` [PATCH for review] [32/48] i386: insert HPET firmware resource after PCI enumeration has completed Andi Kleen
2007-07-19 13:49 ` Andi Kleen [this message]
2007-07-19 13:49 ` [PATCH for review] [34/48] i386: Update alignment when 4K stacks are used Andi Kleen
2007-07-19 13:49 ` [PATCH for review] [35/48] x86_64: remove __smp_alt* sections Andi Kleen
2007-07-19 13:49 ` [PATCH for review] [36/48] x86_64: k8topology add family 10h and 11h PCI IDs Andi Kleen
2007-07-19 13:49 ` [PATCH for review] [37/48] x86_64: make k8topology multi-core aware Andi Kleen
2007-07-19 13:49 ` [PATCH for review] [38/48] x86_64: Put allocated ELF notes in read-only data segment Andi Kleen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070719134903.A60C014E71@wotan.suse.de \
    --to=ak@suse.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=rpjday@mindspring.com \
    --cc=stefanr@s5r6.in-berlin.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®