mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Pierre Ossman <drzeus-list@drzeus.cx>
To: David Vrabel <david.vrabel@csr.com>
Cc: linux-kernel@vger.kernel.org
Subject: Re: sdio: parameterize SDIO FBR register defines
Date: Mon, 6 Aug 2007 16:58:09 +0200	[thread overview]
Message-ID: <20070806165809.1d0b2791@poseidon.drzeus.cx> (raw)
In-Reply-To: <46B6F46B.8050707@csr.com>

On Mon, 06 Aug 2007 11:14:03 +0100
David Vrabel <david.vrabel@csr.com> wrote:

> 
> I really don't follow you objection to this.  If one is maintaining
> the SDIO core then I would expect some familiarity with the spec and
> an understanding the FBRs are per-function but contained in the same
> CCCR/F0 register space.
> 

If we can reduce that barrier, then I think we should. People can't be
expected to keep everything fresh in memory all the time. And we won't
have a team dedicated to hacking this all the time.

> Also, I would consider the start of the CCCR as the "base address".
> 

In some sense, but there are also several identical FBR chunks on the
card. So by most definitions of a base address, the start of each chunk
would be it.

> > Would you be content with replacing "func->num * 0x100" with a
> > macro so that the code becomes something like:
> > 
> > 	SDIO_FBR_BASE(func->num) + SDIO_FBR_STD_IF
> 
> I think this is less readable than SDIO_FBR_STD_IF(func->num).
> 

It's subjective. But the longer version is more understandable for
someone who doesn't have the details of the SDIO protocol fresh in his
mind.

Rgds
-- 
     -- Pierre Ossman

  Linux kernel, MMC maintainer        http://www.kernel.org
  PulseAudio, core developer          http://pulseaudio.org
  rdesktop, core developer          http://www.rdesktop.org

  reply	other threads:[~2007-08-06 14:58 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-07-31 15:36 sdio: enhance IO_RW_EXTENDED support David Vrabel
2007-07-31 15:36 ` sdio: parameterize SDIO FBR register defines David Vrabel
2007-08-04 13:26   ` Pierre Ossman
2007-08-06 10:14     ` David Vrabel
2007-08-06 14:58       ` Pierre Ossman [this message]
2007-07-31 15:36 ` sdio: set the functions' block size David Vrabel
2007-08-04 13:30   ` Pierre Ossman
2007-08-06 10:04     ` David Vrabel
2007-07-31 15:36 ` sdio: extend sdio_readsb() and friends to handle any length of buffer David Vrabel
2007-08-04 13:35   ` Pierre Ossman
2007-08-04 13:23 ` sdio: enhance IO_RW_EXTENDED support Pierre Ossman
2007-08-06 10:31   ` David Vrabel
2007-08-06 15:12     ` Pierre Ossman
2007-08-06 15:32       ` David Vrabel
2007-08-06 18:06         ` Pierre Ossman
2007-08-06 20:01         ` Pierre Ossman
2007-08-07 12:51           ` David Vrabel
2007-08-07 12:53             ` [patch 1/4] sdio: parameterize SDIO FBR register defines David Vrabel
2007-08-07 12:54             ` [patch 2/4] sdio: set the functions' block size David Vrabel
2007-08-07 13:38               ` Pierre Ossman
2007-08-07 17:20                 ` David Vrabel
2007-08-07 17:54                   ` Pierre Ossman
2007-08-08  9:46                     ` David Vrabel
2007-08-08 10:06                       ` Pierre Ossman
2007-08-08 10:19                         ` David Vrabel
2007-08-07 12:55             ` [patch 3/4] sdio: extend sdio_readsb() and friends to handle any length of buffer David Vrabel
2007-08-07 13:42               ` Pierre Ossman
2007-08-07 20:17               ` Pierre Ossman
2007-08-08 10:19                 ` David Vrabel
2007-08-08 10:37                   ` Pierre Ossman
2007-08-08 13:22                     ` David Vrabel
2007-08-08 13:23                       ` [patch 1/3] sdio: add SDIO_FBR_BASE(f) macro David Vrabel
2007-08-08 13:23                       ` [patch 2/3] sdio: set the functions' block size David Vrabel
2007-08-08 13:24                       ` [patch 3/3] sdio: extend sdio_readsb() and friends to handle any length of buffer David Vrabel
2007-08-08 16:55                       ` [patch 3/4] " Pierre Ossman
2007-08-07 12:55             ` [patch 4/4] sdio: disable CD resistor David Vrabel
2007-08-07 13:43               ` Pierre Ossman
2007-08-07 14:46                 ` David Vrabel
2007-08-07 15:08                   ` Pierre Ossman
2007-08-07 13:33             ` sdio: enhance IO_RW_EXTENDED support Pierre Ossman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070806165809.1d0b2791@poseidon.drzeus.cx \
    --to=drzeus-list@drzeus.cx \
    --cc=david.vrabel@csr.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®