From: Matt Mackall <mpm@selenic.com>
To: Dave Hansen <haveblue@us.ibm.com>
Cc: linux-kernel@vger.kernel.org, serue@us.ibm.com,
Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [RFC][PATCH 4/5] introduce TASK_SIZE_OF() for all arches
Date: Tue, 7 Aug 2007 21:03:54 -0500 [thread overview]
Message-ID: <20070808020354.GK30556@waste.org> (raw)
In-Reply-To: <20070807223303.F720DA3E@kernel>
On Tue, Aug 07, 2007 at 03:33:03PM -0700, Dave Hansen wrote:
>
> For the /proc/<pid>/pagemap code[1], we need to able to query how
> much virtual address space a particular task has. The trick is
> that we do it through /proc and can't use TASK_SIZE since it
> references "current" on some arches. The process opening the
> /proc file might be a 32-bit process opening a 64-bit process's
> pagemap file.
That seems perfectly sensible to me, but I think you'll need to bounce
it off Andrew at least. (cc:ed)
> x86_64 already has a TASK_SIZE_OF() macro:
>
> #define TASK_SIZE_OF(child) ((test_tsk_thread_flag(child, TIF_IA32)) ? IA32_PAGE_OFFSET : TASK_SIZE64)
>
> I'd like to have that for other architectures. So, add it
> for all the architectures that actually use "current" in
> their TASK_SIZE. For the others, just add a quick #define
> in sched.h to use plain old TASK_SIZE.
>
> 1. http://www.linuxworld.com/news/2007/042407-kernel.html
>
> Signed-off-by: Dave Hansen <haveblue@us.ibm.com>
> ---
>
> lxc-dave/include/asm-ia64/processor.h | 3 ++-
> lxc-dave/include/asm-parisc/processor.h | 3 ++-
> lxc-dave/include/asm-powerpc/processor.h | 4 +++-
> lxc-dave/include/asm-s390/processor.h | 2 ++
> lxc-dave/include/linux/sched.h | 4 ++++
> 5 files changed, 13 insertions(+), 3 deletions(-)
>
> diff -puN include/asm-ia64/processor.h~task_size_of include/asm-ia64/processor.h
> --- lxc/include/asm-ia64/processor.h~task_size_of 2007-08-07 15:30:54.000000000 -0700
> +++ lxc-dave/include/asm-ia64/processor.h 2007-08-07 15:30:54.000000000 -0700
> @@ -31,7 +31,8 @@
> * each (assuming 8KB page size), for a total of 8TB of user virtual
> * address space.
> */
> -#define TASK_SIZE (current->thread.task_size)
> +#define TASK_SIZE_OF(tsk) ((tsk)->thread.task_size)
> +#define TASK_SIZE TASK_SIZE_OF(current)
>
> /*
> * This decides where the kernel will search for a free chunk of vm
> diff -puN include/asm-parisc/processor.h~task_size_of include/asm-parisc/processor.h
> --- lxc/include/asm-parisc/processor.h~task_size_of 2007-08-07 15:30:54.000000000 -0700
> +++ lxc-dave/include/asm-parisc/processor.h 2007-08-07 15:30:54.000000000 -0700
> @@ -32,7 +32,8 @@
> #endif
> #define current_text_addr() ({ void *pc; current_ia(pc); pc; })
>
> -#define TASK_SIZE (current->thread.task_size)
> +#define TASK_SIZE_OF(tsk) ((tsk)->thread.task_size)
> +#define TASK_SIZE (current->thread.task_size)
> #define TASK_UNMAPPED_BASE (current->thread.map_base)
>
> #define DEFAULT_TASK_SIZE32 (0xFFF00000UL)
> diff -puN include/asm-powerpc/processor.h~task_size_of include/asm-powerpc/processor.h
> --- lxc/include/asm-powerpc/processor.h~task_size_of 2007-08-07 15:30:54.000000000 -0700
> +++ lxc-dave/include/asm-powerpc/processor.h 2007-08-07 15:30:54.000000000 -0700
> @@ -107,7 +107,9 @@ extern struct task_struct *last_task_use
> */
> #define TASK_SIZE_USER32 (0x0000000100000000UL - (1*PAGE_SIZE))
>
> -#define TASK_SIZE (test_thread_flag(TIF_32BIT) ? \
> +#define TASK_SIZE (test_thread_flag(TIF_32BIT) ? \
> + TASK_SIZE_USER32 : TASK_SIZE_USER64)
> +#define TASK_SIZE_OF(tsk) (test_tsk_thread_flag(tsk, TIF_32BIT) ? \
> TASK_SIZE_USER32 : TASK_SIZE_USER64)
>
> /* This decides where the kernel will search for a free chunk of vm
> diff -puN include/asm-s390/processor.h~task_size_of include/asm-s390/processor.h
> --- lxc/include/asm-s390/processor.h~task_size_of 2007-08-07 15:30:54.000000000 -0700
> +++ lxc-dave/include/asm-s390/processor.h 2007-08-07 15:30:54.000000000 -0700
> @@ -75,6 +75,8 @@ extern struct task_struct *last_task_use
>
> # define TASK_SIZE (test_thread_flag(TIF_31BIT) ? \
> (0x80000000UL) : (0x40000000000UL))
> +# define TASK_SIZE_OF(tsk) (test_tsk_thread_flag(tsk, TIF_31BIT) ? \
> + (0x80000000UL) : (0x40000000000UL))
> # define TASK_UNMAPPED_BASE (TASK_SIZE / 2)
> # define DEFAULT_TASK_SIZE (0x40000000000UL)
>
> diff -puN include/linux/sched.h~task_size_of include/linux/sched.h
> --- lxc/include/linux/sched.h~task_size_of 2007-08-07 15:30:54.000000000 -0700
> +++ lxc-dave/include/linux/sched.h 2007-08-07 15:30:54.000000000 -0700
> @@ -1712,6 +1712,10 @@ static inline void inc_syscw(struct task
> }
> #endif
>
> +#ifndef TASK_SIZE_OF
> +#define TASK_SIZE_OF(tsk) TASK_SIZE
> +#endif
> +
> #endif /* __KERNEL__ */
>
> #endif
> _
--
Mathematics is the supreme nostalgia of our time.
next prev parent reply other threads:[~2007-08-08 2:03 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-08-07 22:33 [RFC][PATCH 1/5] pagemap: remove file header Dave Hansen
2007-08-07 22:33 ` [RFC][PATCH 2/5] pagemap: use PAGE_MASK/PAGE_ALIGN() Dave Hansen
2007-08-08 1:54 ` Matt Mackall
2007-08-07 22:33 ` [RFC][PATCH 3/5] pagemap: remove open-coded sizeof(unsigned long) Dave Hansen
2007-08-07 23:40 ` Matt Mackall
2007-08-07 23:55 ` Dave Hansen
2007-08-08 2:01 ` Matt Mackall
2007-08-07 22:33 ` [RFC][PATCH 4/5] introduce TASK_SIZE_OF() for all arches Dave Hansen
2007-08-08 2:03 ` Matt Mackall [this message]
2007-08-08 18:19 ` Dave Hansen
2007-08-07 22:33 ` [RFC][PATCH 5/5] pagemap: add walker for empty areas Dave Hansen
2007-08-08 1:16 ` [RFC][PATCH 1/5] pagemap: remove file header Matt Mackall
2007-08-08 1:31 ` Alan Cox
2007-08-08 3:51 ` Matt Mackall
2007-08-08 16:34 ` Dave Hansen
2007-08-08 16:53 ` Dave Hansen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070808020354.GK30556@waste.org \
--to=mpm@selenic.com \
--cc=akpm@linux-foundation.org \
--cc=haveblue@us.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=serue@us.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome