From: Matt Mackall <mpm@selenic.com>
To: Alan Cox <alan@lxorguk.ukuu.org.uk>
Cc: Dave Hansen <haveblue@us.ibm.com>,
linux-kernel@vger.kernel.org, serue@us.ibm.com
Subject: Re: [RFC][PATCH 1/5] pagemap: remove file header
Date: Tue, 7 Aug 2007 22:51:21 -0500 [thread overview]
Message-ID: <20070808035121.GL30556@waste.org> (raw)
In-Reply-To: <20070808023100.222c4d15@the-village.bc.nu>
On Wed, Aug 08, 2007 at 02:31:00AM +0100, Alan Cox wrote:
> O> > The endianness is only useful when examining a raw dump of
> > > pagemap from a different machine when you don't know the
> > > source of the file. This is pretty rare, and the programs
> > > or scripts doing the copying off-machine can certainly be
> > > made to hold this information.
>
> Nobody fancies doing bi-endian MIPS ?
Indeed not.
> > > The page size is available in userspace at least with libc's
> > > getpagesize(). This will also never vary across processes,
>
> For now. Its a logical direction however thant we end up with bigger page
> sizes either by hardware or by software merging and end up having
> different page sizes for legacy 32bit binaries.
Blerch.
> > I'd really strongly prefer to have no header. It was added to
> > futureproof the thing.
>
> The information needed to parse /proc/pid/pagemap can be stuck
> in /proc/pid/somewherelese. If we ever get page size variations and the
> like then /proc/pid/ is going to end up with that information anyway for
> ps and friends to use.
Well if somewhereelse doesn't exist today, programs written today will
break on tomorrow's kernels.
--
Mathematics is the supreme nostalgia of our time.
next prev parent reply other threads:[~2007-08-08 3:57 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-08-07 22:33 Dave Hansen
2007-08-07 22:33 ` [RFC][PATCH 2/5] pagemap: use PAGE_MASK/PAGE_ALIGN() Dave Hansen
2007-08-08 1:54 ` Matt Mackall
2007-08-07 22:33 ` [RFC][PATCH 3/5] pagemap: remove open-coded sizeof(unsigned long) Dave Hansen
2007-08-07 23:40 ` Matt Mackall
2007-08-07 23:55 ` Dave Hansen
2007-08-08 2:01 ` Matt Mackall
2007-08-07 22:33 ` [RFC][PATCH 4/5] introduce TASK_SIZE_OF() for all arches Dave Hansen
2007-08-08 2:03 ` Matt Mackall
2007-08-08 18:19 ` Dave Hansen
2007-08-07 22:33 ` [RFC][PATCH 5/5] pagemap: add walker for empty areas Dave Hansen
2007-08-08 1:16 ` [RFC][PATCH 1/5] pagemap: remove file header Matt Mackall
2007-08-08 1:31 ` Alan Cox
2007-08-08 3:51 ` Matt Mackall [this message]
2007-08-08 16:34 ` Dave Hansen
2007-08-08 16:53 ` Dave Hansen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070808035121.GL30556@waste.org \
--to=mpm@selenic.com \
--cc=alan@lxorguk.ukuu.org.uk \
--cc=haveblue@us.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=serue@us.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome