From: Andi Kleen <andi@firstfloor.org>
To: Ingo Molnar <mingo@elte.hu>
Cc: Andi Kleen <andi@firstfloor.org>,
linux-kernel@vger.kernel.org,
"Frank Ch. Eigler" <fche@redhat.com>,
Roland McGrath <roland@redhat.com>,
Thomas Gleixner <tglx@linutronix.de>,
"H. Peter Anvin" <hpa@zytor.com>,
Linus Torvalds <torvalds@linux-foundation.org>,
Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [git pull] kgdb-light -v10
Date: Tue, 12 Feb 2008 14:50:27 +0100 [thread overview]
Message-ID: <20080212135027.GA1343@one.firstfloor.org> (raw)
In-Reply-To: <20080212123839.GA15360@elte.hu>
On Tue, Feb 12, 2008 at 01:38:39PM +0100, Ingo Molnar wrote:
> So unless i forgot about something (please yell if so), it seems to me
> kgdb is now pretty ready for an upstream merge.
I don't know -- I have not reread everything. Please don't consider
my comments as approval of the code base. I still think it does quite
a lot of dubious and ugly things overall and should get far more clean up
and get more testing too.
> do spinning for now: we dont _ever_ want to break a correctly working
> system with kgdb.
Stopping all CPUs for indefinite time very much seems like
"breaking a correctly working system" to me. In a correctly working system
kgdb is never entered.
> A valid counter-argument is _not_ to argue "but it would be nice to have
> if the system is broken in X, Y and Z ways" (like you did), but to point
> it out why the behavior we chose is wrong on a correctly working system.
>
> Yes, a buggy system might misbehave in various ways but my primary
> interest is in keeping correctly working systems correct.
The only way I know of to do that is gdb vmlinux /proc/kcore
kgdb certainly isn't it.
> And note that kgdb is not just a "debugger", it's a system inspection
> tool. An intelligent, human-controlled printk.
For that gdb vmlinux /proc/kcore already works fine. Or fireproxy.
If that was the only goal we wouldn't need all that stub code.
> > > just introduce unnecessary complexity.
> >
> > The question is less about actually having it as a module, but just if
> > the interfaces are clean enough to allow it as a module. If not you
> > should probably clean them up.
>
> but your contention is simply wrong. Most of our debugging
> infrastructure is non-modular for a good reason. Modularization
> increases complexity and that's exactly the wrong direction for
The main complexity in module handling is handling (or rather preventing)
module unload. I explicitely excluded that in my earlier mail.
Module loading on the other hand tends to be relatively easy.
I did a modular kernel debugger on my own some time ago and once
the interfaces were clean it was very simple. I think the reverse
is true too -- if having it as a module is easy then the interfaces
are clean too. That is why I asked for it. It's a good basic
sanity check on the design.
>
> > > no, not all architectures have it. This is a weak alias that is
> > > otherwise not linked into the kernel.
> >
> > Can't be very many because oprofile needs it and it works on most
> > archs now. Anyways, the right thing is to just add it to the
> > architectures that still miss it, not reimplement it in kgdb.
>
> it's not reimplemented - kgdb_arch_pc() does not directly map to
> instruction_pointer().
If that is true then it is definitely misnamed and likely
incorrectly implemented on the architecture in question.
> > [...] If kgdb is active it should have priority over crash dumps.
>
> that's the approach we are taking: be as unintrusive as possible. This
> means that the notifier here is registered at the lowest priority. You
> might disagree with it but it's a completely sensible and consistent
> approach.
Yeah, it is consistently wrong agreed.
-Andi
next prev parent reply other threads:[~2008-02-12 13:15 UTC|newest]
Thread overview: 52+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-02-11 1:53 kgdb in git-x86#mm review Andi Kleen
2008-02-11 15:32 ` Frank Ch. Eigler
2008-02-11 16:11 ` Andi Kleen
2008-02-11 16:21 ` [git pull] kgdb-light -v8, (was: Re: kgdb in git-x86#mm review) Ingo Molnar
2008-02-11 16:41 ` [git pull] kgdb-light -v8, Jan Kiszka
2008-02-11 16:54 ` Ingo Molnar
2008-02-11 17:10 ` [git pull] kgdb-light -v8, (was: Re: kgdb in git-x86#mm review) Andi Kleen
2008-02-11 23:03 ` [git pull] kgdb-light -v9 Ingo Molnar
2008-02-12 10:03 ` Andi Kleen
2008-02-12 9:35 ` Sam Ravnborg
2008-02-12 10:26 ` Roland McGrath
2008-02-12 10:34 ` Ingo Molnar
2008-02-12 11:27 ` [git pull] kgdb-light -v10 Ingo Molnar
2008-02-12 12:19 ` Andi Kleen
2008-02-12 12:38 ` Ingo Molnar
2008-02-12 13:30 ` Jason Wessel
2008-02-12 14:39 ` Andi Kleen
2008-02-12 14:35 ` Jason Wessel
2008-02-12 15:36 ` Andi Kleen
2008-02-12 16:21 ` Jason Wessel
2008-02-12 17:10 ` Andi Kleen
2008-02-12 16:48 ` Jason Wessel
2008-02-12 13:50 ` Andi Kleen [this message]
2008-02-12 15:16 ` Ingo Molnar
2008-02-12 15:28 ` Andi Kleen
2008-02-12 15:28 ` Ingo Molnar
2008-02-12 16:11 ` Andi Kleen
2008-02-12 16:24 ` Ingo Molnar
2008-02-12 17:01 ` Andi Kleen
2008-02-12 16:25 ` Linus Torvalds
2008-02-12 16:42 ` Ingo Molnar
2008-02-12 17:07 ` Andi Kleen
2008-02-15 12:35 ` [RFC][PATCH] modular kgdb-light (was: Re: [git pull] kgdb-light -v10) Jan Kiszka
2008-02-15 13:32 ` Andi Kleen
2008-02-15 20:24 ` [RFC][PATCH] modular kgdb-light Jason Wessel
2008-02-15 20:36 ` [git pull] kgdb-light -v10 Jason Wessel
2008-02-12 16:46 ` Linus Torvalds
2008-02-12 17:01 ` Ingo Molnar
2008-02-12 17:10 ` Ingo Molnar
2008-02-12 18:20 ` Andi Kleen
2008-02-12 18:11 ` Linus Torvalds
2008-02-12 19:22 ` Andi Kleen
2008-02-12 19:01 ` Linus Torvalds
2008-02-12 18:20 ` Andrew Morton
2008-02-12 19:16 ` Andi Kleen
2008-02-12 21:01 ` Ingo Molnar
2008-02-12 19:34 ` Frank Ch. Eigler
2008-02-12 20:16 ` Andi Kleen
2008-02-12 13:18 ` Domenico Andreoli
2008-02-12 13:59 ` Jason Wessel
2008-02-12 15:45 ` Domenico Andreoli
2008-02-11 16:03 ` kgdb in git-x86#mm review Mark Lord
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20080212135027.GA1343@one.firstfloor.org \
--to=andi@firstfloor.org \
--cc=akpm@linux-foundation.org \
--cc=fche@redhat.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=roland@redhat.com \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome