mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Serge E. Hallyn" <serue@us.ibm.com>
To: Paul Menage <menage@google.com>
Cc: "Serge E. Hallyn" <serue@us.ibm.com>,
	lkml <linux-kernel@vger.kernel.org>,
	linux-security-module@vger.kernel.org, Greg KH <greg@kroah.com>,
	Stephen Smalley <sds@epoch.ncsc.mil>,
	Casey Schaufler <casey@schaufler-ca.com>,
	Pavel Emelianov <xemul@openvz.org>
Subject: Re: [RFC] cgroups: implement device whitelist lsm (v2)
Date: Fri, 14 Mar 2008 09:05:23 -0500	[thread overview]
Message-ID: <20080314140523.GG8744@sergelap.austin.ibm.com> (raw)
In-Reply-To: <6599ad830803140216k1a04ce4ej4779bf10ec6ef4f9@mail.gmail.com>

Quoting Paul Menage (menage@google.com):
> On Wed, Mar 12, 2008 at 8:27 PM, Serge E. Hallyn <serue@us.ibm.com> wrote:
> >
> >  While composing this with the ns_cgroup may seem logical, it is not
> >  the right thing to do, because updates to /cg/cg1/devcg.deny are
> >  not reflected in /cg/cg1/cg2/devcg.allow.
> 
> Maybe you should follow up the tree to ensure that all parent groups
> have access to the device too? Or alternatively, cache the results of
> this lookup whenever permissions for a device change?

Yes, I considered that.  Alternatively additions to a parent cgroup's
.deny could be propagated to all its descendents (but not additions to
the .allow).

I've noted this as something to add to the next version.

> >  A task may only be moved to another devcgroup if it is moving to
> >  a direct descendent of its current devcgroup.
> 
> What's the rationale for that?

To prevent it escaping to laxer device permissions, which of course only
makes sense if we do what you recommend above :)

> >  CAP_NS_OVERRIDE is defined as the capability needed to cross namespaces.
> >  A task needs both CAP_NS_OVERRIDE and CAP_SYS_ADMIN to create a new
> >  devcgroup, update a devcgroup's access, or move a task to a new
> >  devcgroup.
> 
> But this isn't necessarily crossing namespaces. It could be used for
> device control in the same namespace (e.g. allowing a job to access a
> raw disk for its data storage rather than going through the
> filesystem).

Yeah it should be renamed.  I want to use the same cap which we would
use for user namespaces though.  CAP_NS_CONT(ainer)?  Even though there
really is no such thing as a 'container'.  But that would tie together
any such privileges for cgroups and namespaces.

thanks,
-serge

  reply	other threads:[~2008-03-14 14:05 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-03-13  3:27 Serge E. Hallyn
2008-03-13  9:25 ` James Morris
2008-03-13 13:18   ` Serge E. Hallyn
2008-03-13 13:50     ` James Morris
2008-03-13 14:38       ` Serge E. Hallyn
2008-03-13 22:27         ` James Morris
2008-03-13 22:46           ` Serge E. Hallyn
2008-03-13 23:49             ` James Morris
2008-03-14  1:41               ` Serge E. Hallyn
2008-03-14  4:47                 ` Greg KH
2008-03-14 13:54                   ` Serge E. Hallyn
2008-03-14 13:58                     ` Pavel Emelyanov
2008-03-14 15:45                       ` Serge E. Hallyn
2008-03-14 15:54                         ` Pavel Emelyanov
2008-03-14 16:57                         ` Stephen Smalley
2008-03-14  9:28                 ` Pavel Emelyanov
2008-03-14 13:58                   ` Serge E. Hallyn
2008-03-14 14:05                     ` Pavel Emelyanov
2008-03-14 14:37                       ` Serge E. Hallyn
2008-03-14 15:07                         ` Pavel Emelyanov
2008-03-14 14:12                     ` Paul Menage
2008-03-14 14:42                       ` Serge E. Hallyn
2008-03-16  0:59                         ` Paul Menage
2008-03-14  2:51               ` Casey Schaufler
2008-03-14  9:16 ` Paul Menage
2008-03-14 14:05   ` Serge E. Hallyn [this message]
2008-03-14 14:15     ` Paul Menage
2008-03-14 14:35       ` Serge E. Hallyn
2008-03-16  0:57         ` Paul Menage
2008-03-14  9:18 ` Paul Menage
2008-03-14 14:00   ` Serge E. Hallyn

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080314140523.GG8744@sergelap.austin.ibm.com \
    --to=serue@us.ibm.com \
    --cc=casey@schaufler-ca.com \
    --cc=greg@kroah.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=menage@google.com \
    --cc=sds@epoch.ncsc.mil \
    --cc=xemul@openvz.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®