mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Ravikiran G Thirumalai <kiran@scalex86.org>
Cc: Yinghai Lu <yhlu.kernel@gmail.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	linux-kernel@vger.kernel.org,
	Glauber de Oliveira Costa <gcosta@redhat.com>,
	Andi Kleen <ak@suse.de>,
	shai@scalex86.org
Subject: Re: [patch 1/4] x86: vSMP: Fix is_vsmp_box()
Date: Fri, 21 Mar 2008 10:11:39 +0100	[thread overview]
Message-ID: <20080321091139.GD20420@elte.hu> (raw)
In-Reply-To: <20080320184045.GA6085@localdomain>


* Ravikiran G Thirumalai <kiran@scalex86.org> wrote:

> >>         /* Check if we are running on a ScaleMP vSMP box */
> >>  -       if (read_pci_config(0, 0x1f, 0, PCI_VENDOR_ID) ==
> >>  -            (PCI_VENDOR_ID_SCALEMP || (PCI_DEVICE_ID_SCALEMP_VSMP_CTL << 16)))
> >>  +       if ((read_pci_config_16(0, 0x1f, 0, PCI_VENDOR_ID) ==
> >>  +            PCI_VENDOR_ID_SCALEMP) &&
> >>  +           (read_pci_config_16(0, 0x1f, 0, PCI_DEVICE_ID) ==
> >>  +           PCI_DEVICE_ID_SCALEMP_VSMP_CTL))
> >>                 vsmp = 1;
> >>
> >>         return vsmp;
> >
> >why read two times
> >
> 
> Well, the pci cfg space read happens just _once_ during the boot, as 
> the result is cached in a static flag. The above code is better 
> readable. So readability is better than micro-optimization here.

i think the patch below results in even more readable and a bit smaller 
code - because it's such a simple check?

OTOH, you are right in general, for example in mmconf-fam10h_64.c's 
get_fam10h_pci_mmconf_base() function, we do this:

                id = read_pci_config(bus, slot, 0, PCI_VENDOR_ID);

                vendor = id & 0xffff;
                device = (id>>16) & 0xffff;
                if (pci_probes[i].vendor == vendor &&
                    pci_probes[i].device == device) {

here it would indeed be cleaner to simply do:

                vendor = read_pci_config_16(bus, slot, 0, PCI_VENDOR_ID);
                device = read_pci_config_16(bus, slot, 0, PCI_DEVICE_ID);

instead of open-coding the 16-bit splitting.

	Ingo

------------>
Subject: x86: vsmp fix x86 vsmp fix is vsmp box cleanup
From: Ingo Molnar <mingo@elte.hu>
Date: Fri Mar 21 09:55:06 CET 2008

code got a bit smaller:

arch/x86/kernel/vsmp_64.o:

   text	   data	    bss	    dec	    hex	filename
    205	      4	      0	    209	     d1	vsmp_64.o.before
    181	      4	      0	    185	     b9	vsmp_64.o.after

Signed-off-by: Ingo Molnar <mingo@elte.hu>
---
 arch/x86/kernel/vsmp_64.c |    6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

Index: linux-x86.q/arch/x86/kernel/vsmp_64.c
===================================================================
--- linux-x86.q.orig/arch/x86/kernel/vsmp_64.c
+++ linux-x86.q/arch/x86/kernel/vsmp_64.c
@@ -120,10 +120,8 @@ int is_vsmp_box(void)
 		return vsmp;
 
 	/* Check if we are running on a ScaleMP vSMP box */
-	if ((read_pci_config_16(0, 0x1f, 0, PCI_VENDOR_ID) ==
-	     PCI_VENDOR_ID_SCALEMP) &&
-	    (read_pci_config_16(0, 0x1f, 0, PCI_DEVICE_ID) ==
-	    PCI_DEVICE_ID_SCALEMP_VSMP_CTL))
+	if (read_pci_config(0, 0x1f, 0, PCI_VENDOR_ID) ==
+	     (PCI_VENDOR_ID_SCALEMP | (PCI_DEVICE_ID_SCALEMP_VSMP_CTL << 16)))
 		vsmp = 1;
 
 	return vsmp;

  reply	other threads:[~2008-03-21  9:12 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-03-20  7:37 [patch 0/4] x86: vSMP updates Ravikiran G Thirumalai
2008-03-20  7:39 ` [patch 1/4] x86: vSMP: Fix is_vsmp_box() Ravikiran G Thirumalai
2008-03-20  7:44   ` Yinghai Lu
2008-03-20 18:40     ` Ravikiran G Thirumalai
2008-03-21  9:11       ` Ingo Molnar [this message]
2008-03-21  9:17         ` Yinghai Lu
2008-03-21 17:59         ` Ravikiran G Thirumalai
2008-03-20  7:41 ` [patch 2/4] x86: Fix build breakage when PCI is define and PARAVIRT is not Ravikiran G Thirumalai
2008-03-21  4:30   ` Jeremy Fitzhardinge
2008-03-21  6:28     ` Yinghai Lu
2008-03-21 18:54     ` Ravikiran G Thirumalai
2008-03-22  2:19       ` Jeremy Fitzhardinge
2008-03-20  7:43 ` [patch 3/4] x86: vSMP: Use pvops only if platform has the capability to support it Ravikiran G Thirumalai
2008-03-20  7:45 ` [patch 4/4] x86: apic_is_clustered_box to indicate unsynched TSC's on multiboard vSMP systems Ravikiran G Thirumalai
2008-03-20  7:53   ` Yinghai Lu
2008-03-20 19:02     ` Ravikiran G Thirumalai
2008-03-21  9:15       ` Ingo Molnar
2008-03-21 18:52         ` Ravikiran G Thirumalai
2008-03-21 18:58           ` Ingo Molnar
2008-03-22 18:59             ` Ravikiran G Thirumalai
2008-03-22 20:02               ` Ingo Molnar
2008-03-24 21:48                 ` Ravikiran G Thirumalai
2008-03-25 15:50                   ` Ingo Molnar
2008-03-21  8:54 ` [patch 0/4] x86: vSMP updates Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080321091139.GD20420@elte.hu \
    --to=mingo@elte.hu \
    --cc=ak@suse.de \
    --cc=akpm@linux-foundation.org \
    --cc=gcosta@redhat.com \
    --cc=kiran@scalex86.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=shai@scalex86.org \
    --cc=yhlu.kernel@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®