From: Randy Dunlap <rdunlap@xenotime.net>
To: "Yinghai Lu" <yinghai@kernel.org>
Cc: "H. Peter Anvin" <hpa@zytor.com>,
"Randy Dunlap" <rdunlap@xenotime.net>,
"Ingo Molnar" <mingo@elte.hu>,
"Thomas Gleixner" <tglx@linutronix.de>,
"Andrew Morton" <akpm@linux-foundation.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/3] x86: mtrr_cleanup update command line
Date: Tue, 30 Sep 2008 17:41:17 -0700 [thread overview]
Message-ID: <20080930174117.2e2ef568.rdunlap@xenotime.net> (raw)
In-Reply-To: <86802c440809301659h4ff57a32r28e62b32386752e9@mail.gmail.com>
On Tue, 30 Sep 2008 16:59:49 -0700 Yinghai Lu wrote:
> On Tue, Sep 30, 2008 at 4:52 PM, Yinghai Lu <yinghai@kernel.org> wrote:
> > On Tue, Sep 30, 2008 at 4:41 PM, H. Peter Anvin <hpa@zytor.com> wrote:
> >> Randy Dunlap wrote:
> >>>
> >>> E.g., the "apic" entries are not grouped together and these mtrr entries
> >>> should
> >>> not be grouped together unless they all begin with "mtrr", which is an
> >>> option here:
> >>> they could be renamed to "mtrr-cleanup" and "mtrr-nocleanup".
> >>> And "disable_mtrr_trim" could be renamed to "mtrr-notrim".
> >>>
> >>
> >> That does collide with the (not always kept) convention of prefixing "no" to
> >> disable a boolean option, though.
> >>
> >
> > it seems should group them and then provide one index section...
> >
> or
> 1. put all description in .c files
> 2. have one scripts to search early_param and __setup and create that
> kernel_parameter...
Here's a script that can be used as a starting point if someone wants to:
http://www.xenotime.net/linux/scripts/module-params
---
~Randy
next prev parent reply other threads:[~2008-10-01 0:22 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-09-30 23:29 Yinghai Lu
2008-09-30 23:29 ` [PATCH 2/3] x86: doc mtrr-cleanup-debug Yinghai Lu
2008-09-30 23:29 ` [PATCH 3/3] x86: change MTRR_SANITIZER to def_bool y Yinghai Lu
2008-10-01 6:36 ` Ingo Molnar
2008-10-01 6:46 ` Yinghai Lu
2008-10-01 7:24 ` J.A. Magallón
2008-09-30 23:57 ` [PATCH 1/3] x86: mtrr_cleanup update command line Randy Dunlap
2008-09-30 23:41 ` H. Peter Anvin
2008-09-30 23:52 ` Yinghai Lu
2008-09-30 23:59 ` Yinghai Lu
2008-10-01 0:35 ` Randy Dunlap
2008-10-01 0:41 ` Randy Dunlap [this message]
2008-10-01 0:07 ` Randy Dunlap
2008-10-09 0:07 ` Randy Dunlap
2008-10-09 1:28 ` Yinghai Lu
2008-10-09 17:20 ` Randy Dunlap
2008-10-09 18:08 ` Yinghai Lu
2008-10-09 18:43 ` H. Peter Anvin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20080930174117.2e2ef568.rdunlap@xenotime.net \
--to=rdunlap@xenotime.net \
--cc=akpm@linux-foundation.org \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=tglx@linutronix.de \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®