* 2.6.28-rc4-mmotm1110 - you gotta be kidding me... @ 2008-11-11 2:55 Valdis.Kletnieks 2008-11-11 3:37 ` Andrew Morton 0 siblings, 1 reply; 4+ messages in thread From: Valdis.Kletnieks @ 2008-11-11 2:55 UTC (permalink / raw) To: Andrew Morton; +Cc: linux-kernel [-- Attachment #1: Type: text/plain, Size: 951 bytes --] Somebody's been hitting the phunky pharmaceuticals in the last 4 days, because this ball-of-joy snuck into linux-next.patch sometime between -mmotm1106 and --mmotm1110. Seen in a 'make silentallconfig' Single-depth WCHAN output (SCHED_NO_NO_OMIT_FRAME_POINTER) [Y/n/?] (NEW) ? Calculate simpler /proc/<PID>/wchan values. If this option is disabled then wchan values will recurse back to the caller function. This provides more accurate wchan values, at the expense of slightly more scheduling overhead. If in doubt, say "Y". So if I say 'y', is that a request to disable it, or enable it? And what exactly do I get if I vote *against* 'more accurate wchan values'? Do I get everybody having the same wchan pointing somewhere in the scheduler code, because that's where __builtin_return_address() points? And please - a triple negative in the Kconfig variable name? This has gotta be a winner for poor taste in variable naming... [-- Attachment #2: Type: application/pgp-signature, Size: 226 bytes --] ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: 2.6.28-rc4-mmotm1110 - you gotta be kidding me... 2008-11-11 2:55 2.6.28-rc4-mmotm1110 - you gotta be kidding me Valdis.Kletnieks @ 2008-11-11 3:37 ` Andrew Morton 2008-11-11 4:58 ` Stephen Rothwell 0 siblings, 1 reply; 4+ messages in thread From: Andrew Morton @ 2008-11-11 3:37 UTC (permalink / raw) To: Valdis.Kletnieks; +Cc: linux-kernel, Ken Chen, Ingo Molnar On Mon, 10 Nov 2008 21:55:37 -0500 Valdis.Kletnieks@vt.edu wrote: > Somebody's been hitting the phunky pharmaceuticals in the last 4 days, > because this ball-of-joy snuck into linux-next.patch sometime between > -mmotm1106 and --mmotm1110. > > Seen in a 'make silentallconfig' > > Single-depth WCHAN output (SCHED_NO_NO_OMIT_FRAME_POINTER) [Y/n/?] (NEW) ? > > Calculate simpler /proc/<PID>/wchan values. If this option > is disabled then wchan values will recurse back to the > caller function. This provides more accurate wchan values, > at the expense of slightly more scheduling overhead. I got lost here. > If in doubt, say "Y". > > So if I say 'y', is that a request to disable it, or enable it? And > what exactly do I get if I vote *against* 'more accurate wchan values'? > Do I get everybody having the same wchan pointing somewhere in the > scheduler code, because that's where __builtin_return_address() points? > > And please - a triple negative in the Kconfig variable name? This has > gotta be a winner for poor taste in variable naming... > Even if that is all sorted out, how the heck is anyone to decide whether or not they need this thing? Also, if we really really are so wishy-washy indecisive that we need to make the function optional, it should if at all possible be made runtime-configurable, not compile-time. ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: 2.6.28-rc4-mmotm1110 - you gotta be kidding me... 2008-11-11 3:37 ` Andrew Morton @ 2008-11-11 4:58 ` Stephen Rothwell 2008-11-11 8:01 ` Ingo Molnar 0 siblings, 1 reply; 4+ messages in thread From: Stephen Rothwell @ 2008-11-11 4:58 UTC (permalink / raw) To: Andrew Morton; +Cc: Valdis.Kletnieks, linux-kernel, Ken Chen, Ingo Molnar [-- Attachment #1: Type: text/plain, Size: 1971 bytes --] On Mon, 10 Nov 2008 19:37:13 -0800 Andrew Morton <akpm@linux-foundation.org> wrote: > > On Mon, 10 Nov 2008 21:55:37 -0500 Valdis.Kletnieks@vt.edu wrote: > > > Somebody's been hitting the phunky pharmaceuticals in the last 4 days, > > because this ball-of-joy snuck into linux-next.patch sometime between > > -mmotm1106 and --mmotm1110. > > > > Seen in a 'make silentallconfig' > > > > Single-depth WCHAN output (SCHED_NO_NO_OMIT_FRAME_POINTER) [Y/n/?] (NEW) ? > > > > Calculate simpler /proc/<PID>/wchan values. If this option > > is disabled then wchan values will recurse back to the > > caller function. This provides more accurate wchan values, > > at the expense of slightly more scheduling overhead. > > I got lost here. > > > If in doubt, say "Y". > > > > So if I say 'y', is that a request to disable it, or enable it? And > > what exactly do I get if I vote *against* 'more accurate wchan values'? > > Do I get everybody having the same wchan pointing somewhere in the > > scheduler code, because that's where __builtin_return_address() points? > > > > And please - a triple negative in the Kconfig variable name? This has > > gotta be a winner for poor taste in variable naming... > > > > Even if that is all sorted out, how the heck is anyone to decide > whether or not they need this thing? > > Also, if we really really are so wishy-washy indecisive that we need to > make the function optional, it should if at all possible be made > runtime-configurable, not compile-time. This came from commit a87d091434ed2a34d647979ab12084139ee1fe41 ("x86, sched: enable wchan config menu item on 64-bit"). We have had CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER for some time on various architectures, this commit just made it available on x86_64 (by changing its dependency from X86_32 to X86). -- Cheers, Stephen Rothwell sfr@canb.auug.org.au http://www.canb.auug.org.au/~sfr/ [-- Attachment #2: Type: application/pgp-signature, Size: 197 bytes --] ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: 2.6.28-rc4-mmotm1110 - you gotta be kidding me... 2008-11-11 4:58 ` Stephen Rothwell @ 2008-11-11 8:01 ` Ingo Molnar 0 siblings, 0 replies; 4+ messages in thread From: Ingo Molnar @ 2008-11-11 8:01 UTC (permalink / raw) To: Stephen Rothwell; +Cc: Andrew Morton, Valdis.Kletnieks, linux-kernel, Ken Chen * Stephen Rothwell <sfr@canb.auug.org.au> wrote: > This came from commit a87d091434ed2a34d647979ab12084139ee1fe41 > ("x86, sched: enable wchan config menu item on 64-bit"). We have > had CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER for some time on various > architectures, this commit just made it available on x86_64 (by > changing its dependency from X86_32 to X86). correct. The SCHED_NO_NO name comes from ancient history. Nevertheless i just renamed it to CONFIG_SCHED_OMIT_FRAME_POINTER in tip/sched/core, and pushed out a new auto-sched-next with that rename in place. We can get rid of it completely once Ken's /proc/<pid>/stack hits upstream. (as the superior replacement for wchan) Ingo -----------------> >From ae1e9130bfb9ad55eb97ec3fb17a122b7a118f98 Mon Sep 17 00:00:00 2001 From: Ingo Molnar <mingo@elte.hu> Date: Tue, 11 Nov 2008 09:05:16 +0100 Subject: [PATCH] sched: rename SCHED_NO_NO_OMIT_FRAME_POINTER => SCHED_OMIT_FRAME_POINTER Impact: cleanup, change .config option name We had this ugly config name for a long time for hysteric raisons. Rename it to a saner name. We still cannot get rid of it completely, until /proc/<pid>/stack usage replaces WCHAN usage for good. We'll be able to do that in the v2.6.29/v2.6.30 timeframe. Signed-off-by: Ingo Molnar <mingo@elte.hu> --- arch/ia64/Kconfig | 2 +- arch/m32r/Kconfig | 2 +- arch/mips/Kconfig | 2 +- arch/powerpc/Kconfig | 2 +- arch/x86/Kconfig | 2 +- include/asm-m32r/system.h | 2 +- kernel/Makefile | 2 +- 7 files changed, 7 insertions(+), 7 deletions(-) diff --git a/arch/ia64/Kconfig b/arch/ia64/Kconfig index 27eec71..59d1278 100644 --- a/arch/ia64/Kconfig +++ b/arch/ia64/Kconfig @@ -99,7 +99,7 @@ config GENERIC_IOMAP bool default y -config SCHED_NO_NO_OMIT_FRAME_POINTER +config SCHED_OMIT_FRAME_POINTER bool default y diff --git a/arch/m32r/Kconfig b/arch/m32r/Kconfig index dbaed4a..29047d5 100644 --- a/arch/m32r/Kconfig +++ b/arch/m32r/Kconfig @@ -273,7 +273,7 @@ config GENERIC_CALIBRATE_DELAY bool default y -config SCHED_NO_NO_OMIT_FRAME_POINTER +config SCHED_OMIT_FRAME_POINTER bool default y diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig index f4af967..a5255e7 100644 --- a/arch/mips/Kconfig +++ b/arch/mips/Kconfig @@ -653,7 +653,7 @@ config GENERIC_CMOS_UPDATE bool default y -config SCHED_NO_NO_OMIT_FRAME_POINTER +config SCHED_OMIT_FRAME_POINTER bool default y diff --git a/arch/powerpc/Kconfig b/arch/powerpc/Kconfig index 525c13a..adb23ea 100644 --- a/arch/powerpc/Kconfig +++ b/arch/powerpc/Kconfig @@ -141,7 +141,7 @@ config GENERIC_NVRAM bool default y if PPC32 -config SCHED_NO_NO_OMIT_FRAME_POINTER +config SCHED_OMIT_FRAME_POINTER bool default y diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig index 1d5550d..74db682 100644 --- a/arch/x86/Kconfig +++ b/arch/x86/Kconfig @@ -364,7 +364,7 @@ config X86_RDC321X as R-8610-(G). If you don't have one of these chips, you should say N here. -config SCHED_NO_NO_OMIT_FRAME_POINTER +config SCHED_OMIT_FRAME_POINTER def_bool y prompt "Single-depth WCHAN output" depends on X86 diff --git a/include/asm-m32r/system.h b/include/asm-m32r/system.h index 70a57c8..c980f5b 100644 --- a/include/asm-m32r/system.h +++ b/include/asm-m32r/system.h @@ -23,7 +23,7 @@ */ #if defined(CONFIG_FRAME_POINTER) || \ - !defined(CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER) + !defined(CONFIG_SCHED_OMIT_FRAME_POINTER) #define M32R_PUSH_FP " push fp\n" #define M32R_POP_FP " pop fp\n" #else diff --git a/kernel/Makefile b/kernel/Makefile index e1af039..46e67a3 100644 --- a/kernel/Makefile +++ b/kernel/Makefile @@ -91,7 +91,7 @@ obj-$(CONFIG_FUNCTION_TRACER) += trace/ obj-$(CONFIG_TRACING) += trace/ obj-$(CONFIG_SMP) += sched_cpupri.o -ifneq ($(CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER),y) +ifneq ($(CONFIG_SCHED_OMIT_FRAME_POINTER),y) # According to Alan Modra <alan@linuxcare.com.au>, the -fno-omit-frame-pointer is # needed for x86 only. Why this used to be enabled for all architectures is beyond # me. I suspect most platforms don't need this, but until we know that for sure ^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2008-11-11 8:01 UTC | newest] Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed) -- links below jump to the message on this page -- 2008-11-11 2:55 2.6.28-rc4-mmotm1110 - you gotta be kidding me Valdis.Kletnieks 2008-11-11 3:37 ` Andrew Morton 2008-11-11 4:58 ` Stephen Rothwell 2008-11-11 8:01 ` Ingo Molnar
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®