mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Peter T. Breuer" <ptb@inv.it.uc3m.es>
To: "Johannes Weiner" <hannes@cmpxchg.org>
Cc: "linux kernel" <linux-kernel@vger.kernel.org>
Subject: Re: time_is_after_jiffies misnomer
Date: Tue, 16 Dec 2008 16:17:30 +0100 (MET)	[thread overview]
Message-ID: <200812161517.mBGFHUE07109@inv.it.uc3m.es> (raw)
In-Reply-To: <20081216144608.GA19675@cmpxchg.org> from "Johannes Weiner" at  "Dec16, 2008 03:46:08 pm"

"Also sprach Johannes Weiner:"
> On Tue, Dec 16, 2008 at 12:31:41PM +0100, Peter T. Breuer wrote:
> > 
> > I thought at first that
> > 
> >     time_is_after_jiffies(foo)
> > 
> > meant that the current time is later than foo jiffies.
> 
> 'foo jiffies'?


?? What does that mean? Yes, "the current time is later than foo
jiffies", is what I wrote. I don't understand why you query it. What I
wrote is a perfectly normal english sentence. It means "if the current
time is X and and the 

> It behaves like all the other time_(after|before) macros.  "Compare a
> given time T against some other time X".

It's poor english. Yes, to an english speaker

   time_is_after_jiffies(foo)

looks like

   the current time is later than foo jiffies

Look at the two:

   the current time is later than foo jiffies
                 |   |  |           `/.
               time_is_after_jiffies(foo)

(I AM a native english speaker, and a very good one - please take this
on board and pay attention to it; you'll find me quoted as the author
of hundreds of technical articles on google :-).

The mathematical "jiffies(foo)" for colloquial "foo jiffies" is the
normal way of writing formal predicates.  Like "colour(red)" for
"red colour". This is a predicate.

> T is always the first argument to these macros, it's never the current
> time.  This is consistent.

That's surely not relevant since it's the macro name that we are talking
about, nothing else.

As to "these macros", I see and know of no macros other than the set I
am commenting on. If you mean some others, you'll have to point them
out to me, but it wouldn't invalidate the observation: the macro names
are phrased the wrong way round for a natural english interpretation.


> And jiffies, the X here, is a well-known global variable. :)


> The banner comment above the macro group should have clarified the
> misunderstanding, btw.

No, it says nothing:

  * These four macros compare jiffies and 'a' for convenience.

What's written above the individual macros is more explanatory, but
it's the NAMES of the macros that are the wrong way round for english:

  
  /* time_is_before_jiffies(a) return true if a is before jiffies */
  #define time_is_before_jiffies(a) time_after(jiffies, a)

It's time_is_before_jiffies(foo) that reads the wrong way round in
english. It should be


     current_time_is_after_jiffies(foo).

Best regards


Peter
  


  reply	other threads:[~2008-12-16 15:18 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-12-16 11:31 Peter T. Breuer
2008-12-16 14:46 ` Johannes Weiner
2008-12-16 15:17   ` Peter T. Breuer [this message]
2008-12-16 16:18     ` Andreas Schwab
2008-12-16 16:32       ` Peter T. Breuer
2008-12-16 19:29         ` Chris Friesen
2008-12-16 20:33     ` Johannes Weiner
2008-12-18  7:38 ` Pavel Machek
2008-12-16 16:04 Peter T. Breuer
2008-12-16 16:13 ` Pekka Enberg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200812161517.mBGFHUE07109@inv.it.uc3m.es \
    --to=ptb@inv.it.uc3m.es \
    --cc=hannes@cmpxchg.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®