From: "Peter T. Breuer" <ptb@inv.it.uc3m.es>
To: "Andreas Schwab" <schwab@suse.de>
Cc: "linux kernel" <linux-kernel@vger.kernel.org>
Subject: Re: time_is_after_jiffies misnomer
Date: Tue, 16 Dec 2008 17:32:43 +0100 (MET) [thread overview]
Message-ID: <200812161632.mBGGWh213629@inv.it.uc3m.es> (raw)
In-Reply-To: <jeabawccup.fsf@sykes.suse.de> from "Andreas Schwab" at "Dec 16,2008 05:18:54 pm"
"Also sprach Andreas Schwab:"
[Charset iso-8859-1 unsupported, filtering to ASCII...]
> "Peter T. Breuer" <ptb@inv.it.uc3m.es> writes:
>
> > Look at the two:
> >
> > the current time is later than foo jiffies
> > | | | `/.
> > time_is_after_jiffies(foo)
>
> It's not "foo jiffies", it's time "foo" vs time "jiffies" (where jiffies
> is the well known global variable).
Forgive me, but you don't seem to really be taking it on board here
either ... what it SAYS to an english reader is the opposite of what
you intend it to MEAN, unfortunately :(.
So the name is wrong. It's simple to fix. Just change the name. The
simplest naming fix is from
time_is_after_jiffies(foo)
to
time_is_before_jiffies(foo)
but obviously that would create more confusion yet, given the
unfortunate current scheme! So how about keeping the current macro
names but gradually phasing them out in favour of a parallel set of
alternatives, which could be
current_time_is_before_jiffies(foo)
?? That reads fine in english and this time it means what it says!
Best regards
Peter
next prev parent reply other threads:[~2008-12-16 16:33 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-12-16 11:31 Peter T. Breuer
2008-12-16 14:46 ` Johannes Weiner
2008-12-16 15:17 ` Peter T. Breuer
2008-12-16 16:18 ` Andreas Schwab
2008-12-16 16:32 ` Peter T. Breuer [this message]
2008-12-16 19:29 ` Chris Friesen
2008-12-16 20:33 ` Johannes Weiner
2008-12-18 7:38 ` Pavel Machek
2008-12-16 16:04 Peter T. Breuer
2008-12-16 16:13 ` Pekka Enberg
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200812161632.mBGGWh213629@inv.it.uc3m.es \
--to=ptb@inv.it.uc3m.es \
--cc=linux-kernel@vger.kernel.org \
--cc=schwab@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®