From: Cyrill Gorcunov <gorcunov@gmail.com>
To: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
Cc: Ingo Molnar <mingo@elte.hu>, Yinghai Lu <yinghai@kernel.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH for -tip] irq: for_each_irq_desc() makes simplify
Date: Thu, 25 Dec 2008 17:31:28 +0300 [thread overview]
Message-ID: <20081225143128.GA13388@localhost> (raw)
In-Reply-To: <2f11576a0812250545g1967467fy568099affdaa6c35@mail.gmail.com>
[KOSAKI Motohiro - Thu, Dec 25, 2008 at 10:45:20PM +0900]
| > [KOSAKI Motohiro - Thu, Dec 25, 2008 at 09:41:54PM +0900]
| > ...
| > | Is this good idea?
| > | this patch also tested on above three architecture.
| > |
| > |
| > | ===
| > | Subject: [PATCH] irq: for_each_irq_desc() makes simplify
| > | Impact: cleanup
| > |
| > | all for_each_irq_desc() usage point have !desc check.
| > | then its check can move into for_each_irq_desc() macro.
| > |
| > |
| > | Signed-off-by: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
| > | CC: Yinghai Lu <yinghai@kernel.org>
| > | CC: Ingo Molnar <mingo@elte.hu>
| > | ---
| > | arch/x86/kernel/io_apic.c | 10 ----------
| > | drivers/xen/events.c | 3 ---
| > | fs/proc/stat.c | 3 ---
| > | include/linux/irqnr.h | 6 ++++--
| > | kernel/irq/autoprobe.c | 15 ---------------
| > | kernel/irq/handle.c | 3 ---
| > | kernel/irq/spurious.c | 5 -----
| > | 7 files changed, 4 insertions(+), 41 deletions(-)
| > ...
| >
| > Hi Kosaki,
| >
| > the idea is that good indeed but I wonder if it possible
| > to explain that we skip empty 'desk' in for_each_... name
| > itself. Maybe for_each_irq_desc_defined :) Or something
| > more convenient word instead of "defined"?
|
| "if (!desc) " mean this irqno don't have irq description.
| so I think this name imply mean skipping no irq desctiption element.
|
| Actually, on CONFIG_SPARSEIRQ, desc is filled in dynamically after booting.
| then "defined" is a bit misleading word.
|
So if I would need to iterate over all descriptors including empty
I need to type all this long for(;;) form again? For me for_each_irq_desc
implies to iterate over each irq_desc allocated regardles of internal
descriptor data. For example in list_struct we have a special test if
entry is empty or not. So I think hiding details is not that good (and
that is why I was asking for more descriptive macro name). BUT if it
really supposed to behave like that then I don't object :)
- Cyrill -
next prev parent reply other threads:[~2008-12-25 14:37 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-12-25 10:46 [PATCH for -tip] proc: remove ifdef CONFIG_SPARSE_IRQ from stat.c KOSAKI Motohiro
2008-12-25 10:59 ` Ingo Molnar
2008-12-25 11:00 ` KOSAKI Motohiro
2008-12-25 12:40 ` KOSAKI Motohiro
2008-12-25 12:41 ` [PATCH for -tip] irq: for_each_irq_desc() makes simplify KOSAKI Motohiro
2008-12-25 13:10 ` Cyrill Gorcunov
2008-12-25 13:45 ` KOSAKI Motohiro
2008-12-25 14:31 ` Cyrill Gorcunov [this message]
2008-12-25 14:43 ` KOSAKI Motohiro
2008-12-25 16:01 ` Cyrill Gorcunov
2008-12-26 1:22 ` KOSAKI Motohiro
2008-12-26 9:37 ` Cyrill Gorcunov
2008-12-25 16:49 ` Ingo Molnar
2008-12-25 14:46 ` [PATCH for -tip] proc: remove ifdef CONFIG_SPARSE_IRQ from stat.c KOSAKI Motohiro
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20081225143128.GA13388@localhost \
--to=gorcunov@gmail.com \
--cc=kosaki.motohiro@jp.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome