mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Serge E. Hallyn" <serue@us.ibm.com>
To: Tetsuo Handa <penguin-kernel@i-love.sakura.ne.jp>
Cc: jmorris@namei.org, akpm@linux-foundation.org,
	paulmck@linux.vnet.ibm.com,
	linux-security-module@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [TOMOYO #14 (mmotm 2008-12-30-16-05) 02/10] Singly linked list implementation.
Date: Wed, 7 Jan 2009 13:09:12 -0600	[thread overview]
Message-ID: <20090107190912.GB20311@us.ibm.com> (raw)
In-Reply-To: <200901070636.n076aFY0061512@www262.sakura.ne.jp>

Quoting Tetsuo Handa (penguin-kernel@i-love.sakura.ne.jp):
> James Morris wrote:
> > > Not all structures listed below are used as singly linked list,
> > > but many of them are used as singly linked list.
> > 
> > Can any of these be converted to your singly linked list implementation ?
> 
> Maybe, but will be few.
> 
> Regular singly linked list (which is known as "slist") implementation has
> below characteristics.
> 
>  (1) Supports "add", "read" and "remove" operations.
>  (2) Caller holds read lock when reading, and holds write lock when adding or
>      removing.
>  (3) Iteration method (for_each_*) needn't to call rcu_dereference() because
>      caller holds locks as needed.
> 
> TOMOYO's singly linked list (which is named as "list1") implementation has
> below characteristics.
> 
>  (1) Supports "add" and "read" operations.
>  (2) Caller holds a lock when adding, but doesn't hold a lock when reading.
>  (3) Iteration method (for_each_*) needs to call rcu_dereference() because
>      caller doesn't hold a lock when reading.
> 
> I think it is not a good thing to rename "list1" to "slist".

How about alist (or aolist) for append-only list?

The problem with list1 is that it *really* doesn't imply the
characteristics you cite.

-serge

  reply	other threads:[~2009-01-07 19:09 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-01-01  5:07 [TOMOYO #14 (mmotm 2008-12-30-16-05) 00/10] TOMOYO Linux Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 01/10] Add in_execve flag into task_struct Tetsuo Handa
2009-01-05  8:25   ` James Morris
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 02/10] Singly linked list implementation Tetsuo Handa
2009-01-05  9:07   ` James Morris
2009-01-06  8:13     ` Tetsuo Handa
2009-01-06  9:11       ` James Morris
2009-01-07  6:36         ` Tetsuo Handa
2009-01-07 19:09           ` Serge E. Hallyn [this message]
2009-01-08  6:19             ` Tetsuo Handa
2009-01-14  8:57     ` Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 03/10] Introduce d_realpath() Tetsuo Handa
2009-01-05  9:08   ` James Morris
2009-01-14  8:58     ` Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 04/10] Memory and pathname management functions Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 05/10] Common functions for TOMOYO Linux Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 06/10] File operation restriction part Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 07/10] Domain transition handler Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 08/10] LSM adapter functions Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 09/10] Kconfig and Makefile Tetsuo Handa
2009-01-01  5:07 ` [TOMOYO #14 (mmotm 2008-12-30-16-05) 10/10] MAINTAINERS info Tetsuo Handa

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090107190912.GB20311@us.ibm.com \
    --to=serue@us.ibm.com \
    --cc=akpm@linux-foundation.org \
    --cc=jmorris@namei.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=paulmck@linux.vnet.ibm.com \
    --cc=penguin-kernel@i-love.sakura.ne.jp \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®