* [pull request] async function call updates
@ 2009-01-27 16:50 Arjan van de Ven
0 siblings, 0 replies; only message in thread
From: Arjan van de Ven @ 2009-01-27 16:50 UTC (permalink / raw)
To: torvalds; +Cc: cornelia.huck, linux-kernel
Hi Linus,
please pull the following 4 patches for the async code; they contain
two bugfixs (although the current kernel won't hit it in practice),
documentation and a rename of the "special" API to be more clear
The following changes since commit
5ee810072175042775e39bdd3eaaa68884c27805: Linus Torvalds (1):
Fix "multiple definition of `debugfs_create_size_t'"
are available in the git repository at:
ssh://master.kernel.org/pub/scm/linux/kernel/git/arjan/linux-2.6-async-update.git master
Cornelia Huck (4):
async: Fix running list handling.
async: Handle kthread_run() return codes.
async: Add some documentation.
async: Rename _special -> _domain for clarity.
fs/super.c | 4 +-
include/linux/async.h | 8 +++--
kernel/async.c | 81
+++++++++++++++++++++++++++++++++++++++++------- 3 files changed, 76
insertions(+), 17 deletions(-)
--
Arjan van de Ven Intel Open Source Technology Centre
For development, discussion and tips for power savings,
visit http://www.lesswatts.org
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2009-01-27 16:51 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-01-27 16:50 [pull request] async function call updates Arjan van de Ven
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®