From: Sam Ravnborg <sam@ravnborg.org>
To: Tim Abbott <tabbott@MIT.EDU>
Cc: "Linus Torvalds" <torvalds@linux-foundation.org>,
"Linux kernel mailing list" <linux-kernel@vger.kernel.org>,
"Anders Kaseorg" <andersk@MIT.EDU>,
"Waseem Daher" <wdaher@MIT.EDU>,
"Denys Vlasenko" <vda.linux@googlemail.com>,
"Rusty Russell" <rusty@rustcorp.com.au>,
"Andi Kleen" <andi@firstfloor.org>,
"H. Peter Anvin" <hpa@zytor.com>,
"Stephen Rothwell" <sfr@canb.auug.org.au>,
"Jeff Arnold" <jbarnold@MIT.EDU>,
"Andrew Morton" <akpm@linux-foundation.org>,
"Jon Masters" <jonathan@jonmasters.org>,
"Masami Hiramatsu" <mhiramat@redhat.com>,
"Theodore Ts'o" <tytso@MIT.EDU>,
"Nikanth Karthikesan" <knikanth@suse.de>,
"Arjan van de Ven" <arjan@infradead.org>,
"Paul Mundt" <lethal@linux-sh.org>,
"Américo Wang" <xiyou.wangcong@gmail.com>
Subject: Re: [PATCH v3 1/3] Make section names compatible with -ffunction-sections -fdata-sections
Date: Sun, 26 Apr 2009 11:09:06 +0200 [thread overview]
Message-ID: <20090426090906.GA27809@uranus.ravnborg.org> (raw)
In-Reply-To: <alpine.DEB.1.10.0904251304120.7631@vinegar-pot.mit.edu>
On Sat, Apr 25, 2009 at 10:10:38PM -0400, Tim Abbott wrote:
> On Fri, 24 Apr 2009, Sam Ravnborg wrote:
>
> > This patch touches far too many files.
> > We should try to work out a method so we are in better control
> > of the section names, so renaming in the end is a simple patch
> > touching only a few files.
>
> OK, I'm now planning to implement this approach.
>
> > > -.section .text.head, "ax"
> > > +.section .text..head, "ax"
> >
> > Use __HEAD (from include/linux/init.h)
> > Same goes for all other uses of .text.head.
>
> I notice that __HEAD uses .head.text, while some architectures use
> .text.head. It looks like this is just an inconsistency across
> architectures that will be removed as a consequence of this cleanup work
> (no architecture uses both .head.text and .text.head).
Correct - this is implied by the introduction of __HEAD.
For users of the old naming schme (like i386) you need to adjust the
linker script too.
> One challenge with this approach is that many linker scripts use these
> section names in more complex ways than just squashing HEAD_TEXT at the
> start of the text section. For example, the the linker scripts for x86
> and ia64 have code like:
>
> .text.head : AT(ADDR(.text.head) - LOAD_OFFSET) {
> _text = .; /* Text and read-only data */
> *(.text.head)
> } :text = 0x9090
>
> which can't user either the __HEAD macro (which is the full .section line)
> or the HEAD_TEXT macro (which is the *(.head.text)).
The simple way to deal wi8th this is to accept some duplication of naming
in order to keep readability.
So I suggest you to use:
.head.text : AT(ADDR(.head.text) - LOAD_OFFSET) {
_text = .; /* Text and read-only data */
HEAD_TEXT
} :text = 0x9090
We need to be carefull about keeping some sort of readability
of these linker macro files.
I was not specific in my last mail about this - but I assume you have
understood that the naming ".head.text" was selected so it is compatible
wiht -ffunction-sections. In other words no need for any ugly ".." here.
We should try to be as consistent as possible across architectures here
so it is better to toach a few additiona files rather than adding macros
and the like to accept there sub-optimal section naming.
Sam
next prev parent reply other threads:[~2009-04-26 9:07 UTC|newest]
Thread overview: 99+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-04-05 23:14 [PATCH v2 0/4] Add support for compiling " Tim Abbott
2009-04-05 23:14 ` [PATCH v2 1/4] Make section names compatible " Tim Abbott
2009-04-05 23:14 ` [PATCH v2 2/4] modpost: Check the section flags, not name, to catch missing "ax"/"aw" Tim Abbott
2009-04-05 23:14 ` [PATCH v2 3/4] modpost: Support objects with more than 64k sections Tim Abbott
2009-04-05 23:14 ` [PATCH v2 4/4] x86: Add an option to compile with -ffunction-sections -fdata-sections Tim Abbott
2009-04-08 0:34 ` [PATCH v2 0/4] Add support for compiling " Tim Abbott
2009-04-08 5:22 ` Rusty Russell
2009-04-20 20:26 ` Tim Abbott
2009-04-20 23:40 ` Linus Torvalds
2009-04-21 0:26 ` Tim Abbott
2009-04-21 0:35 ` Linus Torvalds
2009-04-21 1:25 ` H. Peter Anvin
2009-04-21 1:49 ` Denys Vlasenko
2009-04-21 3:18 ` Arjan van de Ven
2009-04-21 3:26 ` Anders Kaseorg
2009-04-21 10:26 ` Andi Kleen
2009-04-21 6:01 ` Tim Abbott
2009-04-21 10:24 ` Andi Kleen
2009-04-23 20:48 ` [PATCH v3 0/3] " Tim Abbott
2009-04-23 20:49 ` [PATCH v3 1/3] Make section names compatible " Tim Abbott
2009-04-23 20:49 ` [PATCH v3 2/3] modpost: Check the section flags, not name, to catch missing "ax"/"aw" Tim Abbott
2009-04-23 20:49 ` [PATCH v3 3/3] modpost: Support objects with more than 64k sections Tim Abbott
2009-04-24 0:16 ` [PATCH v3 1/3] Make section names compatible with -ffunction-sections -fdata-sections Paul Mundt
2009-04-24 17:23 ` Sam Ravnborg
2009-04-26 2:10 ` Tim Abbott
2009-04-26 2:10 ` [PATCH 01/15] Add new HEAD_TEXT_SECTION macro Tim Abbott
2009-04-26 2:10 ` [PATCH 02/15] xtensa: convert to use __HEAD and HEAD_TEXT macros Tim Abbott
2009-04-26 2:10 ` [PATCH 03/15] alpha: " Tim Abbott
2009-04-26 2:10 ` [PATCH 04/15] frv: convert frv " Tim Abbott
2009-04-26 2:11 ` [PATCH 05/15] arm: convert " Tim Abbott
2009-04-26 2:11 ` [PATCH 06/15] ia64: " Tim Abbott
2009-04-26 2:11 ` [PATCH 07/15] m32r: " Tim Abbott
2009-04-26 2:11 ` [PATCH 08/15] m68k: " Tim Abbott
2009-04-26 2:11 ` [PATCH 09/15] mn10300: " Tim Abbott
2009-04-26 2:11 ` [PATCH 10/15] powerpc: " Tim Abbott
2009-04-26 2:11 ` [PATCH 11/15] s390: " Tim Abbott
2009-04-26 2:11 ` [PATCH 12/15] sh: " Tim Abbott
2009-04-26 2:11 ` [PATCH 13/15] sparc: " Tim Abbott
2009-04-26 2:11 ` [PATCH 14/15] x86: " Tim Abbott
2009-04-26 2:11 ` [PATCH 15/15] modpost: convert modpost to use HEAD_TEXT_SECTION macro Tim Abbott
2009-04-26 11:30 ` Sam Ravnborg
2009-04-26 22:18 ` Anders Kaseorg
2009-04-26 11:28 ` [PATCH 14/15] x86: convert to use __HEAD and HEAD_TEXT macros Sam Ravnborg
2009-04-26 16:40 ` Linus Torvalds
2009-04-26 17:12 ` Linus Torvalds
2009-04-26 18:34 ` Sam Ravnborg
2009-04-26 18:56 ` Linus Torvalds
2009-04-26 19:23 ` Sam Ravnborg
2009-04-26 21:07 ` [PATCH] x86: beautify vmlinux_64.lds.S Sam Ravnborg
2009-04-27 4:54 ` [tip:x86/kbuild] " tip-bot for Sam Ravnborg
2009-04-27 4:59 ` [PATCH 14/15] x86: convert to use __HEAD and HEAD_TEXT macros Ingo Molnar
2009-04-27 6:42 ` Sam Ravnborg
2009-04-27 7:19 ` Ingo Molnar
2009-04-27 7:37 ` Sam Ravnborg
2009-04-26 20:50 ` Andi Kleen
2009-04-27 3:47 ` Ingo Molnar
2009-04-30 10:39 ` [tip:x86/kbuild] x86: boot/compressed/vmlinux.lds.S: fix build of bzImage with 64 bit compiler tip-bot for Sam Ravnborg
2009-04-30 14:52 ` H. Peter Anvin
2009-04-30 15:09 ` Sam Ravnborg
2009-04-30 16:29 ` H. Peter Anvin
2009-04-30 17:52 ` Sam Ravnborg
2009-04-30 19:02 ` H. Peter Anvin
2009-04-26 11:24 ` [PATCH 13/15] sparc: convert to use __HEAD and HEAD_TEXT macros Sam Ravnborg
2009-04-26 11:24 ` [PATCH 12/15] sh: " Sam Ravnborg
2009-04-26 11:23 ` [PATCH 11/15] s390: " Sam Ravnborg
2009-04-26 11:23 ` [PATCH 10/15] powerpc: " Sam Ravnborg
2009-04-26 11:22 ` [PATCH 09/15] mn10300: " Sam Ravnborg
2009-04-26 11:22 ` [PATCH 08/15] m68k: " Sam Ravnborg
2009-04-26 11:21 ` [PATCH 07/15] m32r: " Sam Ravnborg
2009-04-28 3:34 ` Hirokazu Takata
2009-04-26 11:21 ` [PATCH 06/15] ia64: " Sam Ravnborg
2009-04-26 11:19 ` [PATCH 05/15] arm: " Sam Ravnborg
2009-04-27 16:46 ` Tim Abbott
2009-04-27 17:00 ` Russell King
2009-04-27 17:06 ` Linus Torvalds
2009-04-27 17:29 ` Luck, Tony
2009-04-28 8:56 ` Ralf Baechle
2009-04-26 11:16 ` [PATCH 04/15] frv: convert frv " Sam Ravnborg
2009-04-26 11:15 ` [PATCH 03/15] alpha: convert " Sam Ravnborg
2009-04-26 11:13 ` [PATCH 02/15] xtensa: " Sam Ravnborg
2009-04-26 16:29 ` [PATCH 01/15] Add new HEAD_TEXT_SECTION macro Linus Torvalds
2009-04-26 2:42 ` [PATCH v3 1/3] Make section names compatible with -ffunction-sections -fdata-sections Paul Mundt
2009-04-26 9:15 ` Sam Ravnborg
2009-04-26 9:20 ` [PATCH] kbuild: fix comment in modpost.c Sam Ravnborg
2009-04-26 17:28 ` Tim Abbott
2009-04-26 9:09 ` Sam Ravnborg [this message]
2009-04-26 21:53 ` [PATCH v3 1/3] Make section names compatible with -ffunction-sections -fdata-sections Tim Abbott
2009-04-26 13:09 ` Rusty Russell
2009-04-24 0:14 ` [PATCH v3 0/3] Add support for compiling " Paul Mundt
2009-04-24 14:19 ` Masami Hiramatsu
2009-04-24 15:32 ` Tim Abbott
2009-04-25 1:49 ` Masami Hiramatsu
2009-04-21 1:05 ` [PATCH v2 0/4] " Denys Vlasenko
2009-04-21 5:50 ` Rusty Russell
2009-04-22 12:47 ` Paul Mundt
2009-04-21 14:02 ` Américo Wang
2009-04-21 17:40 ` Anders Kaseorg
2009-04-22 11:38 ` Masami Hiramatsu
2009-04-22 17:13 ` Tim Abbott
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090426090906.GA27809@uranus.ravnborg.org \
--to=sam@ravnborg.org \
--cc=akpm@linux-foundation.org \
--cc=andersk@MIT.EDU \
--cc=andi@firstfloor.org \
--cc=arjan@infradead.org \
--cc=hpa@zytor.com \
--cc=jbarnold@MIT.EDU \
--cc=jonathan@jonmasters.org \
--cc=knikanth@suse.de \
--cc=lethal@linux-sh.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mhiramat@redhat.com \
--cc=rusty@rustcorp.com.au \
--cc=sfr@canb.auug.org.au \
--cc=tabbott@MIT.EDU \
--cc=torvalds@linux-foundation.org \
--cc=tytso@MIT.EDU \
--cc=vda.linux@googlemail.com \
--cc=wdaher@MIT.EDU \
--cc=xiyou.wangcong@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®