mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Roland McGrath <roland@redhat.com>
To: Oleg Nesterov <oleg@redhat.com>
Cc: linux-kernel@vger.kernel.org
Subject: Re: [FOR REVIEW, PATCH 2/2] introduce "struct wait_opts" to simplify do_wait() pathes
Date: Wed,  6 May 2009 13:09:49 -0700 (PDT)	[thread overview]
Message-ID: <20090506200949.4FF6CFC39E@magilla.sf.frob.com> (raw)
In-Reply-To: Oleg Nesterov's message of  Wednesday, 6 May 2009 07:33:24 +0200 <20090506053324.GA31988@redhat.com>

I like the idea just fine.  Drop the "w" on every field name.
If you want them to have a greppable uniqueness/prefix, use "wo_".
I'd go with a shorter name for the canonical pointer parameter,
like "w" or "wo".

It looks cleaner to me to keep the several args to do_wait() and have
it use a single initializer with = { .foo = a, .bar = b } syntax there.


Thanks,
Roland

  parent reply	other threads:[~2009-05-06 20:10 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-05-06  5:33 Oleg Nesterov
2009-05-06  7:27 ` Ingo Molnar
2009-05-07  6:41   ` Oleg Nesterov
2009-05-07  7:54     ` Ingo Molnar
2009-05-09 16:15       ` Oleg Nesterov
2009-05-11 10:53         ` Andy Whitcroft
2009-05-11 12:43           ` Ingo Molnar
2009-05-06 20:09 ` Roland McGrath [this message]
2009-05-07  6:45   ` Oleg Nesterov
2009-05-07  7:20     ` Roland McGrath
2009-05-07  7:40       ` Oleg Nesterov
2009-05-07  7:49         ` Roland McGrath

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090506200949.4FF6CFC39E@magilla.sf.frob.com \
    --to=roland@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=oleg@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®